Add patch to build pam_smbpass correctly.
This missed the 3.0.25a deadline but it is important enough to put it in.
This commit is contained in:
parent
b4961fa6d4
commit
6210744402
@ -1 +1,2 @@
|
||||
samba-3.0.25.tar.gz
|
||||
samba-3.0.25a.tar.gz
|
||||
|
83
samba-3.0.25a-pam_smbpass.patch
Normal file
83
samba-3.0.25a-pam_smbpass.patch
Normal file
@ -0,0 +1,83 @@
|
||||
Author: gd
|
||||
Revision: r23121
|
||||
Modified: source/Makefile.in source/pam_smbpass/general.h source/pam_smbpass/pam_smb_acct.c source/pam_smbpass/pam_smb_auth.c source/pam_smbpass/pam_smb_passwd.c /branches/SAMBA_3_0_25/source/Makefile.in /branches/SAMBA_3_0_25/source/pam_smbpass/general.h /branches/SAMBA_3_0_26/source/Makefile.in /branches/SAMBA_3_0_26/source/pam_smbpass/general.h
|
||||
Added:
|
||||
Removed:
|
||||
|
||||
|
||||
Fix Bug #2727 and let pam_smbpass at least link and dlopen correctly again.
|
||||
|
||||
Thanks to Bartlomiej Solarz-Niesluchowski <Bartlomiej.Solarz-Niesluchowski@wit.edu.pl>.
|
||||
|
||||
Guenther
|
||||
|
||||
|
||||
Index: source/Makefile.in
|
||||
===================================================================
|
||||
--- source/Makefile.in (revision 23120)
|
||||
+++ source/Makefile.in (revision 23121)
|
||||
@@ -751,9 +751,9 @@
|
||||
|
||||
PAM_SMBPASS_OBJ_0 = pam_smbpass/pam_smb_auth.o pam_smbpass/pam_smb_passwd.o \
|
||||
pam_smbpass/pam_smb_acct.o pam_smbpass/support.o \
|
||||
- $(PARAM_OBJ) $(LIB_NONSMBD_OBJ) $(PASSDB_OBJ) $(GROUPDB_OBJ) \
|
||||
+PAM_SMBPASS_OBJ = $(PAM_SMBPASS_OBJ_0) $(PARAM_OBJ) $(LIB_NONSMBD_OBJ) $(PASSDB_OBJ) $(GROUPDB_OBJ) \
|
||||
$(SECRETS_OBJ) $(SMBLDAP_OBJ) $(LIBSAMBA_OBJ) \
|
||||
- $(RPC_PARSE_OBJ1) $(DOSERR_OBJ)
|
||||
+ $(RPC_PARSE_OBJ1) $(DOSERR_OBJ) $(ERRORMAP_OBJ)
|
||||
|
||||
IDMAP_OBJ = nsswitch/idmap.o nsswitch/idmap_cache.o nsswitch/idmap_util.o @IDMAP_STATIC@
|
||||
|
||||
Index: source/pam_smbpass/pam_smb_auth.c
|
||||
===================================================================
|
||||
--- source/pam_smbpass/pam_smb_auth.c (revision 23120)
|
||||
+++ source/pam_smbpass/pam_smb_auth.c (revision 23121)
|
||||
@@ -109,7 +109,7 @@
|
||||
_log_err( LOG_DEBUG, "username [%s] obtained", name );
|
||||
}
|
||||
|
||||
- if (!initialize_password_db(True)) {
|
||||
+ if (!initialize_password_db(True, NULL)) {
|
||||
_log_err( LOG_ALERT, "Cannot access samba password database" );
|
||||
retval = PAM_AUTHINFO_UNAVAIL;
|
||||
AUTH_RETURN;
|
||||
Index: source/pam_smbpass/pam_smb_passwd.c
|
||||
===================================================================
|
||||
--- source/pam_smbpass/pam_smb_passwd.c (revision 23120)
|
||||
+++ source/pam_smbpass/pam_smb_passwd.c (revision 23121)
|
||||
@@ -137,7 +137,7 @@
|
||||
from a SIGPIPE it's not expecting */
|
||||
oldsig_handler = CatchSignal(SIGPIPE, SIGNAL_CAST SIG_IGN);
|
||||
|
||||
- if (!initialize_password_db(False)) {
|
||||
+ if (!initialize_password_db(False, NULL)) {
|
||||
_log_err( LOG_ALERT, "Cannot access samba password database" );
|
||||
CatchSignal(SIGPIPE, SIGNAL_CAST oldsig_handler);
|
||||
return PAM_AUTHINFO_UNAVAIL;
|
||||
Index: source/pam_smbpass/general.h
|
||||
===================================================================
|
||||
--- source/pam_smbpass/general.h (revision 23120)
|
||||
+++ source/pam_smbpass/general.h (revision 23121)
|
||||
@@ -121,7 +121,7 @@
|
||||
|
||||
struct _pam_failed_auth {
|
||||
char *user; /* user that's failed to be authenticated */
|
||||
- int id; /* uid of requested user */
|
||||
+ uid_t id; /* uid of requested user */
|
||||
char *agent; /* attempt from user with name */
|
||||
int count; /* number of failures so far */
|
||||
};
|
||||
Index: source/pam_smbpass/pam_smb_acct.c
|
||||
===================================================================
|
||||
--- source/pam_smbpass/pam_smb_acct.c (revision 23120)
|
||||
+++ source/pam_smbpass/pam_smb_acct.c (revision 23121)
|
||||
@@ -81,7 +81,7 @@
|
||||
/* Getting into places that might use LDAP -- protect the app
|
||||
from a SIGPIPE it's not expecting */
|
||||
oldsig_handler = CatchSignal(SIGPIPE, SIGNAL_CAST SIG_IGN);
|
||||
- if (!initialize_password_db(True)) {
|
||||
+ if (!initialize_password_db(True, NULL)) {
|
||||
_log_err( LOG_ALERT, "Cannot access samba password database" );
|
||||
CatchSignal(SIGPIPE, SIGNAL_CAST oldsig_handler);
|
||||
return PAM_AUTHINFO_UNAVAIL;
|
||||
|
12
samba.spec
12
samba.spec
@ -1,8 +1,8 @@
|
||||
Summary: The Samba Suite of programs
|
||||
Name: samba
|
||||
Epoch: 0
|
||||
Version: 3.0.25
|
||||
Release: 2%{?dist}
|
||||
Version: 3.0.25a
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.samba.org/
|
||||
@ -46,6 +46,7 @@ Patch111: samba-3.0.13-smbclient.patch
|
||||
#Patch112: samba-3.0.15pre2-bug106483.patch
|
||||
#Patch113: samba-3.0.21-warnings.patch
|
||||
Patch200: samba-3.0.25rc1-inotifiy.patch
|
||||
Patch201: samba-3.0.25a-pam_smbpass.patch
|
||||
|
||||
|
||||
Requires(pre): samba-common = %{epoch}:%{version}-%{release}
|
||||
@ -168,6 +169,7 @@ cp %{SOURCE11} packaging/Fedora/
|
||||
#%patch112 -p1 -b .bug106483
|
||||
#%patch113 -p1 -b .warnings
|
||||
%patch200 -p0 -b .inotify
|
||||
%patch201 -p0 -b .pam_smbpass
|
||||
|
||||
# crap
|
||||
rm -f examples/VFS/.cvsignore
|
||||
@ -629,11 +631,15 @@ exit 0
|
||||
#%{_includedir}/libmsrpc.h
|
||||
|
||||
%changelog
|
||||
* Fri May 25 2007 Simo Sorce <ssorce@redhat.com>
|
||||
- update to 3.0.25a as it contains many fixes
|
||||
- add a fix for pam_smbpass made by Günther but committed upstream after 3.0.25a was cut.
|
||||
|
||||
* Mon May 14 2007 Simo Sorce <ssorce@redhat.com>
|
||||
- final 3.0.25
|
||||
- includes security fixes for CVE-2007-2444,CVE-2007-2446,CVE-2007-2447
|
||||
|
||||
* Mon Apr 30 2007 Guenther Deschner <gdeschner@redhat.com>
|
||||
* Mon Apr 30 2007 Günther Deschner <gdeschner@redhat.com>
|
||||
- move to 3.0.25rc3
|
||||
|
||||
* Thu Apr 19 2007 Simo Sorce <ssorce@redhat.com>
|
||||
|
Loading…
Reference in New Issue
Block a user