Update to Samba 4.1.2.
This commit is contained in:
parent
0682cb8494
commit
5d0c90dc65
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.1.0rc4.tar.xz
|
/samba-4.1.0rc4.tar.xz
|
||||||
/samba-4.1.0.tar.xz
|
/samba-4.1.0.tar.xz
|
||||||
/samba-4.1.1.tar.xz
|
/samba-4.1.1.tar.xz
|
||||||
|
/samba-4.1.2.tar.xz
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
commit 45a1cbb7514f9db5fe2d7c2207d7723092aa164d
|
|
||||||
Author: Volker Lendecke <vl@samba.org>
|
|
||||||
AuthorDate: Thu Jul 11 14:57:53 2013 +0200
|
|
||||||
Commit: Karolin Seeger <kseeger@samba.org>
|
|
||||||
CommitDate: Mon Oct 14 10:11:48 2013 +0200
|
|
||||||
|
|
||||||
ccan: Fix calling memset with zero length parameter
|
|
||||||
|
|
||||||
Signed-off-by: Volker Lendecke <vl@samba.org>
|
|
||||||
Reviewed-by: Andreas Schneider <asn@samba.org>
|
|
||||||
|
|
||||||
Autobuild-User(master): Andreas Schneider <asn@cryptomilk.org>
|
|
||||||
Autobuild-Date(master): Thu Jul 11 16:55:49 CEST 2013 on sn-devel-104
|
|
||||||
|
|
||||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
||||||
|
|
||||||
Fix bug #10190 - Fix memset used with constant zero length parameter.
|
|
||||||
---
|
|
||||||
lib/ccan/tally/tally.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/ccan/tally/tally.c b/lib/ccan/tally/tally.c
|
|
||||||
index 774373c..29f0555 100644
|
|
||||||
--- a/lib/ccan/tally/tally.c
|
|
||||||
+++ b/lib/ccan/tally/tally.c
|
|
||||||
@@ -506,11 +506,11 @@ char *tally_histogram(const struct tally *tally,
|
|
||||||
|
|
||||||
if (count > covered) {
|
|
||||||
count -= covered;
|
|
||||||
+ memset(p, '*', count);
|
|
||||||
} else {
|
|
||||||
count = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
- memset(p, '*', count);
|
|
||||||
p += count;
|
|
||||||
*p = '\n';
|
|
||||||
p++;
|
|
@ -1,109 +0,0 @@
|
|||||||
From d31a18bcaaa3f3dd5f0bf8db705089c42c7ab0b3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andreas Schneider <asn@samba.org>
|
|
||||||
Date: Thu, 14 Nov 2013 18:36:41 +0100
|
|
||||||
Subject: [PATCH] util: Remove 32bit macros breaking strict aliasing.
|
|
||||||
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=10269
|
|
||||||
|
|
||||||
These macros might have worked but they break strict aliasing in the
|
|
||||||
meantime and so the compiler is not able to optimize the relevant code.
|
|
||||||
|
|
||||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
||||||
Reviewed-by: Volker Lendecke <vl@samba.org>
|
|
||||||
|
|
||||||
Autobuild-User(master): Volker Lendecke <vl@samba.org>
|
|
||||||
Autobuild-Date(master): Thu Nov 14 23:16:45 CET 2013 on sn-devel-104
|
|
||||||
|
|
||||||
(cherry picked from commit af69cb2a78810e608ccff115b433801a58a749e4)
|
|
||||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
||||||
---
|
|
||||||
lib/util/byteorder.h | 52 ++--------------------------------------------------
|
|
||||||
1 file changed, 2 insertions(+), 50 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/util/byteorder.h b/lib/util/byteorder.h
|
|
||||||
index 6bcf71e..58cd68a 100644
|
|
||||||
--- a/lib/util/byteorder.h
|
|
||||||
+++ b/lib/util/byteorder.h
|
|
||||||
@@ -35,15 +35,6 @@ Here is a description of this file that I emailed to the samba list once:
|
|
||||||
|
|
||||||
sure.
|
|
||||||
|
|
||||||
-The distinction between 386 and other architectures is only there as
|
|
||||||
-an optimisation. You can take it out completely and it will make no
|
|
||||||
-difference. The routines (macros) in byteorder.h are totally byteorder
|
|
||||||
-independent. The 386 optimsation just takes advantage of the fact that
|
|
||||||
-the x86 processors don't care about alignment, so we don't have to
|
|
||||||
-align ints on int boundaries etc. If there are other processors out
|
|
||||||
-there that aren't alignment sensitive then you could also define
|
|
||||||
-CAREFUL_ALIGNMENT=0 on those processors as well.
|
|
||||||
-
|
|
||||||
Ok, now to the macros themselves. I'll take a simple example, say we
|
|
||||||
want to extract a 2 byte integer from a SMB packet and put it into a
|
|
||||||
type called uint16_t that is in the local machines byte order, and you
|
|
||||||
@@ -130,20 +121,6 @@ static __inline__ void st_le32(uint32_t *addr, const uint32_t val)
|
|
||||||
#define HAVE_ASM_BYTEORDER 0
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-#undef CAREFUL_ALIGNMENT
|
|
||||||
-
|
|
||||||
-/* we know that the 386 can handle misalignment and has the "right"
|
|
||||||
- byteorder */
|
|
||||||
-#if defined(__i386__)
|
|
||||||
-#define CAREFUL_ALIGNMENT 0
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
-#ifndef CAREFUL_ALIGNMENT
|
|
||||||
-#define CAREFUL_ALIGNMENT 1
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#define CVAL(buf,pos) ((unsigned int)(((const uint8_t *)(buf))[pos]))
|
|
||||||
#define CVAL_NC(buf,pos) (((uint8_t *)(buf))[pos]) /* Non-const version of CVAL */
|
|
||||||
#define PVAL(buf,pos) (CVAL(buf,pos))
|
|
||||||
@@ -161,7 +138,7 @@ static __inline__ void st_le32(uint32_t *addr, const uint32_t val)
|
|
||||||
#define SSVALS(buf,pos,val) SSVAL((buf),(pos),((int16_t)(val)))
|
|
||||||
#define SIVALS(buf,pos,val) SIVAL((buf),(pos),((int32_t)(val)))
|
|
||||||
|
|
||||||
-#elif CAREFUL_ALIGNMENT
|
|
||||||
+#else /* not HAVE_ASM_BYTEORDER */
|
|
||||||
|
|
||||||
#define SVAL(buf,pos) (PVAL(buf,pos)|PVAL(buf,(pos)+1)<<8)
|
|
||||||
#define IVAL(buf,pos) (SVAL(buf,pos)|SVAL(buf,(pos)+2)<<16)
|
|
||||||
@@ -174,32 +151,7 @@ static __inline__ void st_le32(uint32_t *addr, const uint32_t val)
|
|
||||||
#define SSVALS(buf,pos,val) SSVALX((buf),(pos),((int16_t)(val)))
|
|
||||||
#define SIVALS(buf,pos,val) SIVALX((buf),(pos),((int32_t)(val)))
|
|
||||||
|
|
||||||
-#else /* not CAREFUL_ALIGNMENT */
|
|
||||||
-
|
|
||||||
-/* this handles things for architectures like the 386 that can handle
|
|
||||||
- alignment errors */
|
|
||||||
-/*
|
|
||||||
- WARNING: This section is dependent on the length of int16_t and int32_t
|
|
||||||
- being correct
|
|
||||||
-*/
|
|
||||||
-
|
|
||||||
-/* get single value from an SMB buffer */
|
|
||||||
-#define SVAL(buf,pos) (*(const uint16_t *)((const char *)(buf) + (pos)))
|
|
||||||
-#define SVAL_NC(buf,pos) (*(uint16_t *)((void *)((char *)(buf) + (pos)))) /* Non const version of above. */
|
|
||||||
-#define IVAL(buf,pos) (*(const uint32_t *)((const char *)(buf) + (pos)))
|
|
||||||
-#define IVAL_NC(buf,pos) (*(uint32_t *)((void *)((char *)(buf) + (pos)))) /* Non const version of above. */
|
|
||||||
-#define SVALS(buf,pos) (*(const int16_t *)((const char *)(buf) + (pos)))
|
|
||||||
-#define SVALS_NC(buf,pos) (*(int16_t *)((void *)((char *)(buf) + (pos)))) /* Non const version of above. */
|
|
||||||
-#define IVALS(buf,pos) (*(const int32_t *)((const char *)(buf) + (pos)))
|
|
||||||
-#define IVALS_NC(buf,pos) (*(int32_t *)((void *)((char *)(buf) + (pos)))) /* Non const version of above. */
|
|
||||||
-
|
|
||||||
-/* store single value in an SMB buffer */
|
|
||||||
-#define SSVAL(buf,pos,val) SVAL_NC(buf,pos)=((uint16_t)(val))
|
|
||||||
-#define SIVAL(buf,pos,val) IVAL_NC(buf,pos)=((uint32_t)(val))
|
|
||||||
-#define SSVALS(buf,pos,val) SVALS_NC(buf,pos)=((int16_t)(val))
|
|
||||||
-#define SIVALS(buf,pos,val) IVALS_NC(buf,pos)=((int32_t)(val))
|
|
||||||
-
|
|
||||||
-#endif /* not CAREFUL_ALIGNMENT */
|
|
||||||
+#endif /* not HAVE_ASM_BYTEORDER */
|
|
||||||
|
|
||||||
/* 64 bit macros */
|
|
||||||
#define BVAL(p, ofs) (IVAL(p,ofs) | (((uint64_t)IVAL(p,(ofs)+4)) << 32))
|
|
||||||
--
|
|
||||||
1.8.4
|
|
||||||
|
|
20
samba.spec
20
samba.spec
@ -1,9 +1,9 @@
|
|||||||
# Set --with testsuite or %bcond_without to run the Samba torture testsuite.
|
# Set --with testsuite or %bcond_without to run the Samba torture testsuite.
|
||||||
%bcond_with testsuite
|
%bcond_with testsuite
|
||||||
|
|
||||||
%define main_release 3
|
%define main_release 1
|
||||||
|
|
||||||
%define samba_version 4.1.1
|
%define samba_version 4.1.2
|
||||||
%define talloc_version 2.0.8
|
%define talloc_version 2.0.8
|
||||||
%define ntdb_version 0.9
|
%define ntdb_version 0.9
|
||||||
%define tdb_version 1.2.12
|
%define tdb_version 1.2.12
|
||||||
@ -85,10 +85,8 @@ Source6: samba.pamd
|
|||||||
Source200: README.dc
|
Source200: README.dc
|
||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch0: samba-4.1.1-Fix-memset-in-ntdb.patch
|
Patch0: samba-4.1.0-upn.patch
|
||||||
Patch1: samba-4.1.0-upn.patch
|
Patch1: samba-4.1.2-doc.patch
|
||||||
Patch2: samba-4.1.2-fix_strict_aliasing.patch
|
|
||||||
Patch3: samba-4.1.2-doc.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
@ -491,10 +489,8 @@ module necessary to communicate to the Winbind Daemon
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n samba-%{version}%{pre_release}
|
%setup -q -n samba-%{version}%{pre_release}
|
||||||
|
|
||||||
%patch0 -p1 -b .samba-4.1.1-Fix-memset-in-ntdb.patch
|
%patch0 -p1 -b .samba-4.1.0-upn.patch
|
||||||
%patch1 -p1 -b .samba-4.1.0-upn.patch
|
%patch1 -p1 -b .samba-4.1.2-doc.patch
|
||||||
%patch2 -p1 -b .samba-4.1.2-fix_strict_aliasing.patch
|
|
||||||
%patch3 -p1 -b .samba-4.1.2-doc.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||||
@ -553,6 +549,7 @@ LDFLAGS="-Wl,-z,relro,-z,now" \
|
|||||||
--with-shared-modules=%{_samba4_modules} \
|
--with-shared-modules=%{_samba4_modules} \
|
||||||
--bundled-libraries=%{_samba4_libraries} \
|
--bundled-libraries=%{_samba4_libraries} \
|
||||||
--with-pam \
|
--with-pam \
|
||||||
|
--without-fam \
|
||||||
%if (! %with_libsmbclient) || (! %with_libwbclient)
|
%if (! %with_libsmbclient) || (! %with_libwbclient)
|
||||||
--private-libraries=%{_samba4_private_libraries} \
|
--private-libraries=%{_samba4_private_libraries} \
|
||||||
%endif
|
%endif
|
||||||
@ -1546,6 +1543,9 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man8/pam_winbind.8*
|
%{_mandir}/man8/pam_winbind.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 25 2013 - Andreas Schneider <asn@redhat.com>
|
||||||
|
- Update to Samba 4.1.2.
|
||||||
|
|
||||||
* Mon Nov 18 2013 - Guenther Deschner <gdeschner@redhat.com> - 4.1.1-3
|
* Mon Nov 18 2013 - Guenther Deschner <gdeschner@redhat.com> - 4.1.1-3
|
||||||
- resolves: #948509 - Fix manpage correctness.
|
- resolves: #948509 - Fix manpage correctness.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user