Fix crash bug in debug system.
This commit is contained in:
parent
51df79e1e6
commit
535a856986
29
samba-3.6.1-debug.patch
Normal file
29
samba-3.6.1-debug.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
commit 5db0cd55d4db9cc71f32dc0097e2f014c22967bc
|
||||||
|
Author: Andrew Bartlett <abartlet@samba.org>
|
||||||
|
AuthorDate: Mon May 9 17:43:45 2011 +0200
|
||||||
|
Commit: Andrew Bartlett <abartlet@samba.org>
|
||||||
|
CommitDate: Fri May 13 18:50:23 2011 +0200
|
||||||
|
|
||||||
|
lib/util/ Fix crash bug caused by gfree_debug()
|
||||||
|
|
||||||
|
The issue is that we should reset the debug_num_classes to 0 when we
|
||||||
|
un-initialise the debug system.
|
||||||
|
|
||||||
|
Andrew Bartlett
|
||||||
|
---
|
||||||
|
lib/util/debug.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/util/debug.c b/lib/util/debug.c
|
||||||
|
index b0a7882..c1b33de 100644
|
||||||
|
--- a/lib/util/debug.c
|
||||||
|
+++ b/lib/util/debug.c
|
||||||
|
@@ -203,7 +203,7 @@ void gfree_debugsyms(void)
|
||||||
|
|
||||||
|
TALLOC_FREE(format_bufr);
|
||||||
|
|
||||||
|
- debug_num_classes = DBGC_MAX_FIXED;
|
||||||
|
+ debug_num_classes = 0;
|
||||||
|
|
||||||
|
state.initialized = false;
|
||||||
|
}
|
10
samba.spec
10
samba.spec
@ -1,4 +1,4 @@
|
|||||||
%define main_release 75
|
%define main_release 76
|
||||||
%define samba_version 3.6.1
|
%define samba_version 3.6.1
|
||||||
%define tdb_version 1.2.9
|
%define tdb_version 1.2.9
|
||||||
%define talloc_version 2.0.5
|
%define talloc_version 2.0.5
|
||||||
@ -45,6 +45,7 @@ Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
|||||||
# The passwd part has been applied, but not the group part
|
# The passwd part has been applied, but not the group part
|
||||||
Patch107: samba-3.2.0pre1-grouppwd.patch
|
Patch107: samba-3.2.0pre1-grouppwd.patch
|
||||||
Patch200: samba-3.2.5-inotify.patch
|
Patch200: samba-3.2.5-inotify.patch
|
||||||
|
Patch300: samba-3.6.1-debug.patch
|
||||||
|
|
||||||
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
||||||
Requires: pam >= 0:0.64
|
Requires: pam >= 0:0.64
|
||||||
@ -210,6 +211,7 @@ cp %{SOURCE11} packaging/Fedora/
|
|||||||
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
||||||
%patch107 -p1 -b .grouppwd
|
%patch107 -p1 -b .grouppwd
|
||||||
%patch200 -p0 -b .inotify
|
%patch200 -p0 -b .inotify
|
||||||
|
%patch300 -p1 -b .debug
|
||||||
|
|
||||||
mv %samba_source/VERSION %samba_source/VERSION.orig
|
mv %samba_source/VERSION %samba_source/VERSION.orig
|
||||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
|
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
|
||||||
@ -252,7 +254,7 @@ CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %configure \
|
|||||||
--with-winbind \
|
--with-winbind \
|
||||||
--without-smbwrapper \
|
--without-smbwrapper \
|
||||||
--with-lockdir=/var/lib/samba \
|
--with-lockdir=/var/lib/samba \
|
||||||
--with-piddir=/var/run \
|
--with-piddir=/run \
|
||||||
--with-mandir=%{_mandir} \
|
--with-mandir=%{_mandir} \
|
||||||
--with-privatedir=/var/lib/samba/private \
|
--with-privatedir=/var/lib/samba/private \
|
||||||
--with-logfilebase=/var/log/samba \
|
--with-logfilebase=/var/log/samba \
|
||||||
@ -667,6 +669,10 @@ fi
|
|||||||
%{_datadir}/pixmaps/samba/logo-small.png
|
%{_datadir}/pixmaps/samba/logo-small.png
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 18 2011 Andreas Schneider <asn@redhat.com> - 1:3.6.1-76
|
||||||
|
- Fix piddir to match with systemd files.
|
||||||
|
- Fix crash bug in the debug system.
|
||||||
|
- resolves: #754525
|
||||||
* Fri Nov 04 2011 Andreas Schneider <asn@redhat.com> - 1:3.6.1-75
|
* Fri Nov 04 2011 Andreas Schneider <asn@redhat.com> - 1:3.6.1-75
|
||||||
- Fix systemd dependencies
|
- Fix systemd dependencies
|
||||||
- resolves: #751397
|
- resolves: #751397
|
||||||
|
Loading…
Reference in New Issue
Block a user