Update to Samba 4.4.0rc5
Guenther
This commit is contained in:
parent
2c679b9a83
commit
42b497c375
1
.gitignore
vendored
1
.gitignore
vendored
@ -61,3 +61,4 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.4.0rc2.tar.xz
|
/samba-4.4.0rc2.tar.xz
|
||||||
/samba-4.4.0rc3.tar.xz
|
/samba-4.4.0rc3.tar.xz
|
||||||
/samba-4.4.0rc4.tar.xz
|
/samba-4.4.0rc4.tar.xz
|
||||||
|
/samba-4.4.0rc5.tar.xz
|
||||||
|
@ -1,73 +0,0 @@
|
|||||||
From 7a961dba2db5861ad0d151c7fd12fb3cd8356a2e Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
|
||||||
Date: Wed, 20 Jan 2016 17:44:45 +0100
|
|
||||||
Subject: [PATCH 1/2] param: add parameter "server multi channel support",
|
|
||||||
defaults to off.
|
|
||||||
|
|
||||||
Guenther
|
|
||||||
|
|
||||||
Pair-Programmed-With: Michael Adam <obnox@samba.org>
|
|
||||||
|
|
||||||
Signed-off-by: Guenther Deschner <gd@samba.org>
|
|
||||||
Signed-off-by: Michael Adam <obnox@samba.org>
|
|
||||||
---
|
|
||||||
.../smbdotconf/protocol/servermultichannelsupport.xml | 19 +++++++++++++++++++
|
|
||||||
1 file changed, 19 insertions(+)
|
|
||||||
create mode 100644 docs-xml/smbdotconf/protocol/servermultichannelsupport.xml
|
|
||||||
|
|
||||||
diff --git a/docs-xml/smbdotconf/protocol/servermultichannelsupport.xml b/docs-xml/smbdotconf/protocol/servermultichannelsupport.xml
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..b85bbd3
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/docs-xml/smbdotconf/protocol/servermultichannelsupport.xml
|
|
||||||
@@ -0,0 +1,19 @@
|
|
||||||
+<samba:parameter name="server multi channel support"
|
|
||||||
+ context="G"
|
|
||||||
+ type="boolean"
|
|
||||||
+ xmlns:samba="http://www.samba.org/samba/DTD/samba-doc">
|
|
||||||
+<description>
|
|
||||||
+ <para>This boolean parameter controls whether
|
|
||||||
+ <citerefentry><refentrytitle>smbd</refentrytitle>
|
|
||||||
+ <manvolnum>8</manvolnum></citerefentry> will support
|
|
||||||
+ SMB3 multi-channel.
|
|
||||||
+ </para>
|
|
||||||
+ <para>This parameter has been added with version 4.4.</para>
|
|
||||||
+ <para>
|
|
||||||
+ Warning: Note that this feature is considered experimental in Samba 4.4.
|
|
||||||
+ Use it at your own risk: it may result in data corruption.
|
|
||||||
+ </para>
|
|
||||||
+</description>
|
|
||||||
+
|
|
||||||
+<value type="default">no</value>
|
|
||||||
+</samba:parameter>
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
||||||
|
|
||||||
From 1f63533b92b859e78e924cc21b7c305ecf245cc8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Adam <obnox@samba.org>
|
|
||||||
Date: Tue, 26 Jan 2016 08:16:51 +0100
|
|
||||||
Subject: [PATCH 2/2] smbd: enable multi-channel if 'server multi channel
|
|
||||||
support = yes' in the config
|
|
||||||
|
|
||||||
Signed-off-by: Michael Adam <obnox@samba.org>
|
|
||||||
---
|
|
||||||
source3/smbd/smbXsrv_client.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/source3/smbd/smbXsrv_client.c b/source3/smbd/smbXsrv_client.c
|
|
||||||
index 87cc307..8062593 100644
|
|
||||||
--- a/source3/smbd/smbXsrv_client.c
|
|
||||||
+++ b/source3/smbd/smbXsrv_client.c
|
|
||||||
@@ -490,6 +490,8 @@ NTSTATUS smbXsrv_client_create(TALLOC_CTX *mem_ctx,
|
|
||||||
client->ev_ctx = ev_ctx;
|
|
||||||
client->msg_ctx = msg_ctx;
|
|
||||||
|
|
||||||
+ client->server_multi_channel_enabled = lp_server_multi_channel_support();
|
|
||||||
+
|
|
||||||
client->table = talloc_move(client, &table);
|
|
||||||
table = client->table;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
23
samba.spec
23
samba.spec
@ -6,15 +6,15 @@
|
|||||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||||
%bcond_without clustering
|
%bcond_without clustering
|
||||||
|
|
||||||
%define main_release 7
|
%define main_release 8
|
||||||
|
|
||||||
%define samba_version 4.4.0
|
%define samba_version 4.4.0
|
||||||
%define talloc_version 2.1.5
|
%define talloc_version 2.1.6
|
||||||
%define tdb_version 1.3.8
|
%define tdb_version 1.3.8
|
||||||
%define tevent_version 0.9.26
|
%define tevent_version 0.9.28
|
||||||
%define ldb_version 1.1.25
|
%define ldb_version 1.1.26
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release rc4
|
%define pre_release rc5
|
||||||
|
|
||||||
%if "x%{?pre_release}" != "x"
|
%if "x%{?pre_release}" != "x"
|
||||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||||
@ -106,8 +106,6 @@ Source6: samba.pamd
|
|||||||
Source200: README.dc
|
Source200: README.dc
|
||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch0: samba-4.4.0rc2-mc-activate.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
@ -189,21 +187,21 @@ BuildRequires: gnutls-devel >= 3.4.7
|
|||||||
BuildRequires: perl(Parse::Yapp)
|
BuildRequires: perl(Parse::Yapp)
|
||||||
|
|
||||||
%if ! %with_internal_talloc
|
%if ! %with_internal_talloc
|
||||||
%global libtalloc_version 2.1.5
|
%global libtalloc_version 2.1.6
|
||||||
|
|
||||||
BuildRequires: libtalloc-devel >= %{libtalloc_version}
|
BuildRequires: libtalloc-devel >= %{libtalloc_version}
|
||||||
BuildRequires: pytalloc-devel >= %{libtalloc_version}
|
BuildRequires: pytalloc-devel >= %{libtalloc_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if ! %with_internal_tevent
|
%if ! %with_internal_tevent
|
||||||
%global libtevent_version 0.9.26
|
%global libtevent_version 0.9.28
|
||||||
|
|
||||||
BuildRequires: libtevent-devel >= %{libtevent_version}
|
BuildRequires: libtevent-devel >= %{libtevent_version}
|
||||||
BuildRequires: python-tevent >= %{libtevent_version}
|
BuildRequires: python-tevent >= %{libtevent_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if ! %with_internal_ldb
|
%if ! %with_internal_ldb
|
||||||
%global libldb_version 1.1.25
|
%global libldb_version 1.1.26
|
||||||
|
|
||||||
BuildRequires: libldb-devel >= %{libldb_version}
|
BuildRequires: libldb-devel >= %{libldb_version}
|
||||||
BuildRequires: pyldb-devel >= %{libldb_version}
|
BuildRequires: pyldb-devel >= %{libldb_version}
|
||||||
@ -682,8 +680,6 @@ and use CTDB instead.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n samba-%{version}%{pre_release}
|
%setup -q -n samba-%{version}%{pre_release}
|
||||||
|
|
||||||
%patch0 -p1 -b .samba-4.4.0rc2-mc-activate.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||||
%global _tevent_lib ,tevent,pytevent
|
%global _tevent_lib ,tevent,pytevent
|
||||||
@ -1970,6 +1966,9 @@ rm -rf %{buildroot}
|
|||||||
%endif # with_clustering_support
|
%endif # with_clustering_support
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 16 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.0-0.8.rc5
|
||||||
|
- Update to Samba 4.4.0rc5
|
||||||
|
|
||||||
* Tue Mar 08 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.0-0.7.rc4
|
* Tue Mar 08 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.0-0.7.rc4
|
||||||
- Update to Samba 4.4.0rc4
|
- Update to Samba 4.4.0rc4
|
||||||
- resolves: #1315942 - CVE-2015-7560 Incorrect ACL get/set allowed on symlink path
|
- resolves: #1315942 - CVE-2015-7560 Incorrect ACL get/set allowed on symlink path
|
||||||
|
Loading…
Reference in New Issue
Block a user