Update to Samba 4.5.0rc1
Guenther
This commit is contained in:
parent
145091f04b
commit
41dfb2a33c
1
.gitignore
vendored
1
.gitignore
vendored
@ -67,3 +67,4 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.4.3.tar.xz
|
||||
/samba-4.4.4.tar.xz
|
||||
/samba-4.4.5.tar.xz
|
||||
/samba-4.5.0rc1.tar.xz
|
||||
|
@ -1,68 +0,0 @@
|
||||
From 9845aff09ac6b136ee363f7fb869bfd3a8f9b8c1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
||||
Date: Fri, 10 Jun 2016 16:51:18 +0200
|
||||
Subject: [PATCH] s3-winbind: Fix schannel connections against trusted domain
|
||||
DCs
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=11830
|
||||
|
||||
Pair-Programmed-With: Andreas Schneider <asn@samba.org>
|
||||
Signed-off-by: Guenther Deschner <gd@samba.org>
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
Reviewed-by: Alexander Bokovoy <ab@samba.org>
|
||||
(cherry picked from commit d2379caa77fe02264323d69fee1bcad33f1bfeee)
|
||||
---
|
||||
source3/winbindd/winbindd_cm.c | 16 +++++++++++++++-
|
||||
1 file changed, 15 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source3/winbindd/winbindd_cm.c b/source3/winbindd/winbindd_cm.c
|
||||
index 45e3fad..f1f98db 100644
|
||||
--- a/source3/winbindd/winbindd_cm.c
|
||||
+++ b/source3/winbindd/winbindd_cm.c
|
||||
@@ -903,6 +903,7 @@ static NTSTATUS get_trust_credentials(struct winbindd_domain *domain,
|
||||
struct cli_credentials *creds;
|
||||
NTSTATUS status;
|
||||
bool force_machine_account = false;
|
||||
+ bool ok;
|
||||
|
||||
/* If we are a DC and this is not our own domain */
|
||||
|
||||
@@ -947,7 +948,13 @@ static NTSTATUS get_trust_credentials(struct winbindd_domain *domain,
|
||||
CRED_DONT_USE_KERBEROS);
|
||||
}
|
||||
|
||||
- if (creds_domain != domain) {
|
||||
+ /*
|
||||
+ * When we contact our own domain and get a list of the trusted domain
|
||||
+ * we have the information if we are able to contact the DC with
|
||||
+ * with our machine account password.
|
||||
+ */
|
||||
+ ok = winbindd_can_contact_domain(domain);
|
||||
+ if (!ok) {
|
||||
/*
|
||||
* We can only use schannel against a direct trust
|
||||
*/
|
||||
@@ -3284,6 +3291,8 @@ static NTSTATUS cm_connect_netlogon_transport(struct winbindd_domain *domain,
|
||||
|
||||
sec_chan_type = cli_credentials_get_secure_channel_type(creds);
|
||||
if (sec_chan_type == SEC_CHAN_NULL) {
|
||||
+ DBG_WARNING("get_secure_channel_type gave SEC_CHAN_NULL for %s\n",
|
||||
+ domain->name);
|
||||
return NT_STATUS_CANT_ACCESS_DOMAIN_INFO;
|
||||
}
|
||||
|
||||
@@ -3323,6 +3332,11 @@ static NTSTATUS cm_connect_netlogon_transport(struct winbindd_domain *domain,
|
||||
conn->netlogon_flags = netlogon_creds->negotiate_flags;
|
||||
TALLOC_FREE(netlogon_creds);
|
||||
|
||||
+ /*
|
||||
+ * FIXME: Document in which case we are not able to contact
|
||||
+ * a DC without schannel. Which information do we try to get
|
||||
+ * from this DC?
|
||||
+ */
|
||||
if (!(conn->netlogon_flags & NETLOGON_NEG_AUTHENTICATED_RPC)) {
|
||||
if (lp_winbind_sealed_pipes() || lp_require_strong_key()) {
|
||||
result = NT_STATUS_DOWNGRADE_DETECTED;
|
||||
--
|
||||
2.8.4
|
||||
|
@ -1,513 +0,0 @@
|
||||
From fb57f3e961c3554a3b6be04681f560e590c4b5f3 Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Bartlett <abartlet@samba.org>
|
||||
Date: Wed, 11 May 2016 05:33:17 +1200
|
||||
Subject: [PATCH] build: Build less of Samba when building
|
||||
--without-ntvfs-fileserver
|
||||
|
||||
We would build, but not use, many components of the NTVFS file server
|
||||
even when we asked not to. They would then consume disk, but not be
|
||||
of any use
|
||||
|
||||
https://bugzilla.samba.org/show_bug.cgi?id=11991
|
||||
|
||||
Signed-off-by: Andrew Bartlett <abartlet@samba.org>
|
||||
Reviewed-by: Garming Sam <garming@catalyst.net.nz>
|
||||
(cherry picked from commit 0b4c741b9c03d147ee5f56d027bacda75c1b5282)
|
||||
---
|
||||
source4/ntvfs/posix/posix_eadb.c | 81 ++++++++++----------
|
||||
source4/ntvfs/posix/wscript_build | 61 +++++++--------
|
||||
source4/ntvfs/wscript_build | 120 +++++++++++++++---------------
|
||||
source4/rpc_server/common/server_info.c | 1 -
|
||||
source4/rpc_server/wkssvc/dcesrv_wkssvc.c | 1 -
|
||||
source4/rpc_server/wscript_build | 18 +++--
|
||||
source4/smb_server/service_smb.c | 4 +-
|
||||
source4/smb_server/wscript_build | 2 +-
|
||||
source4/smbd/server.c | 4 -
|
||||
9 files changed, 149 insertions(+), 143 deletions(-)
|
||||
|
||||
diff --git a/source4/ntvfs/posix/posix_eadb.c b/source4/ntvfs/posix/posix_eadb.c
|
||||
index 31c565c..e08597c 100644
|
||||
--- a/source4/ntvfs/posix/posix_eadb.c
|
||||
+++ b/source4/ntvfs/posix/posix_eadb.c
|
||||
@@ -21,7 +21,9 @@
|
||||
|
||||
#include "includes.h"
|
||||
#include "lib/tdb_wrap/tdb_wrap.h"
|
||||
+#ifdef WITH_NTVFS_FILESERVER
|
||||
#include "vfs_posix.h"
|
||||
+#endif
|
||||
#include "posix_eadb.h"
|
||||
|
||||
#define XATTR_LIST_ATTR ".xattr_list"
|
||||
@@ -143,17 +145,6 @@ NTSTATUS pull_xattr_blob_tdb_raw(struct tdb_wrap *ea_tdb,
|
||||
return NT_STATUS_OK;
|
||||
}
|
||||
|
||||
-NTSTATUS pull_xattr_blob_tdb(struct pvfs_state *pvfs_state,
|
||||
- TALLOC_CTX *mem_ctx,
|
||||
- const char *attr_name,
|
||||
- const char *fname,
|
||||
- int fd,
|
||||
- size_t estimated_size,
|
||||
- DATA_BLOB *blob)
|
||||
-{
|
||||
- return pull_xattr_blob_tdb_raw(pvfs_state->ea_db,mem_ctx,attr_name,fname,fd,estimated_size,blob);
|
||||
-}
|
||||
-
|
||||
/*
|
||||
push a xattr as a blob, using ea_tdb
|
||||
*/
|
||||
@@ -199,14 +190,6 @@ done:
|
||||
talloc_free(mem_ctx);
|
||||
return status;
|
||||
}
|
||||
-NTSTATUS push_xattr_blob_tdb(struct pvfs_state *pvfs_state,
|
||||
- const char *attr_name,
|
||||
- const char *fname,
|
||||
- int fd,
|
||||
- const DATA_BLOB *blob)
|
||||
-{
|
||||
- return push_xattr_blob_tdb_raw(pvfs_state->ea_db, attr_name, fname, fd, blob);
|
||||
-}
|
||||
|
||||
|
||||
/*
|
||||
@@ -234,17 +217,6 @@ NTSTATUS delete_posix_eadb_raw(struct tdb_wrap *ea_tdb, const char *attr_name,
|
||||
|
||||
|
||||
/*
|
||||
- delete a xattr
|
||||
-*/
|
||||
-NTSTATUS delete_posix_eadb(struct pvfs_state *pvfs_state, const char *attr_name,
|
||||
- const char *fname, int fd)
|
||||
-{
|
||||
- return delete_posix_eadb_raw(pvfs_state->ea_db,
|
||||
- attr_name, fname, fd);
|
||||
-}
|
||||
-
|
||||
-
|
||||
-/*
|
||||
delete all xattrs for a file
|
||||
*/
|
||||
NTSTATUS unlink_posix_eadb_raw(struct tdb_wrap *ea_tdb, const char *fname, int fd)
|
||||
@@ -271,14 +243,6 @@ NTSTATUS unlink_posix_eadb_raw(struct tdb_wrap *ea_tdb, const char *fname, int f
|
||||
}
|
||||
|
||||
/*
|
||||
- delete all xattrs for a file
|
||||
-*/
|
||||
-NTSTATUS unlink_posix_eadb(struct pvfs_state *pvfs_state, const char *fname)
|
||||
-{
|
||||
- return unlink_posix_eadb_raw(pvfs_state->ea_db, fname, -1);
|
||||
-}
|
||||
-
|
||||
-/*
|
||||
list all xattrs for a file
|
||||
*/
|
||||
NTSTATUS list_posix_eadb_raw(struct tdb_wrap *ea_tdb, TALLOC_CTX *mem_ctx,
|
||||
@@ -288,3 +252,44 @@ NTSTATUS list_posix_eadb_raw(struct tdb_wrap *ea_tdb, TALLOC_CTX *mem_ctx,
|
||||
return pull_xattr_blob_tdb_raw(ea_tdb, mem_ctx, XATTR_LIST_ATTR,
|
||||
fname, fd, 100, list);
|
||||
}
|
||||
+
|
||||
+#ifdef WITH_NTVFS_FILESERVER
|
||||
+NTSTATUS pull_xattr_blob_tdb(struct pvfs_state *pvfs_state,
|
||||
+ TALLOC_CTX *mem_ctx,
|
||||
+ const char *attr_name,
|
||||
+ const char *fname,
|
||||
+ int fd,
|
||||
+ size_t estimated_size,
|
||||
+ DATA_BLOB *blob)
|
||||
+{
|
||||
+ return pull_xattr_blob_tdb_raw(pvfs_state->ea_db,mem_ctx,attr_name,fname,fd,estimated_size,blob);
|
||||
+}
|
||||
+
|
||||
+NTSTATUS push_xattr_blob_tdb(struct pvfs_state *pvfs_state,
|
||||
+ const char *attr_name,
|
||||
+ const char *fname,
|
||||
+ int fd,
|
||||
+ const DATA_BLOB *blob)
|
||||
+{
|
||||
+ return push_xattr_blob_tdb_raw(pvfs_state->ea_db, attr_name, fname, fd, blob);
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ delete a xattr
|
||||
+*/
|
||||
+NTSTATUS delete_posix_eadb(struct pvfs_state *pvfs_state, const char *attr_name,
|
||||
+ const char *fname, int fd)
|
||||
+{
|
||||
+ return delete_posix_eadb_raw(pvfs_state->ea_db,
|
||||
+ attr_name, fname, fd);
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ delete all xattrs for a file
|
||||
+*/
|
||||
+NTSTATUS unlink_posix_eadb(struct pvfs_state *pvfs_state, const char *fname)
|
||||
+{
|
||||
+ return unlink_posix_eadb_raw(pvfs_state->ea_db, fname, -1);
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
diff --git a/source4/ntvfs/posix/wscript_build b/source4/ntvfs/posix/wscript_build
|
||||
index 06fea0b..a07da33 100644
|
||||
--- a/source4/ntvfs/posix/wscript_build
|
||||
+++ b/source4/ntvfs/posix/wscript_build
|
||||
@@ -1,43 +1,44 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
-bld.SAMBA_SUBSYSTEM('pvfs_acl',
|
||||
- source='pvfs_acl.c',
|
||||
- autoproto='vfs_acl_proto.h',
|
||||
- deps='events samba-modules',
|
||||
- )
|
||||
+if bld.CONFIG_SET('WITH_NTVFS_FILESERVER'):
|
||||
+ bld.SAMBA_SUBSYSTEM('pvfs_acl',
|
||||
+ source='pvfs_acl.c',
|
||||
+ autoproto='vfs_acl_proto.h',
|
||||
+ deps='events samba-modules',
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_MODULE('pvfs_acl_xattr',
|
||||
- source='pvfs_acl_xattr.c',
|
||||
- subsystem='pvfs_acl',
|
||||
- init_function='pvfs_acl_xattr_init',
|
||||
- deps='NDR_XATTR events'
|
||||
- )
|
||||
+ bld.SAMBA_MODULE('pvfs_acl_xattr',
|
||||
+ source='pvfs_acl_xattr.c',
|
||||
+ subsystem='pvfs_acl',
|
||||
+ init_function='pvfs_acl_xattr_init',
|
||||
+ deps='NDR_XATTR events'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_MODULE('pvfs_acl_nfs4',
|
||||
- source='pvfs_acl_nfs4.c',
|
||||
- subsystem='pvfs_acl',
|
||||
- init_function='pvfs_acl_nfs4_init',
|
||||
- deps='NDR_NFS4ACL samdb events'
|
||||
- )
|
||||
+ bld.SAMBA_MODULE('pvfs_acl_nfs4',
|
||||
+ source='pvfs_acl_nfs4.c',
|
||||
+ subsystem='pvfs_acl',
|
||||
+ init_function='pvfs_acl_nfs4_init',
|
||||
+ deps='NDR_NFS4ACL samdb events'
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_SUBSYSTEM('pvfs_aio',
|
||||
- source='pvfs_aio.c',
|
||||
- deps='tevent',
|
||||
- enabled=False
|
||||
- )
|
||||
+ bld.SAMBA_SUBSYSTEM('pvfs_aio',
|
||||
+ source='pvfs_aio.c',
|
||||
+ deps='tevent',
|
||||
+ enabled=False
|
||||
+ )
|
||||
|
||||
|
||||
-bld.SAMBA_MODULE('ntvfs_posix',
|
||||
- source='vfs_posix.c pvfs_util.c pvfs_search.c pvfs_dirlist.c pvfs_fileinfo.c pvfs_unlink.c pvfs_mkdir.c pvfs_open.c pvfs_read.c pvfs_flush.c pvfs_write.c pvfs_fsinfo.c pvfs_qfileinfo.c pvfs_setfileinfo.c pvfs_rename.c pvfs_resolve.c pvfs_shortname.c pvfs_lock.c pvfs_oplock.c pvfs_wait.c pvfs_seek.c pvfs_ioctl.c pvfs_xattr.c pvfs_streams.c pvfs_notify.c pvfs_sys.c xattr_system.c',
|
||||
- autoproto='vfs_posix_proto.h',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_posix_init',
|
||||
- deps='NDR_XATTR attr ntvfs_common MESSAGING LIBWBCLIENT_OLD pvfs_acl pvfs_aio posix_eadb',
|
||||
- internal_module=True
|
||||
- )
|
||||
+ bld.SAMBA_MODULE('ntvfs_posix',
|
||||
+ source='vfs_posix.c pvfs_util.c pvfs_search.c pvfs_dirlist.c pvfs_fileinfo.c pvfs_unlink.c pvfs_mkdir.c pvfs_open.c pvfs_read.c pvfs_flush.c pvfs_write.c pvfs_fsinfo.c pvfs_qfileinfo.c pvfs_setfileinfo.c pvfs_rename.c pvfs_resolve.c pvfs_shortname.c pvfs_lock.c pvfs_oplock.c pvfs_wait.c pvfs_seek.c pvfs_ioctl.c pvfs_xattr.c pvfs_streams.c pvfs_notify.c pvfs_sys.c xattr_system.c',
|
||||
+ autoproto='vfs_posix_proto.h',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_posix_init',
|
||||
+ deps='NDR_XATTR attr ntvfs_common MESSAGING LIBWBCLIENT_OLD pvfs_acl pvfs_aio posix_eadb',
|
||||
+ internal_module=True
|
||||
+ )
|
||||
|
||||
|
||||
bld.SAMBA_PYTHON('python_xattr_native',
|
||||
diff --git a/source4/ntvfs/wscript_build b/source4/ntvfs/wscript_build
|
||||
index 6e3ee6d..44cb78d 100644
|
||||
--- a/source4/ntvfs/wscript_build
|
||||
+++ b/source4/ntvfs/wscript_build
|
||||
@@ -5,71 +5,71 @@ bld.SAMBA_LIBRARY('ntvfs',
|
||||
autoproto='ntvfs_proto.h',
|
||||
deps='tevent samba-modules',
|
||||
private_library=True,
|
||||
- enabled=bld.AD_DC_BUILD_IS_ENABLED()
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
|
||||
-if bld.AD_DC_BUILD_IS_ENABLED():
|
||||
- bld.RECURSE('posix')
|
||||
+bld.RECURSE('posix')
|
||||
+if bld.CONFIG_SET('WITH_NTVFS_FILESERVER'):
|
||||
bld.RECURSE('common')
|
||||
bld.RECURSE('unixuid')
|
||||
bld.RECURSE('sysdep')
|
||||
|
||||
-bld.SAMBA_MODULE('ntvfs_cifs',
|
||||
- source='cifs/vfs_cifs.c',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_cifs_init',
|
||||
- deps='LIBCLI_SMB smbclient-raw param_options'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_smb2',
|
||||
- source='smb2/vfs_smb2.c',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_smb2_init',
|
||||
- deps='LIBCLI_SMB smbclient-raw param_options'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_simple',
|
||||
- source='simple/vfs_simple.c simple/svfs_util.c',
|
||||
- autoproto='simple/proto.h',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_simple_init',
|
||||
- deps='talloc'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_cifsposix',
|
||||
- source='cifs_posix_cli/vfs_cifs_posix.c cifs_posix_cli/svfs_util.c',
|
||||
- autoproto='cifs_posix_cli/proto.h',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_cifs_posix_init',
|
||||
- deps='talloc'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_print',
|
||||
- source='print/vfs_print.c',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_print_init',
|
||||
- deps='talloc'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_ipc',
|
||||
- source='ipc/vfs_ipc.c ipc/ipc_rap.c ipc/rap_server.c',
|
||||
- autoproto='ipc/proto.h',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_ipc_init',
|
||||
- deps='NDR_NAMED_PIPE_AUTH npa_tstream gssapi samba-credentials DCERPC_SHARE'
|
||||
- )
|
||||
-
|
||||
-
|
||||
-bld.SAMBA_MODULE('ntvfs_nbench',
|
||||
- source='nbench/vfs_nbench.c',
|
||||
- subsystem='ntvfs',
|
||||
- init_function='ntvfs_nbench_init',
|
||||
- deps='talloc'
|
||||
- )
|
||||
+ bld.SAMBA_MODULE('ntvfs_cifs',
|
||||
+ source='cifs/vfs_cifs.c',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_cifs_init',
|
||||
+ deps='LIBCLI_SMB smbclient-raw param_options'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_smb2',
|
||||
+ source='smb2/vfs_smb2.c',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_smb2_init',
|
||||
+ deps='LIBCLI_SMB smbclient-raw param_options'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_simple',
|
||||
+ source='simple/vfs_simple.c simple/svfs_util.c',
|
||||
+ autoproto='simple/proto.h',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_simple_init',
|
||||
+ deps='talloc'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_cifsposix',
|
||||
+ source='cifs_posix_cli/vfs_cifs_posix.c cifs_posix_cli/svfs_util.c',
|
||||
+ autoproto='cifs_posix_cli/proto.h',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_cifs_posix_init',
|
||||
+ deps='talloc'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_print',
|
||||
+ source='print/vfs_print.c',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_print_init',
|
||||
+ deps='talloc'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_ipc',
|
||||
+ source='ipc/vfs_ipc.c ipc/ipc_rap.c ipc/rap_server.c',
|
||||
+ autoproto='ipc/proto.h',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_ipc_init',
|
||||
+ deps='NDR_NAMED_PIPE_AUTH npa_tstream gssapi samba-credentials DCERPC_SHARE'
|
||||
+ )
|
||||
+
|
||||
+
|
||||
+ bld.SAMBA_MODULE('ntvfs_nbench',
|
||||
+ source='nbench/vfs_nbench.c',
|
||||
+ subsystem='ntvfs',
|
||||
+ init_function='ntvfs_nbench_init',
|
||||
+ deps='talloc'
|
||||
+ )
|
||||
|
||||
|
||||
diff --git a/source4/rpc_server/common/server_info.c b/source4/rpc_server/common/server_info.c
|
||||
index e23b108..39c75cc 100644
|
||||
--- a/source4/rpc_server/common/server_info.c
|
||||
+++ b/source4/rpc_server/common/server_info.c
|
||||
@@ -26,7 +26,6 @@
|
||||
#include "auth/auth.h"
|
||||
#include "param/param.h"
|
||||
#include "rpc_server/common/common.h"
|
||||
-#include "rpc_server/common/share.h"
|
||||
#include "libds/common/roles.h"
|
||||
|
||||
/*
|
||||
diff --git a/source4/rpc_server/wkssvc/dcesrv_wkssvc.c b/source4/rpc_server/wkssvc/dcesrv_wkssvc.c
|
||||
index 80a518c..baae0e3 100644
|
||||
--- a/source4/rpc_server/wkssvc/dcesrv_wkssvc.c
|
||||
+++ b/source4/rpc_server/wkssvc/dcesrv_wkssvc.c
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "librpc/gen_ndr/ndr_wkssvc.h"
|
||||
#include "librpc/gen_ndr/ndr_srvsvc.h"
|
||||
#include "rpc_server/common/common.h"
|
||||
-#include "rpc_server/common/share.h"
|
||||
#include "param/param.h"
|
||||
|
||||
/*
|
||||
diff --git a/source4/rpc_server/wscript_build b/source4/rpc_server/wscript_build
|
||||
index aaf3d26..b9de1fb 100755
|
||||
--- a/source4/rpc_server/wscript_build
|
||||
+++ b/source4/rpc_server/wscript_build
|
||||
@@ -1,14 +1,14 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
bld.SAMBA_SUBSYSTEM('DCERPC_SHARE',
|
||||
- source='common/server_info.c common/share_info.c',
|
||||
+ source='common/share_info.c',
|
||||
autoproto='common/share.h',
|
||||
deps='ldb',
|
||||
- enabled=bld.AD_DC_BUILD_IS_ENABLED()
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER'),
|
||||
)
|
||||
|
||||
bld.SAMBA_SUBSYSTEM('DCERPC_COMMON',
|
||||
- source='common/forward.c common/reply.c dcesrv_auth.c common/loadparm.c',
|
||||
+ source='common/server_info.c common/forward.c common/reply.c dcesrv_auth.c common/loadparm.c',
|
||||
autoproto='common/proto.h',
|
||||
deps='ldb DCERPC_SHARE samba_server_gensec',
|
||||
enabled=bld.AD_DC_BUILD_IS_ENABLED()
|
||||
@@ -54,7 +54,8 @@ bld.SAMBA_MODULE('dcerpc_srvsvc',
|
||||
autoproto='srvsvc/proto.h',
|
||||
subsystem='dcerpc_server',
|
||||
init_function='dcerpc_server_srvsvc_init',
|
||||
- deps='DCERPC_COMMON NDR_SRVSVC share ntvfs'
|
||||
+ deps='DCERPC_COMMON NDR_SRVSVC share ntvfs',
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
|
||||
|
||||
@@ -88,7 +89,8 @@ bld.SAMBA_MODULE('dcerpc_winreg',
|
||||
subsystem='dcerpc_server',
|
||||
init_function='dcerpc_server_winreg_init',
|
||||
deps='registry ndr-standard',
|
||||
- internal_module=True
|
||||
+ internal_module=True,
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
|
||||
|
||||
@@ -132,7 +134,8 @@ bld.SAMBA_MODULE('dcerpc_spoolss',
|
||||
subsystem='dcerpc_server',
|
||||
init_function='dcerpc_server_spoolss_init',
|
||||
deps='DCERPC_COMMON NDR_SPOOLSS ntptr RPC_NDR_SPOOLSS',
|
||||
- internal_module=True
|
||||
+ internal_module=True,
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
|
||||
|
||||
@@ -155,7 +158,8 @@ bld.SAMBA_MODULE('dcerpc_eventlog',
|
||||
source='eventlog/dcesrv_eventlog6.c',
|
||||
subsystem='dcerpc_server',
|
||||
init_function='dcerpc_server_eventlog6_init',
|
||||
- deps='DCERPC_COMMON'
|
||||
+ deps='DCERPC_COMMON',
|
||||
+ enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
|
||||
bld.SAMBA_MODULE('dcerpc_dnsserver',
|
||||
diff --git a/source4/smb_server/service_smb.c b/source4/smb_server/service_smb.c
|
||||
index 0e4897c..05004b0 100644
|
||||
--- a/source4/smb_server/service_smb.c
|
||||
+++ b/source4/smb_server/service_smb.c
|
||||
@@ -34,7 +34,8 @@
|
||||
#include "dsdb/samdb/samdb.h"
|
||||
#include "param/param.h"
|
||||
#include "file_server/file_server.h"
|
||||
-
|
||||
+#include "ntvfs/ntvfs.h"
|
||||
+#include "lib/cmdline/popt_common.h"
|
||||
/*
|
||||
open the smb server sockets
|
||||
*/
|
||||
@@ -86,6 +87,7 @@ failed:
|
||||
/* called at smbd startup - register ourselves as a server service */
|
||||
NTSTATUS server_service_smb_init(void)
|
||||
{
|
||||
+ ntvfs_init(cmdline_lp_ctx);
|
||||
share_init();
|
||||
return register_server_service("smb", smbsrv_task_init);
|
||||
}
|
||||
diff --git a/source4/smb_server/wscript_build b/source4/smb_server/wscript_build
|
||||
index 78298d9..5860340 100644
|
||||
--- a/source4/smb_server/wscript_build
|
||||
+++ b/source4/smb_server/wscript_build
|
||||
@@ -5,7 +5,7 @@ bld.SAMBA_MODULE('service_smb',
|
||||
autoproto='service_smb_proto.h',
|
||||
subsystem='service',
|
||||
init_function='server_service_smb_init',
|
||||
- deps='SMB_SERVER netif shares samba-hostconfig',
|
||||
+ deps='SMB_SERVER netif shares samba-hostconfig POPT_SAMBA',
|
||||
internal_module=False,
|
||||
enabled=bld.CONFIG_SET('WITH_NTVFS_FILESERVER')
|
||||
)
|
||||
diff --git a/source4/smbd/server.c b/source4/smbd/server.c
|
||||
index bd70ac6..1c74f40 100644
|
||||
--- a/source4/smbd/server.c
|
||||
+++ b/source4/smbd/server.c
|
||||
@@ -28,7 +28,6 @@
|
||||
#include "lib/cmdline/popt_common.h"
|
||||
#include "system/dir.h"
|
||||
#include "system/filesys.h"
|
||||
-#include "ntvfs/ntvfs.h"
|
||||
#include "ntptr/ntptr.h"
|
||||
#include "auth/gensec/gensec.h"
|
||||
#include "libcli/auth/schannel.h"
|
||||
@@ -409,9 +408,6 @@ static int binary_smbd_main(const char *binary_name, int argc, const char *argv[
|
||||
ntptr_init(); /* FIXME: maybe run this in the initialization function
|
||||
of the spoolss RPC server instead? */
|
||||
|
||||
- ntvfs_init(cmdline_lp_ctx); /* FIXME: maybe run this in the initialization functions
|
||||
- of the SMB[,2] server instead? */
|
||||
-
|
||||
process_model_init(cmdline_lp_ctx);
|
||||
|
||||
shared_init = load_samba_modules(NULL, "service");
|
||||
--
|
||||
2.5.5
|
||||
|
80
samba.spec
80
samba.spec
@ -6,15 +6,15 @@
|
||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||
%bcond_without clustering
|
||||
|
||||
%define main_release 1
|
||||
%define main_release 0
|
||||
|
||||
%define samba_version 4.4.5
|
||||
%define talloc_version 2.1.6
|
||||
%define tdb_version 1.3.8
|
||||
%define tevent_version 0.9.28
|
||||
%define ldb_version 1.1.26
|
||||
%define samba_version 4.5.0
|
||||
%define talloc_version 2.1.8
|
||||
%define tdb_version 1.3.10
|
||||
%define tevent_version 0.9.29
|
||||
%define ldb_version 1.1.27
|
||||
# This should be rc1 or nil
|
||||
%define pre_release %nil
|
||||
%define pre_release rc1
|
||||
|
||||
%if "x%{?pre_release}" != "x"
|
||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||
@ -50,7 +50,7 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%global libwbc_alternatives_version 0.12
|
||||
%global libwbc_alternatives_version 0.13
|
||||
%global libwbc_alternatives_suffix %nil
|
||||
%if 0%{?__isa_bits} == 64
|
||||
%global libwbc_alternatives_suffix -64
|
||||
@ -75,7 +75,7 @@
|
||||
|
||||
Name: samba
|
||||
Version: %{samba_version}
|
||||
Release: %{samba_release}.1
|
||||
Release: %{samba_release}
|
||||
|
||||
%if 0%{?rhel}
|
||||
Epoch: 0
|
||||
@ -107,9 +107,6 @@ Source6: samba.pamd
|
||||
Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch0: samba-4.4.5-fix_resolving_trusted_domain_users.patch
|
||||
Patch1: samba-4.4.5-ntvfs_build.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Requires(pre): /usr/sbin/groupadd
|
||||
@ -191,28 +188,28 @@ BuildRequires: gnutls-devel >= 3.4.7
|
||||
BuildRequires: perl(Parse::Yapp)
|
||||
|
||||
%if ! %with_internal_talloc
|
||||
%global libtalloc_version 2.1.6
|
||||
%global libtalloc_version 2.1.8
|
||||
|
||||
BuildRequires: libtalloc-devel >= %{libtalloc_version}
|
||||
BuildRequires: pytalloc-devel >= %{libtalloc_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_tevent
|
||||
%global libtevent_version 0.9.28
|
||||
%global libtevent_version 0.9.29
|
||||
|
||||
BuildRequires: libtevent-devel >= %{libtevent_version}
|
||||
BuildRequires: python-tevent >= %{libtevent_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_ldb
|
||||
%global libldb_version 1.1.26
|
||||
%global libldb_version 1.1.27
|
||||
|
||||
BuildRequires: libldb-devel >= %{libldb_version}
|
||||
BuildRequires: pyldb-devel >= %{libldb_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_tdb
|
||||
%global libtdb_version 1.3.8
|
||||
%global libtdb_version 1.3.10
|
||||
|
||||
BuildRequires: libtdb-devel >= %{libtdb_version}
|
||||
BuildRequires: python-tdb >= %{libtdb_version}
|
||||
@ -687,9 +684,6 @@ and use CTDB instead.
|
||||
%prep
|
||||
%setup -q -n samba-%{version}%{pre_release}
|
||||
|
||||
%patch0 -p 1 -b .samba-4.4.5-fix_resolving_trusted_domain_users.patch
|
||||
%patch1 -p 1 -b .samba-4.4.5-ntvfs_build.patch
|
||||
|
||||
%build
|
||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||
%global _tevent_lib ,tevent,pytevent
|
||||
@ -840,7 +834,7 @@ echo "d /run/ctdb 755 root root" >> %{buildroot}%{_tmpfilesdir}/ctdb.conf
|
||||
install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
|
||||
install -m 0644 packaging/systemd/samba.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/samba
|
||||
%if %with_clustering_support
|
||||
install -m 0644 ctdb/config/ctdb.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/ctdb
|
||||
install -m 0644 ctdb/config/ctdbd.conf %{buildroot}%{_sysconfdir}/sysconfig/ctdb
|
||||
%endif
|
||||
|
||||
install -m 0644 %{SOURCE201} packaging/README.downgrade
|
||||
@ -1160,6 +1154,7 @@ rm -rf %{buildroot}
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/cifsdd
|
||||
%{_bindir}/dbwrap_tool
|
||||
%{_bindir}/findsmb
|
||||
%{_bindir}/nmblookup
|
||||
%{_bindir}/oLschema2ldif
|
||||
%{_bindir}/regdiff
|
||||
@ -1186,7 +1181,7 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man1/regpatch.1*
|
||||
%{_mandir}/man1/regshell.1*
|
||||
%{_mandir}/man1/regtree.1*
|
||||
%exclude %{_mandir}/man1/findsmb.1*
|
||||
%{_mandir}/man1/findsmb.1*
|
||||
%{_mandir}/man1/log2pcap.1*
|
||||
%{_mandir}/man1/rpcclient.1*
|
||||
%{_mandir}/man1/sharesec.1*
|
||||
@ -1255,7 +1250,6 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/libsamdb.so.*
|
||||
%{_libdir}/libsmbconf.so.*
|
||||
%{_libdir}/libsmbldap.so.*
|
||||
%{_libdir}/libtevent-unix-util.so.*
|
||||
%{_libdir}/libtevent-util.so.*
|
||||
%{_libdir}/libdcerpc.so.*
|
||||
|
||||
@ -1568,6 +1562,7 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/ndr/ndr_dcerpc.h
|
||||
%{_includedir}/samba-4.0/ndr/ndr_drsblobs.h
|
||||
%{_includedir}/samba-4.0/ndr/ndr_drsuapi.h
|
||||
%{_includedir}/samba-4.0/ndr/ndr_krb5pac.h
|
||||
%{_includedir}/samba-4.0/ndr/ndr_svcctl.h
|
||||
%{_includedir}/samba-4.0/ndr/ndr_nbt.h
|
||||
%{_includedir}/samba-4.0/netapi.h
|
||||
@ -1622,7 +1617,6 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/libsamba-util.so
|
||||
%{_libdir}/libsamdb.so
|
||||
%{_libdir}/libsmbconf.so
|
||||
%{_libdir}/libtevent-unix-util.so
|
||||
%{_libdir}/libtevent-util.so
|
||||
%{_libdir}/pkgconfig/dcerpc.pc
|
||||
%{_libdir}/pkgconfig/dcerpc_samr.pc
|
||||
@ -1897,6 +1891,7 @@ rm -rf %{buildroot}
|
||||
%{_sysconfdir}/ctdb/events.d/00.ctdb
|
||||
%{_sysconfdir}/ctdb/events.d/01.reclock
|
||||
%{_sysconfdir}/ctdb/events.d/05.system
|
||||
%{_sysconfdir}/ctdb/events.d/06.nfs
|
||||
%{_sysconfdir}/ctdb/events.d/10.external
|
||||
%{_sysconfdir}/ctdb/events.d/10.interface
|
||||
%{_sysconfdir}/ctdb/events.d/11.natgw
|
||||
@ -1919,6 +1914,9 @@ rm -rf %{buildroot}
|
||||
%{_sbindir}/ctdbd
|
||||
%{_sbindir}/ctdbd_wrapper
|
||||
%{_bindir}/ctdb
|
||||
%{_libexecdir}/ctdb/ctdb_killtcp
|
||||
%{_libexecdir}/ctdb/ctdb_lvs
|
||||
%{_libexecdir}/ctdb/ctdb_mutex_fcntl_helper
|
||||
%{_libexecdir}/ctdb/ctdb_natgw
|
||||
%{_libexecdir}/ctdb/ctdb_recovery_helper
|
||||
%{_libexecdir}/ctdb/smnotify
|
||||
@ -1930,6 +1928,7 @@ rm -rf %{buildroot}
|
||||
%{_libexecdir}/ctdb/ctdb_event_helper
|
||||
|
||||
%{_mandir}/man1/ctdb.1.gz
|
||||
%{_mandir}/man1/ctdb_diagnostics.1.gz
|
||||
%{_mandir}/man1/ctdbd.1.gz
|
||||
%{_mandir}/man1/onnode.1.gz
|
||||
%{_mandir}/man1/ltdbtool.1.gz
|
||||
@ -1946,32 +1945,29 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/ctdb-tests/comm_client_test
|
||||
%{_libdir}/ctdb-tests/comm_server_test
|
||||
%{_libdir}/ctdb-tests/comm_test
|
||||
%{_libdir}/ctdb-tests/ctdb_bench
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch_one
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch_readonly_loop
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch_readonly_once
|
||||
%{_libdir}/ctdb-tests/ctdb_functest
|
||||
%{_libdir}/ctdb-tests/ctdb_lock_tdb
|
||||
%{_libdir}/ctdb-tests/ctdb_persistent
|
||||
%{_libdir}/ctdb-tests/ctdb_porting_tests
|
||||
%{_libdir}/ctdb-tests/ctdb_randrec
|
||||
%{_libdir}/ctdb-tests/ctdb_store
|
||||
%{_libdir}/ctdb-tests/ctdb_stubtest
|
||||
%{_libdir}/ctdb-tests/ctdb_packet_parse
|
||||
%{_libdir}/ctdb-tests/ctdb_takeover_tests
|
||||
%{_libdir}/ctdb-tests/ctdb_trackingdb_test
|
||||
%{_libdir}/ctdb-tests/ctdb_transaction
|
||||
%{_libdir}/ctdb-tests/ctdb_traverse
|
||||
%{_libdir}/ctdb-tests/ctdb_update_record
|
||||
%{_libdir}/ctdb-tests/ctdb_update_record_persistent
|
||||
%{_libdir}/ctdb-tests/db_hash_test
|
||||
%{_libdir}/ctdb-tests/fake_ctdbd
|
||||
%{_libdir}/ctdb-tests/fetch_loop
|
||||
%{_libdir}/ctdb-tests/fetch_loop_key
|
||||
%{_libdir}/ctdb-tests/fetch_readonly
|
||||
%{_libdir}/ctdb-tests/fetch_readonly_loop
|
||||
%{_libdir}/ctdb-tests/fetch_ring
|
||||
%{_libdir}/ctdb-tests/g_lock_loop
|
||||
%{_libdir}/ctdb-tests/lock_tdb
|
||||
%{_libdir}/ctdb-tests/message_ring
|
||||
%{_libdir}/ctdb-tests/pkt_read_test
|
||||
%{_libdir}/ctdb-tests/pkt_write_test
|
||||
%{_libdir}/ctdb-tests/porting_tests
|
||||
%{_libdir}/ctdb-tests/protocol_client_test
|
||||
%{_libdir}/ctdb-tests/protocol_types_test
|
||||
%{_libdir}/ctdb-tests/rb_test
|
||||
%{_libdir}/ctdb-tests/reqid_test
|
||||
%{_libdir}/ctdb-tests/srvid_test
|
||||
%{_libdir}/ctdb-tests/transaction_loop
|
||||
%{_libdir}/ctdb-tests/update_record
|
||||
%{_libdir}/ctdb-tests/update_record_persistent
|
||||
%{_bindir}/ctdb_run_tests
|
||||
%{_bindir}/ctdb_run_cluster_tests
|
||||
%dir %{_datadir}/ctdb-tests
|
||||
@ -1986,6 +1982,7 @@ rm -rf %{buildroot}
|
||||
%dir %{_datadir}/ctdb-tests/scripts
|
||||
%{_datadir}/ctdb-tests/scripts/common.sh
|
||||
%{_datadir}/ctdb-tests/scripts/integration.bash
|
||||
%{_datadir}/ctdb-tests/scripts/script_install_paths.sh
|
||||
%{_datadir}/ctdb-tests/scripts/test_wrap
|
||||
%{_datadir}/ctdb-tests/scripts/unit.sh
|
||||
%dir %{_datadir}/ctdb-tests/simple
|
||||
@ -1995,6 +1992,9 @@ rm -rf %{buildroot}
|
||||
%endif # with_clustering_support
|
||||
|
||||
%changelog
|
||||
* Thu Jul 28 2016 Guenther Deschner <gdeschner@redhat.com> - 4.5.0rc1-0
|
||||
- Update to Samba 4.5.0rc1
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:4.4.5-1.1
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user