Update to Samba 4.9.2
Guenther
This commit is contained in:
parent
af6b030436
commit
0516288a3b
2
.gitignore
vendored
2
.gitignore
vendored
@ -141,3 +141,5 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.9.0.tar.asc
|
/samba-4.9.0.tar.asc
|
||||||
/samba-4.9.1.tar.asc
|
/samba-4.9.1.tar.asc
|
||||||
/samba-4.9.1.tar.xz
|
/samba-4.9.1.tar.xz
|
||||||
|
/samba-4.9.2.tar.xz
|
||||||
|
/samba-4.9.2.tar.asc
|
||||||
|
@ -1,117 +0,0 @@
|
|||||||
From e2dd47233f467e2ab80564968be4af6da6505161 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andreas Schneider <asn@samba.org>
|
|
||||||
Date: Mon, 3 Sep 2018 10:35:08 +0200
|
|
||||||
Subject: [PATCH 1/2] waf: Check for -fstack-protect-strong support
|
|
||||||
|
|
||||||
The -fstack-protector* flags are compiler only flags, don't pass them to
|
|
||||||
the linker.
|
|
||||||
|
|
||||||
https://developers.redhat.com/blog/2018/03/21/compiler-and-linker-flags-gcc/
|
|
||||||
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=13601
|
|
||||||
|
|
||||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
||||||
Reviewed-by: Andrew Bartlett <abartlet@samba.org>
|
|
||||||
(cherry picked from commit 38e97f8b52e85bdfcf2d74a4fb3c848fa46ba371)
|
|
||||||
---
|
|
||||||
buildtools/wafsamba/samba_autoconf.py | 36 ++++++++++++++-------------
|
|
||||||
1 file changed, 19 insertions(+), 17 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/buildtools/wafsamba/samba_autoconf.py b/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
index c4391d0c4dc..bfd6f9710db 100644
|
|
||||||
--- a/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
+++ b/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
@@ -674,23 +674,25 @@ def SAMBA_CONFIG_H(conf, path=None):
|
|
||||||
return
|
|
||||||
|
|
||||||
# we need to build real code that can't be optimized away to test
|
|
||||||
- if conf.check(fragment='''
|
|
||||||
- #include <stdio.h>
|
|
||||||
-
|
|
||||||
- int main(void)
|
|
||||||
- {
|
|
||||||
- char t[100000];
|
|
||||||
- while (fgets(t, sizeof(t), stdin));
|
|
||||||
- return 0;
|
|
||||||
- }
|
|
||||||
- ''',
|
|
||||||
- execute=0,
|
|
||||||
- ccflags='-fstack-protector',
|
|
||||||
- ldflags='-fstack-protector',
|
|
||||||
- mandatory=False,
|
|
||||||
- msg='Checking if toolchain accepts -fstack-protector'):
|
|
||||||
- conf.ADD_CFLAGS('-fstack-protector')
|
|
||||||
- conf.ADD_LDFLAGS('-fstack-protector')
|
|
||||||
+ stack_protect_list = ['-fstack-protector-strong', '-fstack-protector']
|
|
||||||
+ for stack_protect_flag in stack_protect_list:
|
|
||||||
+ flag_supported = conf.check(fragment='''
|
|
||||||
+ #include <stdio.h>
|
|
||||||
+
|
|
||||||
+ int main(void)
|
|
||||||
+ {
|
|
||||||
+ char t[100000];
|
|
||||||
+ while (fgets(t, sizeof(t), stdin));
|
|
||||||
+ return 0;
|
|
||||||
+ }
|
|
||||||
+ ''',
|
|
||||||
+ execute=0,
|
|
||||||
+ ccflags=[ '-Werror', '-Wp,-D_FORTIFY_SOURCE=2', stack_protect_flag],
|
|
||||||
+ mandatory=False,
|
|
||||||
+ msg='Checking if compiler accepts %s' % (stack_protect_flag))
|
|
||||||
+ if flag_supported:
|
|
||||||
+ conf.ADD_CFLAGS('-Wp,-D_FORTIFY_SOURCE=2 %s' % (stack_protect_flag))
|
|
||||||
+ break
|
|
||||||
|
|
||||||
if Options.options.debug:
|
|
||||||
conf.ADD_CFLAGS('-g', testflags=True)
|
|
||||||
--
|
|
||||||
2.18.0
|
|
||||||
|
|
||||||
|
|
||||||
From 09f3acb3497efb9ebb8a0d7d199726a8c318e4f8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andreas Schneider <asn@samba.org>
|
|
||||||
Date: Mon, 3 Sep 2018 10:49:52 +0200
|
|
||||||
Subject: [PATCH 2/2] waf: Add -fstack-clash-protection
|
|
||||||
|
|
||||||
https://developers.redhat.com/blog/2018/03/21/compiler-and-linker-flags-gcc/
|
|
||||||
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=13601
|
|
||||||
|
|
||||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
||||||
Reviewed-by: Andrew Bartlett <abartlet@samba.org>
|
|
||||||
(cherry picked from commit fc4df251c88365142515a81bea1120b2b84cc4a0)
|
|
||||||
---
|
|
||||||
buildtools/wafsamba/samba_autoconf.py | 17 +++++++++++++++++
|
|
||||||
1 file changed, 17 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/buildtools/wafsamba/samba_autoconf.py b/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
index bfd6f9710db..f2b3ec8db8d 100644
|
|
||||||
--- a/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
+++ b/buildtools/wafsamba/samba_autoconf.py
|
|
||||||
@@ -694,6 +694,23 @@ def SAMBA_CONFIG_H(conf, path=None):
|
|
||||||
conf.ADD_CFLAGS('-Wp,-D_FORTIFY_SOURCE=2 %s' % (stack_protect_flag))
|
|
||||||
break
|
|
||||||
|
|
||||||
+ flag_supported = conf.check(fragment='''
|
|
||||||
+ #include <stdio.h>
|
|
||||||
+
|
|
||||||
+ int main(void)
|
|
||||||
+ {
|
|
||||||
+ char t[100000];
|
|
||||||
+ while (fgets(t, sizeof(t), stdin));
|
|
||||||
+ return 0;
|
|
||||||
+ }
|
|
||||||
+ ''',
|
|
||||||
+ execute=0,
|
|
||||||
+ ccflags=[ '-Werror', '-fstack-clash-protection'],
|
|
||||||
+ mandatory=False,
|
|
||||||
+ msg='Checking if compiler accepts -fstack-clash-protection')
|
|
||||||
+ if flag_supported:
|
|
||||||
+ conf.ADD_CFLAGS('-fstack-clash-protection')
|
|
||||||
+
|
|
||||||
if Options.options.debug:
|
|
||||||
conf.ADD_CFLAGS('-g', testflags=True)
|
|
||||||
|
|
||||||
--
|
|
||||||
2.18.0
|
|
||||||
|
|
17
samba.spec
17
samba.spec
@ -6,13 +6,13 @@
|
|||||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||||
%bcond_without clustering
|
%bcond_without clustering
|
||||||
|
|
||||||
%define main_release 2
|
%define main_release 0
|
||||||
|
|
||||||
%define samba_version 4.9.1
|
%define samba_version 4.9.2
|
||||||
%define talloc_version 2.1.14
|
%define talloc_version 2.1.14
|
||||||
%define tdb_version 1.3.16
|
%define tdb_version 1.3.16
|
||||||
%define tevent_version 0.9.37
|
%define tevent_version 0.9.37
|
||||||
%define ldb_version 1.4.2
|
%define ldb_version 1.4.3
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release %nil
|
%define pre_release %nil
|
||||||
|
|
||||||
@ -120,8 +120,6 @@ Source14: samba.pamd
|
|||||||
|
|
||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch0: samba-4.9.0rc5-stack-protector.patch
|
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
@ -1504,6 +1502,7 @@ fi
|
|||||||
%{_libdir}/samba/libcli-smb-common-samba4.so
|
%{_libdir}/samba/libcli-smb-common-samba4.so
|
||||||
%{_libdir}/samba/libcli-spoolss-samba4.so
|
%{_libdir}/samba/libcli-spoolss-samba4.so
|
||||||
%{_libdir}/samba/libcliauth-samba4.so
|
%{_libdir}/samba/libcliauth-samba4.so
|
||||||
|
%{_libdir}/samba/libcmdline-contexts-samba4.so
|
||||||
%{_libdir}/samba/libcmdline-credentials-samba4.so
|
%{_libdir}/samba/libcmdline-credentials-samba4.so
|
||||||
%{_libdir}/samba/libcommon-auth-samba4.so
|
%{_libdir}/samba/libcommon-auth-samba4.so
|
||||||
%{_libdir}/samba/libctdb-event-client-samba4.so
|
%{_libdir}/samba/libctdb-event-client-samba4.so
|
||||||
@ -1599,6 +1598,7 @@ fi
|
|||||||
### COMMON-libs
|
### COMMON-libs
|
||||||
%files common-libs
|
%files common-libs
|
||||||
# common libraries
|
# common libraries
|
||||||
|
%{_libdir}/samba/libpopt-samba3-cmdline-samba4.so
|
||||||
%{_libdir}/samba/libpopt-samba3-samba4.so
|
%{_libdir}/samba/libpopt-samba3-samba4.so
|
||||||
%if %{with_intel_aes_accel}
|
%if %{with_intel_aes_accel}
|
||||||
%{_libdir}/samba/libaesni-intel-samba4.so
|
%{_libdir}/samba/libaesni-intel-samba4.so
|
||||||
@ -2159,6 +2159,7 @@ fi
|
|||||||
%{python2_sitearch}/samba/tests/auth_log_samlogon.py*
|
%{python2_sitearch}/samba/tests/auth_log_samlogon.py*
|
||||||
%dir %{python2_sitearch}/samba/tests/blackbox
|
%dir %{python2_sitearch}/samba/tests/blackbox
|
||||||
%{python2_sitearch}/samba/tests/blackbox/__init__.py*
|
%{python2_sitearch}/samba/tests/blackbox/__init__.py*
|
||||||
|
%{python2_sitearch}/samba/tests/blackbox/bug13653.py*
|
||||||
%{python2_sitearch}/samba/tests/blackbox/check_output.py*
|
%{python2_sitearch}/samba/tests/blackbox/check_output.py*
|
||||||
%{python2_sitearch}/samba/tests/blackbox/ndrdump.py*
|
%{python2_sitearch}/samba/tests/blackbox/ndrdump.py*
|
||||||
%{python2_sitearch}/samba/tests/blackbox/samba_dnsupdate.py*
|
%{python2_sitearch}/samba/tests/blackbox/samba_dnsupdate.py*
|
||||||
@ -2663,6 +2664,7 @@ fi
|
|||||||
%{python3_sitearch}/samba/tests/blackbox/__init__.py
|
%{python3_sitearch}/samba/tests/blackbox/__init__.py
|
||||||
%dir %{python3_sitearch}/samba/tests/blackbox/__pycache__
|
%dir %{python3_sitearch}/samba/tests/blackbox/__pycache__
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/__init__.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/__init__.*.pyc
|
||||||
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/bug13653.*.pyc
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/check_output.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/check_output.*.pyc
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/ndrdump.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/ndrdump.*.pyc
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/samba_dnsupdate.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/samba_dnsupdate.*.pyc
|
||||||
@ -2670,6 +2672,7 @@ fi
|
|||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_learner.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_learner.*.pyc
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_replay.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_replay.*.pyc
|
||||||
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_summary.*.pyc
|
%{python3_sitearch}/samba/tests/blackbox/__pycache__/traffic_summary.*.pyc
|
||||||
|
%{python3_sitearch}/samba/tests/blackbox/bug13653.py
|
||||||
%{python3_sitearch}/samba/tests/blackbox/check_output.py
|
%{python3_sitearch}/samba/tests/blackbox/check_output.py
|
||||||
%{python3_sitearch}/samba/tests/blackbox/ndrdump.py
|
%{python3_sitearch}/samba/tests/blackbox/ndrdump.py
|
||||||
%{python3_sitearch}/samba/tests/blackbox/samba_dnsupdate.py
|
%{python3_sitearch}/samba/tests/blackbox/samba_dnsupdate.py
|
||||||
@ -3566,6 +3569,7 @@ fi
|
|||||||
%{_datadir}/ctdb/tests/simple/56_replicated_transaction_recovery.sh
|
%{_datadir}/ctdb/tests/simple/56_replicated_transaction_recovery.sh
|
||||||
%{_datadir}/ctdb/tests/simple/58_ctdb_restoredb.sh
|
%{_datadir}/ctdb/tests/simple/58_ctdb_restoredb.sh
|
||||||
%{_datadir}/ctdb/tests/simple/60_recoverd_missing_ip.sh
|
%{_datadir}/ctdb/tests/simple/60_recoverd_missing_ip.sh
|
||||||
|
%{_datadir}/ctdb/tests/simple/69_recovery_resurrect_deleted.sh
|
||||||
%{_datadir}/ctdb/tests/simple/70_recoverpdbbyseqnum.sh
|
%{_datadir}/ctdb/tests/simple/70_recoverpdbbyseqnum.sh
|
||||||
%{_datadir}/ctdb/tests/simple/71_ctdb_wipedb.sh
|
%{_datadir}/ctdb/tests/simple/71_ctdb_wipedb.sh
|
||||||
%{_datadir}/ctdb/tests/simple/72_update_record_persistent.sh
|
%{_datadir}/ctdb/tests/simple/72_update_record_persistent.sh
|
||||||
@ -3812,6 +3816,9 @@ fi
|
|||||||
%endif # with_clustering_support
|
%endif # with_clustering_support
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 08 2018 Guenther Deschner <gdeschner@redhat.com> - 4.9.2-0
|
||||||
|
- Update to Samba 4.9.2
|
||||||
|
|
||||||
* Wed Sep 26 2018 Alexander Bokovoy <abokovoy@redhat.com> - 4.9.1-2
|
* Wed Sep 26 2018 Alexander Bokovoy <abokovoy@redhat.com> - 4.9.1-2
|
||||||
- Package ctdb/doc/examples
|
- Package ctdb/doc/examples
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (samba-4.9.1.tar.asc) = 2e961c1bddf952fb28268fba1925e567b122a8385a05b5b936dc2affc5da79404620735f77120a79b984115b0702100af208c53a8eb46544a9939715aea74123
|
SHA512 (samba-4.9.2.tar.xz) = 0b4ff4a0417e9612fd6046ba7e7b0fc82ffffe71a49824808401ab9f4580f258bd83d97942fe4e97ea05743debcd943c8afab1c3694eb5267497e71cdcb08045
|
||||||
SHA512 (samba-4.9.1.tar.xz) = b3d5a524382ae6f9f41add2bc342658097a63e756f95b4ea05f855c2aaa317b77e81a06d650e33c5b2afc2d6c558e03bafa4af4037ade071962b65407e91c9c0
|
SHA512 (samba-4.9.2.tar.asc) = 93155bebba6fe69b924761c268647f980669cf5ec75673ed5eb281d5864836d326a804b6853de58f716f13ff27645a0384a61e98e7be94137d4f7dc09c917c3e
|
||||||
|
Loading…
Reference in New Issue
Block a user