3.0.23
This commit is contained in:
parent
0b239ed861
commit
035c67cee2
@ -1 +1 @@
|
||||
samba-3.0.23rc3.tar.gz
|
||||
samba-3.0.23.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
#!/bin/sh
|
||||
|
||||
/usr/lib/rpm/perl.req $* | grep -E -v '(Net::LDAP|Crypt::SmbHash|CGI)'
|
||||
/usr/lib/rpm/perl.req $* | grep -E -v '(Net::LDAP|Crypt::SmbHash|CGI|Unicode::MapUTF8)'
|
||||
|
||||
|
52
samba-3.0.23-logfiles.patch
Normal file
52
samba-3.0.23-logfiles.patch
Normal file
@ -0,0 +1,52 @@
|
||||
--- samba-3.0.23rc2/source/lib/popt_common.c.logfiles 2006-06-09 15:30:31.000000000 -0400
|
||||
+++ samba-3.0.23rc2/source/lib/popt_common.c 2006-06-14 12:20:02.000000000 -0400
|
||||
@@ -54,7 +54,7 @@
|
||||
else
|
||||
pname++;
|
||||
|
||||
- pstr_sprintf(logfile, "%s/log.%s", arg, pname);
|
||||
+ pstr_sprintf(logfile, "%s/%s.log", arg, pname);
|
||||
lp_set_logfile(logfile);
|
||||
}
|
||||
|
||||
--- samba-3.0.8pre1/source/nmbd/nmbd.c.logfiles 2004-09-22 08:42:14.000000000 -0400
|
||||
+++ samba-3.0.8pre1/source/nmbd/nmbd.c 2004-09-27 14:16:59.000000000 -0400
|
||||
@@ -626,7 +626,7 @@
|
||||
sys_srandom(time(NULL) ^ sys_getpid());
|
||||
|
||||
if (!override_logfile) {
|
||||
- slprintf(logfile, sizeof(logfile)-1, "%s/log.nmbd", dyn_LOGFILEBASE);
|
||||
+ slprintf(logfile, sizeof(logfile)-1, "%s/nmbd.log", dyn_LOGFILEBASE);
|
||||
lp_set_logfile(logfile);
|
||||
}
|
||||
|
||||
--- samba-3.0.8pre1/source/nsswitch/winbindd.c.logfiles 2004-09-22 08:42:13.000000000 -0400
|
||||
+++ samba-3.0.8pre1/source/nsswitch/winbindd.c 2004-09-27 14:17:35.000000000 -0400
|
||||
@@ -856,7 +856,7 @@
|
||||
}
|
||||
|
||||
if (!override_logfile) {
|
||||
- pstr_sprintf(logfile, "%s/log.winbindd", dyn_LOGFILEBASE);
|
||||
+ pstr_sprintf(logfile, "%s/winbindd.log", dyn_LOGFILEBASE);
|
||||
lp_set_logfile(logfile);
|
||||
}
|
||||
setup_logging("winbindd", log_stdout);
|
||||
--- samba-3.0.11/packaging/Fedora/samba.log.logfiles 2005-02-03 22:07:48.000000000 -0500
|
||||
+++ samba-3.0.11/packaging/Fedora/samba.log 2005-02-04 16:17:00.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-/var/log/samba/*.log /var/log/samba/log.smbd /var/log/samba/log.nmbd {
|
||||
+/var/log/samba/*.log {
|
||||
notifempty
|
||||
missingok
|
||||
sharedscripts
|
||||
--- samba-3.0.23/packaging/Fedora/smb.conf.logfiles 2006-07-11 11:23:52.000000000 -0400
|
||||
+++ samba-3.0.23/packaging/Fedora/smb.conf 2006-07-11 11:27:00.000000000 -0400
|
||||
@@ -63,7 +63,7 @@
|
||||
|
||||
# this tells Samba to use a separate log file for each machine
|
||||
# that connects
|
||||
- log file = /usr/local/samba/var/log.%m
|
||||
+ log file = /usr/local/samba/var/%m.log
|
||||
|
||||
# Put a capping on the size of the log files (in Kb).
|
||||
max log size = 50
|
12
samba-3.0.23-smb.conf.patch
Normal file
12
samba-3.0.23-smb.conf.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- samba-3.0.23/packaging/Fedora/smb.conf.upstream 2006-07-11 11:29:05.000000000 -0400
|
||||
+++ samba-3.0.23/packaging/Fedora/smb.conf 2006-07-11 11:30:45.000000000 -0400
|
||||
@@ -57,6 +57,9 @@
|
||||
# bsd, cups, sysv, plp, lprng, aix, hpux, qnx
|
||||
; printing = cups
|
||||
|
||||
+# This option tells cups that the data has already been rasterized
|
||||
+cups options = raw
|
||||
+
|
||||
# Uncomment this if you want a guest account, you must add this to /etc/passwd
|
||||
# otherwise the user "nobody" is used
|
||||
; guest account = pcguest
|
20
samba.spec
20
samba.spec
@ -3,15 +3,15 @@
|
||||
Summary: The Samba SMB server.
|
||||
Name: samba
|
||||
Version: 3.0.23
|
||||
Release: 0.RC3
|
||||
Release: 2
|
||||
Epoch: 0
|
||||
License: GNU GPL Version 2
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.samba.org/
|
||||
|
||||
#TAG: change for non-pre
|
||||
Source: ftp://us2.samba.org/pub/samba/%{name}-%{version}rc3.tar.gz
|
||||
#Source: ftp://us2.samba.org/pub/samba/%{name}-%{version}.tar.gz
|
||||
#Source: ftp://us2.samba.org/pub/samba/%{name}-%{version}rc3.tar.gz
|
||||
Source: ftp://us2.samba.org/pub/samba/%{name}-%{version}.tar.gz
|
||||
|
||||
# Red Hat specific replacement-files
|
||||
Source1: samba.log
|
||||
@ -33,9 +33,9 @@ Source999: filter-requires-samba.sh
|
||||
# generic patches
|
||||
Patch101: samba-2.2.0-smbw.patch
|
||||
Patch102: samba-3.0.0beta1-pipedir.patch
|
||||
Patch103: samba-3.0.23rc2-logfiles.patch
|
||||
Patch103: samba-3.0.23-logfiles.patch
|
||||
Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
||||
Patch105: samba-3.0.21b-smb.conf.patch
|
||||
Patch105: samba-3.0.23-smb.conf.patch
|
||||
Patch106: samba-3.0.20pre1-man.patch
|
||||
# The passwd part has been applied, but not the group part
|
||||
Patch107: samba-3.0.23rc3-passwd.patch
|
||||
@ -100,8 +100,8 @@ Web browser.
|
||||
|
||||
%prep
|
||||
# TAG: change for non-pre
|
||||
%setup -q -n samba-3.0.23rc3
|
||||
# % setup -q
|
||||
# % setup -q -n samba-3.0.23rc3
|
||||
%setup -q
|
||||
|
||||
# copy Red Hat specific scripts
|
||||
mkdir packaging/Fedora
|
||||
@ -446,6 +446,12 @@ fi
|
||||
%{_mandir}/man7/libsmbclient.7*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 11 2006 Jay Fenlason <fenlason@redhat.com> 3.0.23-2
|
||||
- New upstream release.
|
||||
- Use modified filter-requires-samba.sh from packaging/RHEL/setup/
|
||||
to get rid of bogus dependency on perl(Unicode::MapUTF8)
|
||||
- Update the -logfiles and -smb.conf patches to work with 3.0.23
|
||||
|
||||
* Thu Jul 6 2006 Jay Fenlason <fenlason@redhat.com> 3.0.23-0.RC3
|
||||
- New upstream RC release.
|
||||
- Update the -logfiles, and -passwd patches for
|
||||
|
Loading…
Reference in New Issue
Block a user