57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From c33cc5a6198a9d32c2fe8da8cd3038627d99ebab Mon Sep 17 00:00:00 2001
|
|
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
Date: Wed, 17 Oct 2018 13:52:48 +0200
|
|
Subject: [PATCH] zkey: Makefile: Avoid relink of modules during 'make install'
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Because targets check-dep-zkey and check-dep-zkey-cryptsetup
|
|
do not produce any file, any targets that have a pre-req on those
|
|
targets are rebuilt during 'make install'.
|
|
|
|
Also correct .PHONY targets.
|
|
|
|
Fixes: https://github.com/ibm-s390-tools/s390-tools/issues/46
|
|
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
|
---
|
|
zkey/Makefile | 9 +++++++--
|
|
1 file changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/zkey/Makefile b/zkey/Makefile
|
|
index 901ddd4..bc7bc33 100644
|
|
--- a/zkey/Makefile
|
|
+++ b/zkey/Makefile
|
|
@@ -37,6 +37,7 @@ check-dep-zkey:
|
|
"openssl/evp.h", \
|
|
"openssl-devel", \
|
|
"HAVE_OPENSSL=0")
|
|
+ touch check-dep-zkey
|
|
|
|
check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
|
$(call check_dep, \
|
|
@@ -50,6 +51,7 @@ check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
|
"json-c/json.h", \
|
|
"json-c-devel", \
|
|
"HAVE_JSONC=0")
|
|
+ touch check-dep-zkey-cryptsetup
|
|
|
|
zkey-skip:
|
|
echo " SKIP zkey due to HAVE_OPENSSL=0"
|
|
@@ -93,6 +95,9 @@ install-zkey-cryptsetup:
|
|
install: all install-common $(INSTALL_TARGETS)
|
|
|
|
clean:
|
|
- rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h
|
|
+ rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h \
|
|
+ check-dep-zkey check-dep-zkey-cryptsetup
|
|
|
|
-.PHONY: all install clean
|
|
+.PHONY: all install clean zkey-skip zkey-cryptsetup-skip-cryptsetup2 \
|
|
+ zkey-cryptsetup-skip-jsonc install-common install-zkey \
|
|
+ install-zkey-cryptsetup
|
|
--
|
|
2.17.2
|
|
|