- don't relink the zkey tools
This commit is contained in:
parent
c301cb59af
commit
2ff30e744f
56
s390-tools-zkey-no-relink.patch
Normal file
56
s390-tools-zkey-no-relink.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From c33cc5a6198a9d32c2fe8da8cd3038627d99ebab Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Wed, 17 Oct 2018 13:52:48 +0200
|
||||
Subject: [PATCH] zkey: Makefile: Avoid relink of modules during 'make install'
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Because targets check-dep-zkey and check-dep-zkey-cryptsetup
|
||||
do not produce any file, any targets that have a pre-req on those
|
||||
targets are rebuilt during 'make install'.
|
||||
|
||||
Also correct .PHONY targets.
|
||||
|
||||
Fixes: https://github.com/ibm-s390-tools/s390-tools/issues/46
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Signed-off-by: Jan Höppner <hoeppner@linux.ibm.com>
|
||||
---
|
||||
zkey/Makefile | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/zkey/Makefile b/zkey/Makefile
|
||||
index 901ddd4..bc7bc33 100644
|
||||
--- a/zkey/Makefile
|
||||
+++ b/zkey/Makefile
|
||||
@@ -37,6 +37,7 @@ check-dep-zkey:
|
||||
"openssl/evp.h", \
|
||||
"openssl-devel", \
|
||||
"HAVE_OPENSSL=0")
|
||||
+ touch check-dep-zkey
|
||||
|
||||
check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
||||
$(call check_dep, \
|
||||
@@ -50,6 +51,7 @@ check-dep-zkey-cryptsetup: detect-libcryptsetup.h
|
||||
"json-c/json.h", \
|
||||
"json-c-devel", \
|
||||
"HAVE_JSONC=0")
|
||||
+ touch check-dep-zkey-cryptsetup
|
||||
|
||||
zkey-skip:
|
||||
echo " SKIP zkey due to HAVE_OPENSSL=0"
|
||||
@@ -93,6 +95,9 @@ install-zkey-cryptsetup:
|
||||
install: all install-common $(INSTALL_TARGETS)
|
||||
|
||||
clean:
|
||||
- rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h
|
||||
+ rm -f *.o zkey zkey-cryptsetup detect-libcryptsetup.h \
|
||||
+ check-dep-zkey check-dep-zkey-cryptsetup
|
||||
|
||||
-.PHONY: all install clean
|
||||
+.PHONY: all install clean zkey-skip zkey-cryptsetup-skip-cryptsetup2 \
|
||||
+ zkey-cryptsetup-skip-jsonc install-common install-zkey \
|
||||
+ install-zkey-cryptsetup
|
||||
--
|
||||
2.17.2
|
||||
|
@ -5,7 +5,7 @@ Name: s390utils
|
||||
Summary: Utilities and daemons for IBM z Systems
|
||||
Group: System Environment/Base
|
||||
Version: 2.6.0
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
Epoch: 2
|
||||
License: MIT
|
||||
ExclusiveArch: s390 s390x
|
||||
@ -36,6 +36,8 @@ Patch1: s390-tools-zipl-fiemap.patch
|
||||
# https://github.com/ibm-s390-tools/s390-tools/pull/35
|
||||
Patch2: s390-tools-cleanup.patch
|
||||
Patch3: 0007-blscfg-sort-like-rpm-nvr-not-like-a-single-version.patch
|
||||
# https://github.com/ibm-s390-tools/s390-tools/issues/46
|
||||
Patch4: s390-tools-zkey-no-relink.patch
|
||||
|
||||
Patch1000: cmsfs-1.1.8-warnings.patch
|
||||
Patch1001: cmsfs-1.1.8-kernel26.patch
|
||||
@ -68,6 +70,7 @@ be used together with the zSeries (s390) Linux kernel and device drivers.
|
||||
%patch1 -p1 -b .zipl-fiemap
|
||||
%patch2 -p1 -b .cleanup
|
||||
%patch3 -p1 -b .blscfg-rpm-nvr-sort
|
||||
%patch4 -p1 -b .zkey-no-relink
|
||||
|
||||
#
|
||||
# cmsfs
|
||||
@ -813,6 +816,9 @@ User-space development files for the s390/s390x architecture.
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 22 2018 Dan Horák <dan[at]danny.cz> - 2:2.6.0-8
|
||||
- don't relink the zkey tools
|
||||
|
||||
* Mon Oct 15 2018 Peter Jones <pjones@redhat.com> - 2.6.0-7
|
||||
- Make the blscfg sort order match what grub2 and grubby do. (pjones)
|
||||
- Add a ~debug suffix instead of -debug to sort it correctly. (javierm)
|
||||
|
Loading…
Reference in New Issue
Block a user