Initial support for OpenSSL 3.0.0-alpha15
Resolves: rhbz#1948976
This commit is contained in:
parent
7f4b98b7bf
commit
c6ba796773
1
.gitignore
vendored
1
.gitignore
vendored
@ -341,3 +341,4 @@
|
||||
/rust-1.51.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rust-openssl-cc1c74c1a313ac46b5fa3da602a46cff6fdd06a2.tar.gz
|
||||
|
30
rust-openssl-300.patch
Normal file
30
rust-openssl-300.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- rustc-1.52.0-src/Cargo.lock.orig 2021-05-03 13:57:16.000000000 -0700
|
||||
+++ rustc-1.52.0-src/Cargo.lock 2021-05-05 17:33:12.300459810 -0700
|
||||
@@ -2402,15 +2402,15 @@ dependencies = [
|
||||
|
||||
[[package]]
|
||||
name = "openssl"
|
||||
-version = "0.10.30"
|
||||
+version = "0.10.33"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "8d575eff3665419f9b83678ff2815858ad9d11567e082f5ac1814baba4e2bcb4"
|
||||
dependencies = [
|
||||
"bitflags",
|
||||
- "cfg-if 0.1.10",
|
||||
+ "cfg-if 1.0.0",
|
||||
"foreign-types",
|
||||
- "lazy_static",
|
||||
"libc",
|
||||
+ "once_cell",
|
||||
"openssl-sys",
|
||||
]
|
||||
|
||||
@@ -2431,7 +2431,7 @@ dependencies = [
|
||||
|
||||
[[package]]
|
||||
name = "openssl-sys"
|
||||
-version = "0.9.58"
|
||||
+version = "0.9.61"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "a842db4709b604f0fe5d1170ae3565899be2ad3d9cbc72dedc789ac0511f78de"
|
||||
dependencies = [
|
12
rust.spec
12
rust.spec
@ -84,6 +84,13 @@ Patch101: rustc-1.51.0-disable-http2.patch
|
||||
# (affects RHEL6 kernels when building for RHEL7)
|
||||
Patch102: rustc-1.51.0-no-default-pie.patch
|
||||
|
||||
# Initial support for OpenSSL 3.0.0-alpha15
|
||||
# https://github.com/sfackler/rust-openssl/pull/1264
|
||||
%global rust_openssl_commit cc1c74c1a313ac46b5fa3da602a46cff6fdd06a2
|
||||
%global rust_openssl rust-openssl-%{rust_openssl_commit}
|
||||
Source103: https://github.com/sfackler/rust-openssl/archive/%{rust_openssl_commit}/%{rust_openssl}.tar.gz
|
||||
Patch103: rust-openssl-300.patch
|
||||
|
||||
|
||||
# Get the Rust triple for any arch.
|
||||
%{lua: function rust_triple(arch)
|
||||
@ -442,6 +449,10 @@ rm -rf vendor/libgit2-sys/libgit2/
|
||||
rm -rf vendor/libssh2-sys/
|
||||
%endif
|
||||
|
||||
rm -rf vendor/openssl{,-sys}/*
|
||||
tar -xf %{SOURCE103} -C vendor/ --strip-components=1 %{rust_openssl}/openssl{,-sys}/
|
||||
%patch103 -p1
|
||||
|
||||
# This only affects the transient rust-installer, but let it use our dynamic xz-libs
|
||||
sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
|
||||
|
||||
@ -735,6 +746,7 @@ export %{rust_env}
|
||||
* Thu May 13 2021 Josh Stone <jistone@redhat.com> - 1.52.1-1
|
||||
- Update to 1.52.1. Includes security fixes for CVE-2020-36323,
|
||||
CVE-2021-28876, CVE-2021-28878, CVE-2021-28879, and CVE-2021-31162.
|
||||
- Initial support for OpenSSL 3.0.0-alpha15
|
||||
|
||||
* Wed Apr 28 2021 Josh Stone <jistone@redhat.com> - 1.51.0-1
|
||||
- Update to 1.51.0. Includes security fixes for CVE-2021-28875
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
SHA512 (rustc-1.52.1-src.tar.xz) = 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
|
||||
SHA512 (rust-openssl-cc1c74c1a313ac46b5fa3da602a46cff6fdd06a2.tar.gz) = 5a267b255db3ebf66d5bcff9a2f03f4c8cebd74486daa9bef35426002898fb941c28bacb40972da96ddad8c17aae51919d18b72e326e9db47e32af2c8100ed37
|
||||
|
@ -4,3 +4,4 @@ SHA512 (rust-1.51.0-i686-unknown-linux-gnu.tar.xz) = 05d08e44827dcba8197667deb9a
|
||||
SHA512 (rust-1.51.0-powerpc64le-unknown-linux-gnu.tar.xz) = b53a741d1d75637fb31ddb0364e1f91427c3818ca145f819b906d13c32c638ae77fbaa567a6220b6bf69f38cc00d2b95615778a86f4acadd63efe2e62b1b01ef
|
||||
SHA512 (rust-1.51.0-s390x-unknown-linux-gnu.tar.xz) = a72ad31c6306f939c4f963133ddc0b3fabc9e506bdff5e318f5275658b7271a675a51d208d306d94fb01739cbcf0f62f018fc7490ca6db54b301852202749d16
|
||||
SHA512 (rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz) = 9f95045119bcd5ef7be54f5b5bdc9ebc6bd6c48437d90762a1cfbc03281882f81087e1877eecae9573ba5e7cd7c11ef5fed979034c57f45b6547cbfeb11eef6d
|
||||
SHA512 (rust-openssl-cc1c74c1a313ac46b5fa3da602a46cff6fdd06a2.tar.gz) = 5a267b255db3ebf66d5bcff9a2f03f4c8cebd74486daa9bef35426002898fb941c28bacb40972da96ddad8c17aae51919d18b72e326e9db47e32af2c8100ed37
|
||||
|
Loading…
Reference in New Issue
Block a user