Update to 1.52.1.
Related: rhbz#1947202 Resolves: rhbz#1952539 Resolves: rhbz#1952541 Resolves: rhbz#1952547 Resolves: rhbz#1952982 Resolves: rhbz#1952984 Resolves: rhbz#1953007 Resolves: rhbz#1954944
This commit is contained in:
parent
4fc7c95a13
commit
7f4b98b7bf
6
.gitignore
vendored
6
.gitignore
vendored
@ -335,3 +335,9 @@
|
||||
/rust-1.50.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.50.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.50.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
/rustc-1.52.1-src.tar.xz
|
||||
/rust-1.51.0-aarch64-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-i686-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-powerpc64le-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-s390x-unknown-linux-gnu.tar.xz
|
||||
/rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz
|
||||
|
31
rust.spec
31
rust.spec
@ -9,10 +9,10 @@
|
||||
# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
|
||||
# or nightly wants some beta-YYYY-MM-DD
|
||||
# Note that cargo matches the program version here, not its crate version.
|
||||
%global bootstrap_rust 1.50.0
|
||||
%global bootstrap_cargo 1.50.0
|
||||
%global bootstrap_channel 1.50.0
|
||||
%global bootstrap_date 2021-02-11
|
||||
%global bootstrap_rust 1.51.0
|
||||
%global bootstrap_cargo 1.51.0
|
||||
%global bootstrap_channel 1.51.0
|
||||
%global bootstrap_date 2021-03-25
|
||||
|
||||
# Only the specified arches will use bootstrap binaries.
|
||||
#global bootstrap_arches %%{rust_arches}
|
||||
@ -52,7 +52,7 @@
|
||||
%endif
|
||||
|
||||
Name: rust
|
||||
Version: 1.51.0
|
||||
Version: 1.52.1
|
||||
Release: 1%{?dist}
|
||||
Summary: The Rust Programming Language
|
||||
License: (ASL 2.0 or MIT) and (BSD and MIT)
|
||||
@ -71,10 +71,6 @@ Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
|
||||
# https://github.com/rust-lang/rust/issues/80810#issuecomment-781784032
|
||||
Patch1: 0001-Revert-Auto-merge-of-79547.patch
|
||||
|
||||
# Fix bootstrap for stage0 rust 1.51
|
||||
# https://github.com/rust-lang/rust/pull/81910
|
||||
Patch2: rustc-1.51.0-backport-pr81910.patch
|
||||
|
||||
### RHEL-specific patches below ###
|
||||
|
||||
# Disable cargo->libgit2->libssh2 on RHEL, as it's not approved for FIPS (rhbz1732949)
|
||||
@ -168,17 +164,13 @@ BuildRequires: pkgconfig(libssh2) >= 1.6.0
|
||||
BuildRequires: %{python}
|
||||
|
||||
%if %with bundled_llvm
|
||||
BuildRequires: cmake3 >= 3.4.3
|
||||
Provides: bundled(llvm) = 11.0.1
|
||||
BuildRequires: cmake3 >= 3.13.4
|
||||
Provides: bundled(llvm) = 12.0.0
|
||||
%else
|
||||
BuildRequires: cmake >= 2.8.11
|
||||
%if 0%{?epel} == 7
|
||||
%global llvm llvm9.0
|
||||
%endif
|
||||
%if 0%{?fedora} >= 34
|
||||
# we're not ready for llvm-12 yet
|
||||
%global llvm llvm11
|
||||
%endif
|
||||
%if %defined llvm
|
||||
%global llvm_root %{_libdir}/%{llvm}
|
||||
%else
|
||||
@ -409,7 +401,6 @@ test -f '%{local_rust_root}/bin/rustc'
|
||||
%setup -q -n %{rustc_package}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%if %with disabled_libssh2
|
||||
%patch100 -p1
|
||||
@ -688,6 +679,7 @@ export %{rust_env}
|
||||
%{_docdir}/%{name}/html/*.png
|
||||
%{_docdir}/%{name}/html/*.svg
|
||||
%{_docdir}/%{name}/html/*.woff
|
||||
%{_docdir}/%{name}/html/*.woff2
|
||||
%license %{_docdir}/%{name}/html/*.txt
|
||||
%license %{_docdir}/%{name}/html/*.md
|
||||
|
||||
@ -740,8 +732,13 @@ export %{rust_env}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 13 2021 Josh Stone <jistone@redhat.com> - 1.52.1-1
|
||||
- Update to 1.52.1. Includes security fixes for CVE-2020-36323,
|
||||
CVE-2021-28876, CVE-2021-28878, CVE-2021-28879, and CVE-2021-31162.
|
||||
|
||||
* Wed Apr 28 2021 Josh Stone <jistone@redhat.com> - 1.51.0-1
|
||||
- Update to 1.51.0.
|
||||
- Update to 1.51.0. Includes security fixes for CVE-2021-28875
|
||||
and CVE-2021-28877.
|
||||
|
||||
* Tue Apr 27 2021 Josh Stone <jistone@redhat.com> - 1.50.0-1
|
||||
- Update to 1.50.0.
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 852684d306cee955ed751f1e8d8eec6adaecff3b Mon Sep 17 00:00:00 2001
|
||||
From: Joshua Nelson <jyn514@gmail.com>
|
||||
Date: Mon, 8 Feb 2021 22:51:21 -0500
|
||||
Subject: [PATCH] Use format string in bootstrap panic instead of a string
|
||||
directly
|
||||
|
||||
This fixes the following warning when compiling with nightly:
|
||||
|
||||
```
|
||||
warning: panic message is not a string literal
|
||||
--> src/bootstrap/builder.rs:1515:24
|
||||
|
|
||||
1515 | panic!(out);
|
||||
| ^^^
|
||||
|
|
||||
= note: `#[warn(non_fmt_panic)]` on by default
|
||||
= note: this is no longer accepted in Rust 2021
|
||||
help: add a "{}" format string to Display the message
|
||||
|
|
||||
1515 | panic!("{}", out);
|
||||
| ^^^^^
|
||||
help: or use std::panic::panic_any instead
|
||||
|
|
||||
1515 | std::panic::panic_any(out);
|
||||
| ^^^^^^^^^^^^^^^^^^^^^^
|
||||
```
|
||||
|
||||
(cherry picked from commit 31c93397bde772764cda3058e16f9cef61895090)
|
||||
---
|
||||
src/bootstrap/builder.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
|
||||
index f1a160250dbe..0f5fcb4af400 100644
|
||||
--- a/src/bootstrap/builder.rs
|
||||
+++ b/src/bootstrap/builder.rs
|
||||
@@ -1490,7 +1490,7 @@ pub fn ensure<S: Step>(&'a self, step: S) -> S::Output {
|
||||
for el in stack.iter().rev() {
|
||||
out += &format!("\t{:?}\n", el);
|
||||
}
|
||||
- panic!(out);
|
||||
+ panic!("{}", out);
|
||||
}
|
||||
if let Some(out) = self.cache.get(&step) {
|
||||
self.verbose(&format!("{}c {:?}", " ".repeat(stack.len()), step));
|
||||
--
|
||||
2.31.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rustc-1.51.0-src.tar.xz) = ded91468ddf3e6627f00e7ec3d44452aa24eb727a183c0de9d90264f593119a54300d56b09251a88260db480b48554181ae195c538996a32d68d48b6587ac0df
|
||||
SHA512 (rustc-1.52.1-src.tar.xz) = 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
|
||||
|
@ -1,6 +1,6 @@
|
||||
SHA512 (rustc-1.51.0-src.tar.xz) = ded91468ddf3e6627f00e7ec3d44452aa24eb727a183c0de9d90264f593119a54300d56b09251a88260db480b48554181ae195c538996a32d68d48b6587ac0df
|
||||
SHA512 (rust-1.50.0-aarch64-unknown-linux-gnu.tar.xz) = e6b409afc8e85a88ecb9ff439a6eb9dcb93d5553e81549fb4f332b9e2d946dce0424319c5092e60aab9435944af70d0117d15c12d54d2059ef73c1fdf36d8273
|
||||
SHA512 (rust-1.50.0-i686-unknown-linux-gnu.tar.xz) = bff117733d11731f56e8659265d0b47327e2af3f7c46aca494747a92b4f634dd35fa9731a1be59dd69821042f88bded253e1d7b5693ca237c9a167408ca7f898
|
||||
SHA512 (rust-1.50.0-powerpc64le-unknown-linux-gnu.tar.xz) = e3dc75ba7dff3a358042542afa398ec8771a23f5f699454a876ddc1f3583d399fe5350696a5da62d71ca97ea882c9ae1fcb60dc2e9fdf76bc7a9af892096371e
|
||||
SHA512 (rust-1.50.0-s390x-unknown-linux-gnu.tar.xz) = 733513af2a7ef7a782a5ebfbd080071194ac47084022b54b4830de84facef9986d65525f8666a4c226e9878e43b00ebced26d6077e5fb1b7f775ac8f290fba97
|
||||
SHA512 (rust-1.50.0-x86_64-unknown-linux-gnu.tar.xz) = ab49e3ecb14e4af8e48548845184e9ab3d564ab2341c1e5462b7847347c79d13324211b860988d219ccb646143bf142fb14c3ab03663b06cfe9ca275128d9fa0
|
||||
SHA512 (rustc-1.52.1-src.tar.xz) = 55f5053ce40d4eba4663052817aef6a6275139ca229c89cd1ec44711458b412720203301d8c7975aac5720a91fcaf21847f8184f641cbb0004f722520283c73c
|
||||
SHA512 (rust-1.51.0-aarch64-unknown-linux-gnu.tar.xz) = 2af31290e1065a4611f34e6cc8c62ee494c222becfb21ec6707059c119069b0adf0eec23e56bad4a3cc8690b2556309ec58cbd9003a959983689cc46c7c63361
|
||||
SHA512 (rust-1.51.0-i686-unknown-linux-gnu.tar.xz) = 05d08e44827dcba8197667deb9a7f3584465085ce1b79a38deb138849a07c716646a70f1cc2cee02b41c45ec7c3a3b7800a3fae62ebe04d6f72f017a5d722bab
|
||||
SHA512 (rust-1.51.0-powerpc64le-unknown-linux-gnu.tar.xz) = b53a741d1d75637fb31ddb0364e1f91427c3818ca145f819b906d13c32c638ae77fbaa567a6220b6bf69f38cc00d2b95615778a86f4acadd63efe2e62b1b01ef
|
||||
SHA512 (rust-1.51.0-s390x-unknown-linux-gnu.tar.xz) = a72ad31c6306f939c4f963133ddc0b3fabc9e506bdff5e318f5275658b7271a675a51d208d306d94fb01739cbcf0f62f018fc7490ca6db54b301852202749d16
|
||||
SHA512 (rust-1.51.0-x86_64-unknown-linux-gnu.tar.xz) = 9f95045119bcd5ef7be54f5b5bdc9ebc6bd6c48437d90762a1cfbc03281882f81087e1877eecae9573ba5e7cd7c11ef5fed979034c57f45b6547cbfeb11eef6d
|
||||
|
Loading…
Reference in New Issue
Block a user