Update to 0.4.1

Also, remove sev dependency patch introduced in
70b868feb7

Signed-off-by: Tyler Fanelli <tfanelli@redhat.com>
This commit is contained in:
Tyler Fanelli 2023-07-19 23:50:22 -04:00 committed by Yaakov Selkowitz
parent 51da1368e7
commit 17f080d6b2
3 changed files with 7 additions and 35 deletions

View File

@ -11,8 +11,8 @@
%global crate sevctl
Name: rust-sevctl
Version: 0.3.2
Release: 5%{?dist}
Version: 0.4.1
Release: 1%{?dist}
Summary: Administrative utility for AMD SEV
License: Apache-2.0
@ -23,8 +23,6 @@ Source1: LICENSE.dependencies
# tar xf %%{crate}-%%{version}.crate ; pushd %%{crate}-%%{version} ; \
# cargo vendor && tar Jcvf ../%%{crate}-%%{version}-vendor.tar.xz vendor/ ; popd
Source2: %{crate}-%{version}-vendor.tar.xz
# Temporal patch to update the sev dependency
Patch: sevctl-update-sev.diff
# SEV is an AMD x86_64 CPU feature so doesn't make sense to
# try to build on other arches
@ -86,6 +84,10 @@ cp -pav %{SOURCE1} .
%endif
%changelog
* Wed Jul 19 2023 Tyler Fanelli <tfanelli@redhat.com> - 0.4.1-1
- Update to 0.4.1
- Remove patch to update sev dependency.
* Mon May 15 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 0.3.2-5
- Use vendored dependencies for RHEL builds

View File

@ -1,29 +0,0 @@
diff --git a/Cargo.toml b/Cargo.toml
index 8a106d2..9f0fa4f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -71,7 +71,7 @@ features = ["derive"]
version = "1.0"
[dependencies.sev]
-version = "1.0.1"
+version = "1.1.0"
features = ["openssl"]
[dependencies.structopt]
diff --git a/src/main.rs b/src/main.rs
index 742aec2..fb337fc 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -16,7 +16,10 @@ use structopt::StructOpt;
use codicon::*;
use ::sev::certs::*;
-use ::sev::firmware::host::{types::Status, Firmware, PlatformStatusFlags};
+use ::sev::firmware::host::{
+ types::{PlatformStatusFlags, Status},
+ Firmware,
+};
use ::sev::Generation;
use std::fs::File;

View File

@ -1,2 +1 @@
SHA512 (sevctl-0.3.2.crate) = bd41f105a0846c268999cc7b0b93566fbca91faae8c84a09216af63aba575579a27194e4b69a113b5d08c94710a4289002f818625391630862f2963ba1bfe5ce
SHA512 (sevctl-0.3.2-vendor.tar.xz) = 6d03a079dbcdc11a92fae242fe6d51636370962033b33eb6b2ad241df4292be9c32c62a216c8d608ab3bfafca52495a38b3e6ea19d664a8a219491fbf5a7ae72
SHA512 (sevctl-0.4.1.crate) = 0c882da6be7447ab640bc3606cfea6592f8e5cc38e25c19c42c4b4ce3bd28bcddf52e3b2fa96aa802750fa159f86d4f2567b9da45d867cf2d85402d45e82277b