Include a patch to update sev dependency
- Include a patch to update sev dependency Signed-off-by: Sergio Lopez <slp@redhat.com>
This commit is contained in:
parent
d64f633c64
commit
70b868feb7
@ -12,6 +12,8 @@ License: Apache-2.0
|
||||
URL: https://crates.io/crates/sevctl
|
||||
Source0: %{crates_source}
|
||||
Source1: LICENSE.dependencies
|
||||
# Temporal patch to update the sev dependency
|
||||
Patch: sevctl-update-sev.diff
|
||||
|
||||
# SEV is an AMD x86_64 CPU feature so doesn't make sense to
|
||||
# try to build on other arches
|
||||
@ -63,6 +65,9 @@ cp -pav %{SOURCE1} .
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Feb 09 2023 Sergio Lopez <slp@redhat.com> - 0.3.2-3
|
||||
- Include a patch to update sev dependency
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
29
sevctl-update-sev.diff
Normal file
29
sevctl-update-sev.diff
Normal file
@ -0,0 +1,29 @@
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 8a106d2..9f0fa4f 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -71,7 +71,7 @@ features = ["derive"]
|
||||
version = "1.0"
|
||||
|
||||
[dependencies.sev]
|
||||
-version = "1.0.1"
|
||||
+version = "1.1.0"
|
||||
features = ["openssl"]
|
||||
|
||||
[dependencies.structopt]
|
||||
diff --git a/src/main.rs b/src/main.rs
|
||||
index 742aec2..fb337fc 100644
|
||||
--- a/src/main.rs
|
||||
+++ b/src/main.rs
|
||||
@@ -16,7 +16,10 @@ use structopt::StructOpt;
|
||||
use codicon::*;
|
||||
|
||||
use ::sev::certs::*;
|
||||
-use ::sev::firmware::host::{types::Status, Firmware, PlatformStatusFlags};
|
||||
+use ::sev::firmware::host::{
|
||||
+ types::{PlatformStatusFlags, Status},
|
||||
+ Firmware,
|
||||
+};
|
||||
use ::sev::Generation;
|
||||
|
||||
use std::fs::File;
|
Loading…
Reference in New Issue
Block a user