90930c04f1
The eln macro requires ELN SIG approval, and there is no need to differ from RHEL here. More importantly, we don't want the dynamic buildrequires in ELN either. RHEL/ELN cargo macros do not support -f, so import the RHEL/c9s patch which adds rdcore to the default features. While we're at it, use the RHEL %%cargo_prep -V to handle vendoring rather than manually modifing the cargo config.
12 lines
303 B
Diff
12 lines
303 B
Diff
diff -ur a/Cargo.toml b/Cargo.toml
|
|
--- a/Cargo.toml 1969-12-31 19:00:01.000000000 -0500
|
|
+++ b/Cargo.toml 2023-03-14 07:57:14.025021766 -0400
|
|
@@ -195,6 +195,7 @@
|
|
|
|
[features]
|
|
docgen = ["dep:clap_mangen"]
|
|
+default = ["rdcore"]
|
|
rdcore = []
|
|
|
|
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|