spec: new upstream version 0.15.0
Resolves: rhbz#2101940
This commit is contained in:
parent
3947c14b67
commit
bdc8b4d299
3
.gitignore
vendored
3
.gitignore
vendored
@ -25,3 +25,6 @@
|
|||||||
/coreos-installer-dracut-ce0fe1e.tar.gz
|
/coreos-installer-dracut-ce0fe1e.tar.gz
|
||||||
/coreos-installer-dracut-527b9ca.tar.gz
|
/coreos-installer-dracut-527b9ca.tar.gz
|
||||||
/coreos-installer-dracut-1a262bd.tar.gz
|
/coreos-installer-dracut-1a262bd.tar.gz
|
||||||
|
/coreos-installer-0.15.0.crate
|
||||||
|
/coreos-installer-0.15.0-vendor.tar.gz
|
||||||
|
/coreos-installer-dracut-89d5789.tar.gz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- coreos-installer-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
||||||
+++ coreos-installer-0.11.0/Cargo.toml 2021-12-15T20:16:00.065634+00:00
|
|
||||||
@@ -39,7 +39,6 @@
|
|
||||||
opt-level = 3
|
|
||||||
|
|
||||||
[profile.release]
|
|
||||||
-lto = true
|
|
||||||
debug = true
|
|
||||||
|
|
||||||
[lib]
|
|
@ -1,9 +1,9 @@
|
|||||||
--- coreos-installer-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
--- coreos-installer-0.15.0/Cargo.toml.old 2022-06-30 14:41:55.017099085 -0400
|
||||||
+++ coreos-installer-0.11.0/Cargo.toml 2021-12-15T20:13:31.152703+00:00
|
+++ coreos-installer-0.15.0/Cargo.toml 2022-06-30 14:44:20.754046186 -0400
|
||||||
@@ -139,6 +139,7 @@
|
@@ -156,6 +156,7 @@
|
||||||
version = "^1.0"
|
|
||||||
|
|
||||||
[features]
|
[features]
|
||||||
|
mangen = ["clap_mangen"]
|
||||||
+default = ["rdcore"]
|
+default = ["rdcore"]
|
||||||
rdcore = []
|
rdcore = []
|
||||||
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
# Generated by rust2rpm 16
|
# Originally generated by rust2rpm 16
|
||||||
%define dracutlibdir %{_prefix}/lib/dracut
|
%define dracutlibdir %{_prefix}/lib/dracut
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
%global __cargo_skip_build 0
|
%global __cargo_skip_build 0
|
||||||
# The library is for internal code reuse and is not a public API
|
# The library is for internal code reuse and is not a public API
|
||||||
%global __cargo_is_lib 0
|
%global __cargo_is_lib 0
|
||||||
|
|
||||||
%global dracutcommit 1a262bd9553ee0b3607b4d1982947a1fd6567c35
|
%global dracutcommit 89d5789ef30ee35c7d083f425c7a083459989dbd
|
||||||
%global dracutshortcommit %(c=%{dracutcommit}; echo ${c:0:7})
|
%global dracutshortcommit %(c=%{dracutcommit}; echo ${c:0:7})
|
||||||
|
|
||||||
%global crate coreos-installer
|
%global crate coreos-installer
|
||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 0.11.0
|
Version: 0.15.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||||
|
|
||||||
# Upstream license specification: Apache-2.0
|
# Upstream license specification: Apache-2.0
|
||||||
@ -26,16 +26,12 @@ Source2: https://github.com/coreos/coreos-installer-dracut/archive/%{drac
|
|||||||
# The RHEL 8 rust-toolset macros don't let us enable features from the
|
# The RHEL 8 rust-toolset macros don't let us enable features from the
|
||||||
# %%cargo_* macros. Enable rdcore directly in Cargo.toml.
|
# %%cargo_* macros. Enable rdcore directly in Cargo.toml.
|
||||||
Patch0: enable-rdcore.patch
|
Patch0: enable-rdcore.patch
|
||||||
# LTO causes runtime crashes on s390x
|
|
||||||
# https://github.com/coreos/coreos-installer/pull/360
|
|
||||||
# https://github.com/coreos/coreos-installer/issues/372
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1863466
|
|
||||||
Patch1: disable-lto.patch
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
BuildRequires: rust-toolset
|
BuildRequires: rust-toolset
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
# To ensure we're not bundling system libraries
|
||||||
BuildRequires: xz-devel
|
BuildRequires: xz-devel
|
||||||
%else
|
%else
|
||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
@ -85,11 +81,6 @@ Obsoletes: coreos-installer-dracut < 0.0.1
|
|||||||
|
|
||||||
%description -n %{crate} %{_description}
|
%description -n %{crate} %{_description}
|
||||||
|
|
||||||
%files -n %{crate}
|
|
||||||
%license LICENSE
|
|
||||||
%doc README.md
|
|
||||||
%{_bindir}/coreos-installer
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -n %{crate}-%{version} -p1 -a 2
|
%autosetup -n %{crate}-%{version} -p1 -a 2
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
@ -123,33 +114,16 @@ sed -i 's/"-Ccodegen-units=1",//' .cargo/config
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
%make_install
|
%make_install RELEASE=1
|
||||||
# 51coreos-installer for coreos-installer-dracut
|
# 51coreos-installer for coreos-installer-dracut
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/51coreos-installer/module-setup.sh
|
%make_install -C coreos-installer-dracut-%{dracutcommit}
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer.target
|
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/scripts/coreos-installer-service
|
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/scripts/coreos-installer-growfs
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-growfs.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-luks-open.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-reboot.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-noreboot.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-poweroff.service
|
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/51coreos-installer coreos-installer-dracut-%{dracutcommit}/dracut/systemd/coreos-installer-generator
|
|
||||||
%else
|
%else
|
||||||
%cargo_install -f rdcore
|
%cargo_install -f rdcore
|
||||||
# Install binaries, dracut modules, units, targets, generators for running via systemd
|
# Install binaries, dracut modules, units, targets, generators for running via systemd
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/50rdcore dracut/50rdcore/module-setup.sh
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/50rdcore dracut/50rdcore/module-setup.sh
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir} scripts/coreos-installer-service
|
make install-scripts DESTDIR=%{buildroot}
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir} scripts/coreos-installer-disable-device-auto-activation
|
make install-systemd DESTDIR=%{buildroot}
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-disable-device-auto-activation.service
|
make install-man DESTDIR=%{buildroot}
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-reboot.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-noreboot.service
|
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-pre.target
|
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer.target
|
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-post.target
|
|
||||||
install -D -m 0755 -t %{buildroot}%{_systemdgeneratordir} systemd/coreos-installer-generator
|
|
||||||
mv %{buildroot}%{_bindir}/rdcore %{buildroot}%{dracutlibdir}/modules.d/50rdcore/
|
mv %{buildroot}%{_bindir}/rdcore %{buildroot}%{dracutlibdir}/modules.d/50rdcore/
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -191,6 +165,12 @@ from the initramfs.
|
|||||||
%{dracutlibdir}/modules.d/51coreos-installer
|
%{dracutlibdir}/modules.d/51coreos-installer
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%files -n %{crate}
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{_bindir}/coreos-installer
|
||||||
|
%{_mandir}/man8/*
|
||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%check
|
%check
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
@ -201,6 +181,11 @@ from the initramfs.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 12 2022 Michael Armijo <marmijo@redhat.com> - 0.15.0-1
|
||||||
|
- New release
|
||||||
|
- Sync with Fedora package
|
||||||
|
- Install coreos-installer-dracut with "make install"
|
||||||
|
|
||||||
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.11.0-4
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.11.0-4
|
||||||
- update coi-dracut to fix growfs service Before
|
- update coi-dracut to fix growfs service Before
|
||||||
|
|
||||||
|
9
sources
9
sources
@ -1,6 +1,3 @@
|
|||||||
SHA512 (coreos-installer-0.11.0.crate) = a07d65b05ee25717dddccccb6c56367d1798f2e9c0c166ef4ffe42e2ecb9b246fd5bf2c4a0166f1908dd9a59d42db937a7bb3ba5f0a146e43882dea40df868db
|
SHA512 (coreos-installer-0.15.0.crate) = b1ef91e5710eb10ff06b2fb0bc0f3f78c28796e863caebd89d3ffac35a6347dfb107a072403e2c9a0b129ee32d0f73c331fd3a19d0476f4dcbb8836a1ea1b70a
|
||||||
SHA512 (coreos-installer-0.11.0-vendor.tar.gz) = e813994338d0212e4cddafc969f99f285c441353756bc3f214943513a7999177300539aa98209a3bfdc54e29e2d60775ab492da7c066f2072e7674c08478c22f
|
SHA512 (coreos-installer-0.15.0-vendor.tar.gz) = c1fec1b196622cf1710b27d220aa748eb4322fb69f899f34037ae266883e7d63d6986f8d31bd3eaeeceeaa2a13f728f2e4e310697d6dc271e6ddc370d0c99160
|
||||||
SHA512 (coreos-installer-dracut-43d5fe4.tar.gz) = bc0bc6894429979eac865da370ad469989426ac6415757b6bd26d86ddcd6c20112d95bf3636741142d5171bbeacef49892378af9acb1bb29cbe8bbac6f044f8e
|
SHA512 (coreos-installer-dracut-89d5789.tar.gz) = deed6561a922382f781c14fe3ba3c322c7ad2c4e5cc353e54b443b9bf0a0f6a3ab4a32e42e600371b157963fb7fa0ff4f1c9418c74999225b972674b3b992cfb
|
||||||
SHA512 (coreos-installer-dracut-ce0fe1e.tar.gz) = 3aa974276207d6eb5b7139a449e77d43ea39dd759be2d92ae29d3607537b0d8cb03c9dd62578f5389115c5a27d3c96117013a43b371d27a28e290bb929d8874e
|
|
||||||
SHA512 (coreos-installer-dracut-527b9ca.tar.gz) = e740907703cb042f145183fd93da1c6b7951e37304517af2f86269a00871d8eafac8cf2c7b3538fe5221a3d28529b2f9d4ce70acfe1251ddf24dbc3e8d35fe59
|
|
||||||
SHA512 (coreos-installer-dracut-1a262bd.tar.gz) = 9dfd7e6e7e029f54621d8b1756e1491d77d118f6312fc7d99642963f0040b848ec85d3d1c7fec52499e5c7c1608e5a4769c133a9a277ed294ef512287c08a5ad
|
|
||||||
|
Loading…
Reference in New Issue
Block a user