import rust-coreos-installer-0.16.1-2.el9
This commit is contained in:
parent
e3e9fdc734
commit
b13016ff7b
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,3 +1,3 @@
|
|||||||
SOURCES/coreos-installer-0.15.0-vendor.tar.gz
|
SOURCES/coreos-installer-0.16.1-vendor.tar.gz
|
||||||
SOURCES/coreos-installer-0.15.0.crate
|
SOURCES/coreos-installer-0.16.1.crate
|
||||||
SOURCES/coreos-installer-dracut-38d9f61.tar.gz
|
SOURCES/coreos-installer-dracut-5a456ad.tar.gz
|
||||||
|
@ -1,3 +1,3 @@
|
|||||||
8e250257f77d3c5c42ce433c5d5f424a22580a3a SOURCES/coreos-installer-0.15.0-vendor.tar.gz
|
c5696c7f7e9da590855ec835e928f3f7e6303529 SOURCES/coreos-installer-0.16.1-vendor.tar.gz
|
||||||
981cfec7af755b78700c0e470a9e539a7fc1538c SOURCES/coreos-installer-0.15.0.crate
|
51565a808a2349b49f5ef5f15be23d87313df146 SOURCES/coreos-installer-0.16.1.crate
|
||||||
5a36af3d6018cd244b9dad5b031d2a2c07529e34 SOURCES/coreos-installer-dracut-38d9f61.tar.gz
|
6dd225c4d210b3a2e6ded364e243471934483e30 SOURCES/coreos-installer-dracut-5a456ad.tar.gz
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
--- coreos-installer-0.15.0/Cargo.toml.old 2022-06-30 14:41:55.017099085 -0400
|
--- a/Cargo2.toml 2022-09-21 11:19:37.605292726 -0400
|
||||||
+++ coreos-installer-0.15.0/Cargo.toml 2022-06-30 14:44:20.754046186 -0400
|
+++ b/Cargo.toml 2022-09-21 11:22:29.029020709 -0400
|
||||||
@@ -156,6 +156,7 @@
|
@@ -194,6 +194,7 @@
|
||||||
|
|
||||||
[features]
|
[features]
|
||||||
mangen = ["clap_mangen"]
|
docgen = ["clap_mangen"]
|
||||||
+default = ["rdcore"]
|
+default = ["rdcore"]
|
||||||
rdcore = []
|
rdcore = []
|
||||||
|
|
||||||
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|
||||||
version = ">= 0.3, < 0.5"
|
|
||||||
|
@ -5,13 +5,13 @@
|
|||||||
# The library is for internal code reuse and is not a public API
|
# The library is for internal code reuse and is not a public API
|
||||||
%global __cargo_is_lib 0
|
%global __cargo_is_lib 0
|
||||||
|
|
||||||
%global dracutcommit 38d9f618cd6817ec7c1f1797b273d6f1f46852cb
|
%global dracutcommit 5a456ad690acffb43d49abed9f1940c915d68694
|
||||||
%global dracutshortcommit %(c=%{dracutcommit}; echo ${c:0:7})
|
%global dracutshortcommit %(c=%{dracutcommit}; echo ${c:0:7})
|
||||||
|
|
||||||
%global crate coreos-installer
|
%global crate coreos-installer
|
||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 0.15.0
|
Version: 0.16.1
|
||||||
Release: 2%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||||
|
|
||||||
@ -37,6 +37,7 @@ BuildRequires: xz-devel
|
|||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: systemd-rpm-macros
|
BuildRequires: systemd-rpm-macros
|
||||||
|
BuildRequires: libzstd-devel
|
||||||
# For tests
|
# For tests
|
||||||
BuildRequires: gnupg2
|
BuildRequires: gnupg2
|
||||||
|
|
||||||
@ -124,6 +125,7 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/50rdcore dracut/50rd
|
|||||||
make install-scripts DESTDIR=%{buildroot}
|
make install-scripts DESTDIR=%{buildroot}
|
||||||
make install-systemd DESTDIR=%{buildroot}
|
make install-systemd DESTDIR=%{buildroot}
|
||||||
make install-man DESTDIR=%{buildroot}
|
make install-man DESTDIR=%{buildroot}
|
||||||
|
make install-data DESTDIR=%{buildroot}
|
||||||
mv %{buildroot}%{_bindir}/rdcore %{buildroot}%{dracutlibdir}/modules.d/50rdcore/
|
mv %{buildroot}%{_bindir}/rdcore %{buildroot}%{dracutlibdir}/modules.d/50rdcore/
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -170,6 +172,8 @@ from the initramfs.
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
%{_bindir}/coreos-installer
|
%{_bindir}/coreos-installer
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
|
%dir %{_datadir}/coreos-installer
|
||||||
|
%{_datadir}/coreos-installer/example-config.yaml
|
||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%check
|
%check
|
||||||
@ -181,6 +185,14 @@ from the initramfs.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 07 2022 Irene Diez <idiez@redhat.com> - 0.16.1-2
|
||||||
|
- Add ignition support to coi-dracut
|
||||||
|
- Fix usb installation
|
||||||
|
|
||||||
|
* Wed Sep 21 2022 Steven Presti <spresti@redhat.com> - 0.16.1-1
|
||||||
|
- new version
|
||||||
|
- Add libzstd dependency
|
||||||
|
|
||||||
* Thu Aug 18 2022 Antonio Murdaca <runcom@linux.com> - 0.15.0-2
|
* Thu Aug 18 2022 Antonio Murdaca <runcom@linux.com> - 0.15.0-2
|
||||||
- update coi-dracut to support LVM backed growfs service
|
- update coi-dracut to support LVM backed growfs service
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user