Resolves: rhbz#2021611
- 0.11.0 - Fix inadvertent inclusion of coreos-installer-dracut in -bootinfra
This commit is contained in:
parent
02467521ff
commit
68cede387b
2
.gitignore
vendored
2
.gitignore
vendored
@ -18,3 +18,5 @@
|
||||
/coreos-installer-dracut-80d42a6.tar.gz
|
||||
/coreos-installer-dracut-597124f.tar.gz
|
||||
/coreos-installer-dracut-9332fe5.tar.gz
|
||||
/coreos-installer-0.11.0.crate
|
||||
/coreos-installer-0.11.0-vendor.tar.gz
|
||||
|
@ -1,12 +1,10 @@
|
||||
--- coreos-installer-0.10.0/Cargo.toml 2021-09-02 10:50:54.538578470 +0200
|
||||
+++ coreos-installer-0.10.0/Cargo.toml 2021-09-02 10:51:20.779926148 +0200
|
||||
@@ -35,9 +35,6 @@
|
||||
[profile.dev.package.miniz_oxide]
|
||||
--- coreos-installer-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ coreos-installer-0.11.0/Cargo.toml 2021-12-15T20:16:00.065634+00:00
|
||||
@@ -39,7 +39,6 @@
|
||||
opt-level = 3
|
||||
|
||||
-[profile.release]
|
||||
[profile.release]
|
||||
-lto = true
|
||||
-
|
||||
debug = true
|
||||
|
||||
[lib]
|
||||
name = "libcoreinst"
|
||||
path = "src/lib.rs"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- coreos-installer-0.10.0/Cargo.toml 2021-09-02 10:48:49.577922841 +0200
|
||||
+++ coreos-installer-0.10.0/Cargo.toml 2021-09-02 10:49:23.366370513 +0200
|
||||
@@ -129,6 +129,7 @@
|
||||
--- coreos-installer-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ coreos-installer-0.11.0/Cargo.toml 2021-12-15T20:13:31.152703+00:00
|
||||
@@ -139,6 +139,7 @@
|
||||
version = "^1.0"
|
||||
|
||||
[features]
|
||||
|
@ -11,14 +11,15 @@
|
||||
%global crate coreos-installer
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.10.1
|
||||
Release: 6%{?dist}
|
||||
Version: 0.11.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/coreos-installer
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# not used on Fedora
|
||||
Source1: https://github.com/coreos/%{crate}/releases/download/v%{version}/%{crate}-%{version}-vendor.tar.gz
|
||||
Source2: https://github.com/coreos/coreos-installer-dracut/archive/%{dracutcommit}/coreos-installer-dracut-%{dracutshortcommit}.tar.gz
|
||||
|
||||
@ -170,7 +171,7 @@ This subpackage contains boot-time infrastructure for Fedora CoreOS and
|
||||
RHEL CoreOS. It is not needed on other platforms.
|
||||
|
||||
%files -n %{crate}-bootinfra
|
||||
%{dracutlibdir}/modules.d/*
|
||||
%{dracutlibdir}/modules.d/50rdcore
|
||||
%{_libexecdir}/*
|
||||
%{_unitdir}/*
|
||||
%{_systemdgeneratordir}/*
|
||||
@ -185,7 +186,7 @@ This subpackage contains files and configuration to run coreos-installer
|
||||
from the initramfs.
|
||||
|
||||
%files -n %{crate}-dracut
|
||||
%{dracutlibdir}/modules.d/51coreos-installer/*
|
||||
%{dracutlibdir}/modules.d/51coreos-installer
|
||||
%endif
|
||||
|
||||
%if %{with check}
|
||||
@ -198,6 +199,11 @@ from the initramfs.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Dec 15 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 0.11.0-1
|
||||
- New release
|
||||
- Fix inadvertent inclusion of coreos-installer-dracut in -bootinfra on RHEL
|
||||
- Have -dracut own 51coreos-installer directory on RHEL
|
||||
|
||||
* Tue Nov 30 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 0.10.1-6
|
||||
- Vendor rust dependencies on RHEL only
|
||||
- Add coreos-installer-dracut subpackage on RHEL only
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (coreos-installer-0.10.1.crate) = 33ca2d4d13ce6a0c42b4f2b8ef0206e8dd1a91b377363ce908f265540b40653be7e3d0baa0cd0b308877be656c3bfd40d1a368f94da2b619f71f5ba635af9076
|
||||
SHA512 (coreos-installer-0.10.1-vendor.tar.gz) = bcf6d2a2aeeef49b8beda43815ed2cbfca630902ec936e6b3caac128e11b2a4800cd82a8420a740842e8975466b393d81d14a26c9d444f6ca1f105ecc50a7afa
|
||||
SHA512 (coreos-installer-0.11.0.crate) = a07d65b05ee25717dddccccb6c56367d1798f2e9c0c166ef4ffe42e2ecb9b246fd5bf2c4a0166f1908dd9a59d42db937a7bb3ba5f0a146e43882dea40df868db
|
||||
SHA512 (coreos-installer-0.11.0-vendor.tar.gz) = e813994338d0212e4cddafc969f99f285c441353756bc3f214943513a7999177300539aa98209a3bfdc54e29e2d60775ab492da7c066f2072e7674c08478c22f
|
||||
SHA512 (coreos-installer-dracut-9332fe5.tar.gz) = 2cd481c4aacddcb51726a2d7e84879e7cb7623b5d984b1bd496362bfb3dc7ea6fb232864d696b7b72900d797674d14754222532167da545f445d8092ec2fe6ea
|
||||
|
Loading…
Reference in New Issue
Block a user