Unbundle serde_with and its dependencies
https://bugzilla.redhat.com/show_bug.cgi?id=2033857 was fixed, so we can undo the bundling. Fixes https://bugzilla.redhat.com/show_bug.cgi?id=2033859.
This commit is contained in:
parent
89b375e901
commit
1cdd286d84
@ -1,11 +0,0 @@
|
|||||||
--- coreos-installer-0.12.0/Cargo.toml.old 2021-12-17 15:04:38.560516015 -0500
|
|
||||||
+++ coreos-installer-0.12.0/Cargo.toml 2021-12-17 16:45:29.567815138 -0500
|
|
||||||
@@ -120,7 +120,7 @@
|
|
||||||
version = "^1.0"
|
|
||||||
|
|
||||||
[dependencies.serde_with]
|
|
||||||
-version = "1.9.4"
|
|
||||||
+path = "vendor/serde_with"
|
|
||||||
|
|
||||||
[dependencies.serde_yaml]
|
|
||||||
version = "0.8"
|
|
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 0.12.0
|
Version: 0.12.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||||
|
|
||||||
# Upstream license specification: Apache-2.0
|
# Upstream license specification: Apache-2.0
|
||||||
@ -26,16 +26,6 @@ Source2: https://github.com/coreos/coreos-installer-dracut/archive/%{drac
|
|||||||
# LTO causes OOM on Fedora armv7hl builders with Rust 1.57.0
|
# LTO causes OOM on Fedora armv7hl builders with Rust 1.57.0
|
||||||
Patch1: disable-lto.patch
|
Patch1: disable-lto.patch
|
||||||
|
|
||||||
# rust-serde_with doesn't include the default "macros" feature. Bundle
|
|
||||||
# serde_with and its dependencies while we sort out this mess.
|
|
||||||
Patch2: bundle-serde_with.patch
|
|
||||||
BuildRequires: rust-ident_case+default-devel
|
|
||||||
Provides: bundled(crate(darling)) = 0.13.0
|
|
||||||
Provides: bundled(crate(darling_core)) = 0.13.0
|
|
||||||
Provides: bundled(crate(darling_macro)) = 0.13.0
|
|
||||||
Provides: bundled(crate(serde_with)) = 1.11.0
|
|
||||||
Provides: bundled(crate(serde_with_macros)) = 1.5.1
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
BuildRequires: rust-toolset
|
BuildRequires: rust-toolset
|
||||||
@ -109,18 +99,6 @@ directory = "vendor"
|
|||||||
EOF
|
EOF
|
||||||
%else
|
%else
|
||||||
%cargo_prep
|
%cargo_prep
|
||||||
# FIXME: until the serde_with package provides the macros feature
|
|
||||||
tar xvf %{SOURCE1}
|
|
||||||
mkdir -p .cargo
|
|
||||||
cat >>.cargo/config << EOF
|
|
||||||
[patch.crates-io]
|
|
||||||
darling = { path = 'vendor/darling' }
|
|
||||||
darling_core = { path = 'vendor/darling_core' }
|
|
||||||
darling_macro = { path = 'vendor/darling_macro' }
|
|
||||||
serde_with = { path = 'vendor/serde_with' }
|
|
||||||
serde_with_macros = { path = 'vendor/serde_with_macros' }
|
|
||||||
EOF
|
|
||||||
# /FIXME
|
|
||||||
%endif
|
%endif
|
||||||
# Fix SIGSEGV in tests on s390x
|
# Fix SIGSEGV in tests on s390x
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1883457
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1883457
|
||||||
@ -215,6 +193,9 @@ from the initramfs.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 20 2021 Benjamin Gilbert <bgilbert@redhat.com> - 0.12.0-2
|
||||||
|
- Unbundle serde_with and its dependencies
|
||||||
|
|
||||||
* Fri Dec 17 2021 Benjamin Gilbert <bgilbert@redhat.com> - 0.12.0-1
|
* Fri Dec 17 2021 Benjamin Gilbert <bgilbert@redhat.com> - 0.12.0-1
|
||||||
- New release
|
- New release
|
||||||
- Temporarily bundle serde_with and its dependencies
|
- Temporarily bundle serde_with and its dependencies
|
||||||
|
Loading…
Reference in New Issue
Block a user