Build with mbrman 0.5.0
This commit is contained in:
parent
5411a49ca3
commit
0caf53238c
19
mbrman-0.5.0.patch
Normal file
19
mbrman-0.5.0.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- coreos-installer-0.16.1/Cargo.toml.old 2022-10-14 01:32:13.064282069 -0400
|
||||||
|
+++ coreos-installer-0.16.1/Cargo.toml 2022-10-14 01:32:44.416313454 -0400
|
||||||
|
@@ -199,4 +199,3 @@ rdcore = []
|
||||||
|
[target."cfg(target_arch = \"s390x\")".dependencies.mbrman]
|
||||||
|
-version = ">= 0.3, < 0.5"
|
||||||
|
-default-features = false
|
||||||
|
+version = ">= 0.5, < 0.6"
|
||||||
|
|
||||||
|
--- a/src/s390x/fba.rs
|
||||||
|
+++ b/src/s390x/fba.rs
|
||||||
|
@@ -39,7 +39,7 @@ pub(crate) fn fba_make_partitions(
|
||||||
|
length: blocks * bytes_per_block as u64,
|
||||||
|
});
|
||||||
|
mbr[idx + 1] = MBRPartitionEntry {
|
||||||
|
- boot: false,
|
||||||
|
+ boot: mbrman::BOOT_INACTIVE,
|
||||||
|
first_chs: CHS::empty(),
|
||||||
|
sys: 0x83, // MBR_LINUX_DATA_PARTITION
|
||||||
|
last_chs: CHS::empty(),
|
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: rust-%{crate}
|
Name: rust-%{crate}
|
||||||
Version: 0.16.1
|
Version: 0.16.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||||
|
|
||||||
# Upstream license specification: Apache-2.0
|
# Upstream license specification: Apache-2.0
|
||||||
@ -23,6 +23,10 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
|
|||||||
Source1: https://github.com/coreos/%{crate}/releases/download/v%{version}/%{crate}-%{version}-vendor.tar.gz
|
Source1: https://github.com/coreos/%{crate}/releases/download/v%{version}/%{crate}-%{version}-vendor.tar.gz
|
||||||
Source2: https://github.com/coreos/coreos-installer-dracut/archive/%{dracutcommit}/coreos-installer-dracut-%{dracutshortcommit}.tar.gz
|
Source2: https://github.com/coreos/coreos-installer-dracut/archive/%{dracutcommit}/coreos-installer-dracut-%{dracutshortcommit}.tar.gz
|
||||||
|
|
||||||
|
# Build with mbrman 0.5.x
|
||||||
|
# https://github.com/coreos/coreos-installer/pull/1019
|
||||||
|
Patch0: mbrman-0.5.0.patch
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
BuildRequires: rust-toolset
|
BuildRequires: rust-toolset
|
||||||
@ -181,6 +185,9 @@ from the initramfs.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 14 2022 Benjamin Gilbert <bgilbert@redhat.com> - 0.16.1-2
|
||||||
|
- Build with mbrman 0.5.0
|
||||||
|
|
||||||
* Mon Sep 19 2022 Benjamin Gilbert <bgilbert@redhat.com> - 0.16.1-1
|
* Mon Sep 19 2022 Benjamin Gilbert <bgilbert@redhat.com> - 0.16.1-1
|
||||||
- New release
|
- New release
|
||||||
- Sync coreos-installer-dracut with CentOS Stream 9
|
- Sync coreos-installer-dracut with CentOS Stream 9
|
||||||
|
Loading…
Reference in New Issue
Block a user