0.4.0
This commit is contained in:
parent
7ffee3387d
commit
0aa72fcd35
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/coreos-installer-0.2.0.crate
|
||||
/coreos-installer-0.2.1.crate
|
||||
/coreos-installer-0.3.0.crate
|
||||
/coreos-installer-0.4.0.crate
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- coreos-installer-0.3.0/Cargo.toml.old 2020-07-15 14:35:50.232739083 -0400
|
||||
+++ coreos-installer-0.3.0/Cargo.toml 2020-07-15 14:36:14.063736809 -0400
|
||||
@@ -36,7 +36,7 @@
|
||||
version = "^1.3"
|
||||
|
||||
[dependencies.byte-unit]
|
||||
-version = "^4.0"
|
||||
+version = ">= 3.1.0, < 5.0.0"
|
||||
|
||||
[dependencies.clap]
|
||||
version = "^2.33"
|
@ -1,20 +1,20 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global __cargo_skip_build 0
|
||||
# The library is for internal code reuse and is not a public API
|
||||
%global __cargo_is_lib 0
|
||||
|
||||
%global crate coreos-installer
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.3.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Installer for Fedora CoreOS and RHEL CoreOS
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/coreos-installer
|
||||
Source: %{crates_source}
|
||||
# https://github.com/coreos/coreos-installer/pull/299
|
||||
Patch0: cargo-byte-unit.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
@ -65,7 +65,8 @@ Obsoletes: coreos-installer-dracut < 0.0.1
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
# Install binaries, units, targets, generators for running via systemd
|
||||
# Install binaries, dracut modules, units, targets, generators for running via systemd
|
||||
install -D -m 0755 -t %{buildroot}%{_prefix}/lib/dracut/modules.d/50rdcore dracut/50rdcore/module-setup.sh
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir} scripts/coreos-installer-service
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir} scripts/coreos-installer-disable-device-auto-activation
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-disable-device-auto-activation.service
|
||||
@ -75,15 +76,29 @@ install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-noreboot.
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer-pre.target
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} systemd/coreos-installer.target
|
||||
install -D -m 0755 -t %{buildroot}%{_systemdgeneratordir} systemd/coreos-installer-generator
|
||||
mv %{buildroot}%{_bindir}/rdcore %{buildroot}%{_prefix}/lib/dracut/modules.d/50rdcore/
|
||||
|
||||
%package -n %{crate}-systemd
|
||||
Summary: Systemd service files for %{crate}
|
||||
%package -n %{crate}-bootinfra
|
||||
Summary: %{crate} boot-time infrastructure for use on Fedora/RHEL CoreOS
|
||||
Requires: %{crate}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
# ASL 2.0
|
||||
# ASL 2.0 or Boost
|
||||
# MIT
|
||||
# MIT or ASL 2.0
|
||||
# Unlicense or MIT
|
||||
# zlib
|
||||
License: ASL 2.0 and MIT and zlib
|
||||
|
||||
%description -n %{crate}-systemd
|
||||
%{summary}.
|
||||
# Package was renamed from coreos-installer-systemd when rdcore was added
|
||||
Provides: %{crate}-systemd = %{version}-%{release}
|
||||
Obsoletes: %{crate}-systemd <= 0.3.0-3
|
||||
|
||||
%files -n %{crate}-systemd
|
||||
%description -n %{crate}-bootinfra
|
||||
This subpackage contains boot-time infrastructure for Fedora CoreOS and
|
||||
RHEL CoreOS. It is not needed on other platforms.
|
||||
|
||||
%files -n %{crate}-bootinfra
|
||||
%{_prefix}/lib/dracut/modules.d/*
|
||||
%{_libexecdir}/*
|
||||
%{_unitdir}/*
|
||||
%{_systemdgeneratordir}/*
|
||||
@ -94,6 +109,11 @@ Requires: %{crate}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jul 24 2020 Benjamin Gilbert <bgilbert@redhat.com> - 0.4.0-1
|
||||
- New release
|
||||
- Rename -systemd subpackage to -bootinfra
|
||||
- Add rdcore Dracut module to -bootinfra
|
||||
|
||||
* Fri Jul 24 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.3.0-2
|
||||
- Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (coreos-installer-0.3.0.crate) = 0922b99f82461d7bfe1ec4723c5f89343c2918a59c7f2872fc37dfbf7176c75eb465fa260418e5d34d773304120f9a2166e603803bd2d7f20e05328b6dfa7ca3
|
||||
SHA512 (coreos-installer-0.4.0.crate) = 7923886a90cd16a2abed3fbe6effbe916342b9a4a76d92b86c2fa8849538ab91c45bcde5c3f6fcbff97034681a0cfd84a26e82fe219a2303cf4ab99a1ca00061
|
||||
|
Loading…
Reference in New Issue
Block a user