Revert "Skip the ssl tests on Brew s390x build environment."
This reverts commit 9599325b90
.
This issue was fixed on RHELBLD-6305.
Bump release for rebuild.
Related: rhbz#1938942
This commit is contained in:
parent
9599325b90
commit
fc890b7d73
@ -1,16 +0,0 @@
|
||||
diff --git a/test/rubygems/test_bundled_ca.rb b/test/rubygems/test_bundled_ca.rb
|
||||
index 6973758c4c..71f61ca8f7 100644
|
||||
--- a/test/rubygems/test_bundled_ca.rb
|
||||
+++ b/test/rubygems/test_bundled_ca.rb
|
||||
@@ -32,7 +32,7 @@ def assert_https(host)
|
||||
http.verify_mode = OpenSSL::SSL::VERIFY_PEER
|
||||
http.cert_store = bundled_certificate_store
|
||||
http.get('/')
|
||||
- rescue Errno::ENOENT, Errno::ETIMEDOUT, SocketError
|
||||
+ rescue Errno::ECONNREFUSED, Errno::ENETUNREACH, Errno::ENOENT, Errno::ETIMEDOUT, SocketError
|
||||
skip "#{host} seems offline, I can't tell whether ssl would work."
|
||||
rescue OpenSSL::SSL::SSLError => e
|
||||
# Only fail for certificate verification errors
|
||||
--
|
||||
2.29.2
|
||||
|
12
ruby.spec
12
ruby.spec
@ -22,7 +22,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 137
|
||||
%global release 138
|
||||
%{!?release_string:%define release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
# The RubyGems library has to stay out of Ruby directory tree, since the
|
||||
@ -153,10 +153,6 @@ Patch15: ruby-dwarf5-avoid_crash-r1.patch
|
||||
# Avoid possible timeout errors in TestBugReporter#test_bug_reporter_add.
|
||||
# https://bugs.ruby-lang.org/issues/16492
|
||||
Patch19: ruby-2.7.1-Timeout-the-test_bug_reporter_add-witout-raising-err.patch
|
||||
# Skip the ssl tests on Brew s390x build environment.
|
||||
# https://projects.engineering.redhat.com/browse/RHELBLD-6305
|
||||
# https://github.com/ruby/ruby/pull/4112
|
||||
Patch100: ruby-3.0.0-Skip-ssl-tests-for-offline.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Suggests: rubypick
|
||||
@ -593,9 +589,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch9 -p1
|
||||
%patch15 -p1
|
||||
%patch19 -p1
|
||||
%ifarch s390x
|
||||
%patch100 -p1
|
||||
%endif
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -1346,7 +1339,7 @@ MSPECOPTS=""
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 07 2021 Jarek Prokop <jprokop@redhat.com> - 3.0.1-137
|
||||
* Mon Jun 07 2021 Jarek Prokop <jprokop@redhat.com> - 3.0.1-138
|
||||
- Upgrade to Ruby 3.0.1 by merging Fedora rawhide branch (commit: 6b2ff68).
|
||||
* Add missing `rubygem-` prefix for bundled provide of 'connection_pool'.
|
||||
* Pass ldflags to gem install via CONFIGURE_ARGS
|
||||
@ -1367,7 +1360,6 @@ MSPECOPTS=""
|
||||
* Drop Net::Telnet and XMLRPC packages, because they were dropped from Ruby.
|
||||
Resolves: rhbz#1938942
|
||||
- Fix FTBFS due to an incompatible load directive.
|
||||
- Skip the SSL tests on Brew s390x build environment.
|
||||
|
||||
* Wed Apr 07 2021 Pavel Valena <pvalena@redhat.com> - 2.7.3-136
|
||||
- Upgrade to Ruby 2.7.3.
|
||||
|
Loading…
Reference in New Issue
Block a user