Upgrade to Ruby 2.0.0 (r39217).
This commit is contained in:
parent
14d28871b5
commit
f731780a81
@ -1,17 +1,17 @@
|
||||
From 770799128d4cf0b2908f8cd15d935fc6cc24397a Mon Sep 17 00:00:00 2001
|
||||
From 2e15c6bdac1c145cce0c21677477ced8df26718b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 8 Feb 2013 18:20:50 +0100
|
||||
Subject: [PATCH] Add configuration arch specific dir flag.
|
||||
|
||||
---
|
||||
configure.in | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
configure.in | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 7604bb8..418b0cb 100644
|
||||
index d6af000..1c094a3 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3186,6 +3191,10 @@ AC_ARG_WITH(rubylibprefix,
|
||||
@@ -3221,6 +3221,10 @@ AC_SUBST(rubylibprefix)
|
||||
rubylibdir='${rubylibprefix}/${ruby_version}'
|
||||
rubyarchdir=${multiarch+'${rubyarchprefix}/${ruby_version}'}${multiarch-'${rubylibdir}/${arch}'}
|
||||
|
||||
@ -23,5 +23,5 @@ index 7604bb8..418b0cb 100644
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
--
|
||||
1.8.1
|
||||
1.8.1.2
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 5afb0d89ab0e6297b333f45b4bd30a20024e80c7 Mon Sep 17 00:00:00 2001
|
||||
From 1e109d1a0265dfdde2324a6a97e4225eb4343efc Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 8 Feb 2013 22:48:41 +0100
|
||||
Subject: [PATCH] Prevent duplicated paths when empty version string is
|
||||
@ -10,10 +10,10 @@ Subject: [PATCH] Prevent duplicated paths when empty version string is
|
||||
2 files changed, 13 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 5850bbf..7604bb8 100644
|
||||
index e83cfb4..d6af000 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3265,6 +3265,9 @@ shvar_to_cpp RIDIR "${ridir}"
|
||||
@@ -3308,6 +3308,9 @@ shvar_to_cpp RIDIR "${ridir}"
|
||||
if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
||||
AC_DEFINE_UNQUOTED(RUBY_LIB_VERSION_STYLE, $RUBY_LIB_VERSION_STYLE !<verconf>!)
|
||||
else
|
||||
@ -24,7 +24,7 @@ index 5850bbf..7604bb8 100644
|
||||
fi
|
||||
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, ${RUBY_EXEC_PREFIX})
|
||||
diff --git a/version.c b/version.c
|
||||
index 282960d..54c4513 100644
|
||||
index 6ba6453..c78f609 100644
|
||||
--- a/version.c
|
||||
+++ b/version.c
|
||||
@@ -39,9 +39,15 @@
|
||||
@ -43,7 +43,7 @@ index 282960d..54c4513 100644
|
||||
#ifndef RUBY_ARCH_LIB_FOR
|
||||
#define RUBY_ARCH_LIB_FOR(arch) RUBY_LIB "/"arch
|
||||
#endif
|
||||
@@ -77,8 +83,10 @@ const char ruby_initial_load_paths[] =
|
||||
@@ -79,8 +85,10 @@ const char ruby_initial_load_paths[] =
|
||||
RUBY_SITE_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
||||
#endif
|
||||
RUBY_SITE_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
||||
@ -54,7 +54,7 @@ index 282960d..54c4513 100644
|
||||
|
||||
#ifndef NO_RUBY_VENDOR_LIB
|
||||
RUBY_VENDOR_LIB2 "\0"
|
||||
@@ -86,8 +94,10 @@ const char ruby_initial_load_paths[] =
|
||||
@@ -88,8 +96,10 @@ const char ruby_initial_load_paths[] =
|
||||
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
||||
#endif
|
||||
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
||||
@ -66,5 +66,5 @@ index 282960d..54c4513 100644
|
||||
RUBY_LIB "\0"
|
||||
#ifdef RUBY_THINARCH
|
||||
--
|
||||
1.8.1
|
||||
1.8.1.2
|
||||
|
||||
|
11
ruby.spec
11
ruby.spec
@ -11,10 +11,9 @@
|
||||
|
||||
# Specify the named version. It has precedense to revision.
|
||||
#%%global milestone preview2
|
||||
%global milestone rc2
|
||||
|
||||
# Keep the revision enabled for pre-releases from SVN.
|
||||
%global revision 39070
|
||||
%global revision 39217
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -63,7 +62,7 @@
|
||||
%global rdoc_version 4.0.0.rc.2.1
|
||||
%global bigdecimal_version 1.1.0
|
||||
%global io_console_version 0.4.1
|
||||
%global json_version 1.7.5
|
||||
%global json_version 1.7.7
|
||||
%global minitest_version 4.3.2
|
||||
%global psych_version 2.0.0
|
||||
|
||||
@ -112,6 +111,9 @@ Patch12: ruby-1.9.3-mkmf-verbose.patch
|
||||
# documentation should be generated, since json gem is sudenly not accessible.
|
||||
# https://github.com/rubygems/rubygems/pull/452
|
||||
Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
|
||||
# This prevents issues, when ruby configuration specifies --with-ruby-version=''.
|
||||
# https://github.com/rubygems/rubygems/pull/455
|
||||
Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||
@ -372,6 +374,7 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
||||
%patch9 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -538,7 +541,7 @@ DISABLE_TESTS="-x test_dl2.rb $DISABLE_TESTS"
|
||||
DISABLE_TESTS="-x test_io.rb $DISABLE_TESTS"
|
||||
%endif
|
||||
|
||||
#make check TESTS="-v $DISABLE_TESTS"
|
||||
make check TESTS="-v $DISABLE_TESTS"
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
|
81
rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
Normal file
81
rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
Normal file
@ -0,0 +1,81 @@
|
||||
From c9b2eff36728266052ccfff54d3ac0a0624fd0f1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Thu, 14 Feb 2013 11:50:41 +0100
|
||||
Subject: [PATCH 1/2] Use File.join insteado of manual path creation.
|
||||
|
||||
This prevents issues, when File.join in #new_default_spec removes
|
||||
superfluous slashes while they are kept in expected paths. E.g. the test
|
||||
would fail if ruby configuration specifies --with-ruby-version=''.
|
||||
---
|
||||
test/rubygems/test_gem_commands_contents_command.rb | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/test/rubygems/test_gem_commands_contents_command.rb b/test/rubygems/test_gem_commands_contents_command.rb
|
||||
index 60df53f..35c9631 100644
|
||||
--- a/test/rubygems/test_gem_commands_contents_command.rb
|
||||
+++ b/test/rubygems/test_gem_commands_contents_command.rb
|
||||
@@ -140,10 +140,10 @@ lib/foo.rb
|
||||
@cmd.execute
|
||||
end
|
||||
|
||||
- expected = %W[
|
||||
- #{Gem::ConfigMap[:bindir]}/default_command
|
||||
- #{Gem::ConfigMap[:rubylibdir]}/default/gem.rb
|
||||
- #{Gem::ConfigMap[:archdir]}/default_gem.so
|
||||
+ expected = [
|
||||
+ File.join(Gem::ConfigMap[:bindir], 'default_command'),
|
||||
+ File.join(Gem::ConfigMap[:rubylibdir], 'default/gem.rb'),
|
||||
+ File.join(Gem::ConfigMap[:archdir], 'default_gem.so')
|
||||
].sort.join "\n"
|
||||
|
||||
assert_equal expected, @ui.output.chomp
|
||||
--
|
||||
1.8.1.2
|
||||
|
||||
|
||||
From b022cef7b2e6c2d138388a6c2db02cca8c408cc6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Thu, 14 Feb 2013 13:35:20 +0100
|
||||
Subject: [PATCH 2/2] Do not add last slash to Gem.user_dir if ruby_version
|
||||
string is empty.
|
||||
|
||||
---
|
||||
lib/rubygems/defaults.rb | 4 +++-
|
||||
test/rubygems/test_gem.rb | 6 ++++--
|
||||
2 files changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/rubygems/defaults.rb b/lib/rubygems/defaults.rb
|
||||
index ea84e5c..05c35bb 100644
|
||||
--- a/lib/rubygems/defaults.rb
|
||||
+++ b/lib/rubygems/defaults.rb
|
||||
@@ -54,7 +54,9 @@ module Gem
|
||||
# Path for gems in the user's home directory
|
||||
|
||||
def self.user_dir
|
||||
- File.join Gem.user_home, '.gem', ruby_engine, ConfigMap[:ruby_version]
|
||||
+ parts = [Gem.user_home, '.gem', ruby_engine]
|
||||
+ parts << ConfigMap[:ruby_version] unless ConfigMap[:ruby_version].empty?
|
||||
+ File.join parts
|
||||
end
|
||||
|
||||
##
|
||||
diff --git a/test/rubygems/test_gem.rb b/test/rubygems/test_gem.rb
|
||||
index bf77009..9ee78f7 100644
|
||||
--- a/test/rubygems/test_gem.rb
|
||||
+++ b/test/rubygems/test_gem.rb
|
||||
@@ -1186,8 +1186,10 @@ class TestGem < Gem::TestCase
|
||||
end
|
||||
|
||||
def test_self_user_dir
|
||||
- assert_equal File.join(@userhome, '.gem', Gem.ruby_engine,
|
||||
- Gem::ConfigMap[:ruby_version]), Gem.user_dir
|
||||
+ parts = [@userhome, '.gem', Gem.ruby_engine]
|
||||
+ parts << Gem::ConfigMap[:ruby_version] unless Gem::ConfigMap[:ruby_version].empty?
|
||||
+
|
||||
+ assert_equal File.join(parts), Gem.user_dir
|
||||
end
|
||||
|
||||
def test_self_user_home
|
||||
--
|
||||
1.8.1.2
|
||||
|
Loading…
Reference in New Issue
Block a user