Update to Ruby 2.3.1.
This commit is contained in:
parent
dd6ce9ce9c
commit
f2347fa378
@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 0e371e2..d4f1dcb 100644
|
index 0e371e2..d4f1dcb 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4334,6 +4334,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
@@ -4374,6 +4374,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||||
AC_SUBST(sitearchhdrdir)dnl
|
AC_SUBST(sitearchhdrdir)dnl
|
||||||
AC_SUBST(vendorarchhdrdir)dnl
|
AC_SUBST(vendorarchhdrdir)dnl
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 37d9a62..553d4d0 100644
|
index 37d9a62..553d4d0 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3592,6 +3592,11 @@ if test ${multiarch+set}; then
|
@@ -3632,6 +3632,11 @@ if test ${multiarch+set}; then
|
||||||
fi
|
fi
|
||||||
|
|
||||||
archlibdir='${libdir}/${arch}'
|
archlibdir='${libdir}/${arch}'
|
||||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index db37cd6..ce8d149 100644
|
index db37cd6..ce8d149 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4188,7 +4188,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
@@ -4228,7 +4228,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||||
|
|
||||||
if test -z "${ruby_version_dir_name}"; then
|
if test -z "${ruby_version_dir_name}"; then
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 553d4d0..03a4152 100644
|
index 553d4d0..03a4152 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4252,6 +4252,8 @@ AC_SUBST(vendorarchdir)dnl
|
@@ -4292,6 +4292,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 03a4152..0e371e2 100644
|
index 03a4152..0e371e2 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4224,6 +4224,10 @@ AC_ARG_WITH(vendorarchdir,
|
@@ -4264,6 +4264,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||||
[vendorarchdir=$withval],
|
[vendorarchdir=$withval],
|
||||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||||
|
|
||||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
|||||||
if test "${LOAD_RELATIVE+set}"; then
|
if test "${LOAD_RELATIVE+set}"; then
|
||||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||||
RUBY_EXEC_PREFIX=''
|
RUBY_EXEC_PREFIX=''
|
||||||
@@ -4248,6 +4252,7 @@ AC_SUBST(sitearchdir)dnl
|
@@ -4288,6 +4292,7 @@ AC_SUBST(sitearchdir)dnl
|
||||||
AC_SUBST(vendordir)dnl
|
AC_SUBST(vendordir)dnl
|
||||||
AC_SUBST(vendorlibdir)dnl
|
AC_SUBST(vendorlibdir)dnl
|
||||||
AC_SUBST(vendorarchdir)dnl
|
AC_SUBST(vendorarchdir)dnl
|
||||||
|
@ -20,7 +20,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index db37cd6..6e73fae 100644
|
index db37cd6..6e73fae 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4137,9 +4137,6 @@ AS_CASE(["$target_os"],
|
@@ -4177,9 +4177,6 @@ AS_CASE(["$target_os"],
|
||||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -30,7 +30,7 @@ index db37cd6..6e73fae 100644
|
|||||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||||
AC_ARG_WITH(rubyarchprefix,
|
AC_ARG_WITH(rubyarchprefix,
|
||||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||||
@@ -4162,58 +4159,64 @@ AC_ARG_WITH(ridir,
|
@@ -4202,58 +4199,64 @@ AC_ARG_WITH(ridir,
|
||||||
AC_SUBST(ridir)
|
AC_SUBST(ridir)
|
||||||
AC_SUBST(RI_BASE_NAME)
|
AC_SUBST(RI_BASE_NAME)
|
||||||
|
|
||||||
@ -124,7 +124,7 @@ index db37cd6..6e73fae 100644
|
|||||||
|
|
||||||
if test "${LOAD_RELATIVE+set}"; then
|
if test "${LOAD_RELATIVE+set}"; then
|
||||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||||
@@ -4230,6 +4233,7 @@ AC_SUBST(sitearchincludedir)dnl
|
@@ -4270,6 +4273,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||||
AC_SUBST(arch)dnl
|
AC_SUBST(arch)dnl
|
||||||
AC_SUBST(sitearch)dnl
|
AC_SUBST(sitearch)dnl
|
||||||
AC_SUBST(ruby_version)dnl
|
AC_SUBST(ruby_version)dnl
|
||||||
@ -286,7 +286,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 6e73fae..c842725 100644
|
index 6e73fae..c842725 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -274,7 +274,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
@@ -275,7 +275,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||||
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`
|
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`
|
||||||
AC_SUBST(RUBY_BASE_NAME)
|
AC_SUBST(RUBY_BASE_NAME)
|
||||||
AC_SUBST(RUBYW_BASE_NAME)
|
AC_SUBST(RUBYW_BASE_NAME)
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 98e565ec78cb4a07ffde8589ac4581fca31e9c17 Mon Sep 17 00:00:00 2001
|
|
||||||
From: mrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
|
||||||
Date: Thu, 7 Jan 2016 13:35:32 +0000
|
|
||||||
Subject: [PATCH] * ruby.h: undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
|
||||||
and HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P on C++. [ruby-core:72736]
|
|
||||||
[Bug #11962]
|
|
||||||
|
|
||||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53455 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
|
||||||
---
|
|
||||||
ChangeLog | 6 ++++++
|
|
||||||
include/ruby/ruby.h | 7 +++++++
|
|
||||||
2 files changed, 13 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/include/ruby/ruby.h b/include/ruby/ruby.h
|
|
||||||
index 7aabf5b..82dca14 100644
|
|
||||||
--- a/include/ruby/ruby.h
|
|
||||||
+++ b/include/ruby/ruby.h
|
|
||||||
@@ -26,6 +26,13 @@ extern "C" {
|
|
||||||
#include RUBY_EXTCONF_H
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#if defined(__cplusplus)
|
|
||||||
+/* __builtin_choose_expr and __builtin_types_compatible aren't available
|
|
||||||
+ * on C++. See https://gcc.gnu.org/onlinedocs/gcc/Other-Builtins.html */
|
|
||||||
+# undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
|
||||||
+# undef HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#include "defines.h"
|
|
||||||
|
|
||||||
#define NORETURN_STYLE_NEW 1
|
|
25
ruby-2.4.0-increase-timeout-for-ARMv7.patch
Normal file
25
ruby-2.4.0-increase-timeout-for-ARMv7.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 35568b41699ca1cd466fc8d23a84139b73ad0f1b Mon Sep 17 00:00:00 2001
|
||||||
|
From: naruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||||
|
Date: Tue, 19 Jan 2016 02:52:37 +0000
|
||||||
|
Subject: [PATCH] increase timeout for ARMv7
|
||||||
|
|
||||||
|
http://rubyci.s3.amazonaws.com/scw-9d6766/ruby-trunk/log/20160113T091704Z.diff.html.gz
|
||||||
|
|
||||||
|
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53586 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||||
|
---
|
||||||
|
test/ruby/test_iseq.rb | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/ruby/test_iseq.rb b/test/ruby/test_iseq.rb
|
||||||
|
index 7af8c1b..4561eeb 100644
|
||||||
|
--- a/test/ruby/test_iseq.rb
|
||||||
|
+++ b/test/ruby/test_iseq.rb
|
||||||
|
@@ -187,7 +187,7 @@ def test_safe_call_chain
|
||||||
|
end
|
||||||
|
|
||||||
|
def test_parent_iseq_mark
|
||||||
|
- assert_separately([], <<-'end;')
|
||||||
|
+ assert_separately([], <<-'end;', timeout: 20)
|
||||||
|
->{
|
||||||
|
->{
|
||||||
|
->{
|
14
ruby.spec
14
ruby.spec
@ -1,6 +1,6 @@
|
|||||||
%global major_version 2
|
%global major_version 2
|
||||||
%global minor_version 3
|
%global minor_version 3
|
||||||
%global teeny_version 0
|
%global teeny_version 1
|
||||||
%global major_minor_version %{major_version}.%{minor_version}
|
%global major_minor_version %{major_version}.%{minor_version}
|
||||||
|
|
||||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||||
@ -21,7 +21,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global release 54
|
%global release 55
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||||
|
|
||||||
# The RubyGems library has to stay out of Ruby directory three, since the
|
# The RubyGems library has to stay out of Ruby directory three, since the
|
||||||
@ -122,10 +122,9 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
|||||||
# Use miniruby to regenerate prelude.c.
|
# Use miniruby to regenerate prelude.c.
|
||||||
# https://bugs.ruby-lang.org/issues/10554
|
# https://bugs.ruby-lang.org/issues/10554
|
||||||
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||||
# 98e565ec78cb4a07ffde8589ac4581fca31e9c17
|
# Prevent test failures on ARM.
|
||||||
# https://bugs.ruby-lang.org/issues/11962
|
# https://bugs.ruby-lang.org/issues/12331
|
||||||
# https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/53455
|
Patch8: ruby-2.4.0-increase-timeout-for-ARMv7.patch
|
||||||
Patch8: ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch
|
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Suggests: rubypick
|
Suggests: rubypick
|
||||||
@ -952,6 +951,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{ruby_libdir}/tkextlib
|
%{ruby_libdir}/tkextlib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 29 2016 Vít Ondruch <vondruch@redhat.com> - 2.3.1-55
|
||||||
|
- Update to Ruby 2.3.1.
|
||||||
|
|
||||||
* Wed Feb 3 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.3.0-54
|
* Wed Feb 3 2016 Peter Robinson <pbrobinson@fedoraproject.org> 2.3.0-54
|
||||||
- Add rubypick and rubygems requires to ruby-devel to deal with BuildRequires
|
- Add rubypick and rubygems requires to ruby-devel to deal with BuildRequires
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user