Upgrade to Ruby 2.0.0 (r35368).

This commit is contained in:
Vít Ondruch 2012-04-18 19:40:36 +02:00
parent 7fe201b148
commit ea3cb65d83
7 changed files with 54 additions and 49 deletions

View File

@ -15,7 +15,7 @@ diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..f57e4c4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -34,6 +34,9 @@ datadir = @datadir@
@@ -37,6 +37,9 @@ datadir = @datadir@
archdir = @archdir@
sitearch = @sitearch@
sitedir = @sitedir@
@ -29,7 +29,7 @@ diff --git a/configure.in b/configure.in
index 83e5d76..31532bd 100644
--- a/configure.in
+++ b/configure.in
@@ -2811,6 +2811,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
@@ -2866,6 +2866,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
dir="${SITE_DIR}"
done
@ -45,7 +45,7 @@ index 83e5d76..31532bd 100644
AC_ARG_WITH(vendordir,
AS_HELP_STRING([--with-vendordir=DIR], [vendor libraries in DIR [[RUBY_LIB_PREFIX/vendor_ruby]], "no" to disable vendor directory]),
[vendordir=$withval],
@@ -2820,19 +2829,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -2875,19 +2884,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDOR_DIR}"
done
@ -78,7 +78,7 @@ index 83e5d76..31532bd 100644
fi
pat=`echo "$RUBY_LIB_PREFIX/" | tr -c '\012' .`'\(.*\)'
@@ -2850,6 +2872,13 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
@@ -2905,12 +2927,26 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
[
RUBY_SITE_LIB_PATH="\"${RUBY_SITE_LIB_PATH}\""
])
@ -92,31 +92,30 @@ index 83e5d76..31532bd 100644
AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_VENDOR_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_VENDOR_LIB_PATH\" : \"$pat\"`"'"'
@@ -2857,6 +2886,13 @@ AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
],
[
RUBY_VENDOR_LIB_PATH="\"${RUBY_VENDOR_LIB_PATH}\""
])
+ ])
+AS_CASE(["$RUBY_VENDOR_ARCHLIB_PATH"],
+ ["$RUBY_LIB_PREFIX/"*], [
+ RUBY_VENDOR_ARCHLIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_VENDOR_ARCHLIB_PATH\" : \"$pat\"`"'"'
+ ],
+ [
+ RUBY_VENDOR_ARCHLIB_PATH="\"${RUBY_VENDOR_ARCHLIB_PATH}\""
+ ])
])
pat=`echo "$RUBY_EXEC_PREFIX/" | tr -c '\012' .`'\(.*\)'
AS_CASE(["$RUBY_LIB_PREFIX"],
["$RUBY_EXEC_PREFIX/"*], [
@@ -2878,19 +2914,23 @@ if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB)
@@ -2933,19 +2969,23 @@ if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, ${RUBY_SITE_LIB_PATH})
+ AC_DEFINE_UNQUOTED(RUBY_SITE_ARCHLIB, ${RUBY_SITE_ARCHLIB_PATH})
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, ${RUBY_SITE_LIB_PATH} !<verconf>!)
+ AC_DEFINE_UNQUOTED(RUBY_SITE_ARCHLIB, ${RUBY_SITE_ARCHLIB_PATH} !<verconf>!)
fi
if test "x$VENDOR_DIR" = xno; then
AC_DEFINE(NO_RUBY_VENDOR_LIB)
AC_DEFINE(NO_RUBY_VENDOR_LIB, [] !<verconf>!)
else
AC_DEFINE_UNQUOTED(RUBY_VENDOR_LIB, ${RUBY_VENDOR_LIB_PATH})
+ AC_DEFINE_UNQUOTED(RUBY_VENDOR_ARCHLIB, ${RUBY_VENDOR_ARCHLIB_PATH})
AC_DEFINE_UNQUOTED(RUBY_VENDOR_LIB, ${RUBY_VENDOR_LIB_PATH} !<verconf>!)
+ AC_DEFINE_UNQUOTED(RUBY_VENDOR_ARCHLIB, ${RUBY_VENDOR_ARCHLIB_PATH} !<verconf>!)
fi
AC_SUBST(arch)dnl
@ -170,7 +169,7 @@ diff --git a/version.c b/version.c
index 59d4e5e..2558aa0 100644
--- a/version.c
+++ b/version.c
@@ -50,8 +50,12 @@
@@ -51,8 +51,12 @@
#ifndef RUBY_ARCHLIB
#define RUBY_ARCHLIB RUBY_LIB "/"RUBY_ARCH
#endif

View File

@ -1,6 +1,6 @@
--- a/configure.in.orig 2011-10-18 08:56:21.587594685 +0200
+++ b/configure.in 2011-10-18 08:56:59.751593321 +0200
@@ -2935,6 +2935,8 @@
@@ -2990,6 +2990,8 @@
configure_args=$ac_configure_args
AC_SUBST(configure_args)dnl

View File

@ -14,7 +14,7 @@ diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..d61b2ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -31,6 +31,7 @@ libexecdir = @libexecdir@
@@ -34,6 +34,7 @@ libexecdir = @libexecdir@
datarootdir = @datarootdir@
datadir = @datadir@
arch = @arch@
@ -26,7 +26,7 @@ diff --git a/configure.in b/configure.in
index 83e5d76..e6dc38c 100644
--- a/configure.in
+++ b/configure.in
@@ -2793,6 +2793,15 @@ else
@@ -2848,6 +2848,15 @@ else
RUBY_LIB_VERSION="\"${ruby_version}\""
fi
@ -42,7 +42,7 @@ index 83e5d76..e6dc38c 100644
AC_ARG_WITH(sitedir,
AS_HELP_STRING([--with-sitedir=DIR], [site libraries in DIR [[RUBY_LIB_PREFIX/site_ruby]], "no" to disable site directory]),
[sitedir=$withval],
@@ -2815,16 +2824,25 @@ if test "${LOAD_RELATIVE+set}"; then
@@ -2870,16 +2879,25 @@ if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
RUBY_LIB_PREFIX="`eval echo "$RUBY_LIB_PREFIX" | sed 's|^NONE/|/|;s|^'"$prefix"'/|/|'`"
@ -68,15 +68,15 @@ index 83e5d76..e6dc38c 100644
AS_CASE(["$RUBY_SITE_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_SITE_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_SITE_LIB_PATH\" : \"$pat\"`"'"'
@@ -2855,6 +2873,7 @@ else
@@ -2910,6 +2928,7 @@
fi
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, "${RUBY_EXEC_PREFIX}")
AC_DEFINE_UNQUOTED(RUBY_LIB_PREFIX, ${RUBY_LIB_PREFIX})
+AC_DEFINE_UNQUOTED(RUBY_ARCHLIB, ${RUBY_ARCH_LIB_PATH})
AC_DEFINE_UNQUOTED(RUBY_LIB_PREFIX, ${RUBY_LIB_PREFIX} !<verconf>!)
+AC_DEFINE_UNQUOTED(RUBY_ARCHLIB, ${RUBY_ARCH_LIB_PATH} !<verconf>!)
if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB)
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
@@ -2869,6 +2888,7 @@ fi
@@ -2924,6 +2943,7 @@ fi
AC_SUBST(arch)dnl
AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl
@ -117,7 +117,7 @@ diff --git a/version.c b/version.c
index 59d4e5e..915a0a2 100644
--- a/version.c
+++ b/version.c
@@ -47,7 +47,9 @@
@@ -48,7 +48,9 @@
#define RUBY_SITE_LIB2 RUBY_SITE_LIB "/"RUBY_LIB_VERSION
#define RUBY_VENDOR_LIB2 RUBY_VENDOR_LIB "/"RUBY_LIB_VERSION
#endif

View File

@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
index b1bc951..91c5d0d 100644
--- a/configure.in
+++ b/configure.in
@@ -2838,6 +2838,13 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -2893,6 +2893,13 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDORARCH_DIR}"
done
@ -29,7 +29,7 @@ index b1bc951..91c5d0d 100644
if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
@@ -2931,6 +2938,7 @@ AC_SUBST(sitearch)dnl
@@ -2986,6 +2993,7 @@ AC_SUBST(sitearch)dnl
AC_SUBST(sitearchdir)dnl
AC_SUBST(vendordir)dnl
AC_SUBST(vendorarchdir)dnl
@ -53,15 +53,15 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index 6bfc73e..31dc446 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -300,6 +300,7 @@ sitelibdir = CONFIG["sitelibdir"]
@@ -311,6 +311,7 @@ sitelibdir = CONFIG["sitelibdir"]
sitearchlibdir = CONFIG["sitearchdir"]
vendorlibdir = CONFIG["vendorlibdir"]
vendorarchlibdir = CONFIG["vendorarchdir"]
+rubygemsdir = CONFIG["rubygemsdir"]
mandir = CONFIG["mandir"]
capidir = CONFIG["docdir"]
mandir = CONFIG["mandir", true]
capidir = CONFIG["docdir", true]
configure_args = Shellwords.shellwords(CONFIG["configure_args"])
@@ -487,7 +488,15 @@ end
@@ -498,7 +499,15 @@ end
install?(:local, :comm, :lib) do
prepare "library scripts", rubylibdir
noinst = %w[README* *.txt *.rdoc]
@ -81,7 +81,7 @@ diff --git a/version.c b/version.c
index 59d4e5e..12ba7e9 100644
--- a/version.c
+++ b/version.c
@@ -103,6 +103,10 @@ const char ruby_initial_load_paths[] =
@@ -104,6 +104,10 @@ const char ruby_initial_load_paths[] =
#endif
#endif

View File

@ -13,7 +13,7 @@ diff --git a/configure.in b/configure.in
index e742e74..86cb68f 100644
--- a/configure.in
+++ b/configure.in
@@ -2963,6 +2963,17 @@ else
@@ -3018,6 +3018,17 @@ else
fi
AC_SUBST(USE_RUBYGEMS)
@ -75,7 +75,7 @@ diff --git a/version.c b/version.c
index 59d4e5e..641dc33 100644
--- a/version.c
+++ b/version.c
@@ -38,9 +38,15 @@
@@ -39,9 +39,15 @@
#define RUBY_VENDOR_LIB RUBY_LIB_PREFIX"/vendor_ruby"
#endif
@ -91,7 +91,7 @@ index 59d4e5e..641dc33 100644
#define RUBY_ARCHLIB RUBY_LIB "/"RUBY_ARCH
#define RUBY_SITE_ARCHLIB RUBY_SITE_LIB2 "/"RUBY_SITEARCH
#define RUBY_VENDOR_ARCHLIB RUBY_VENDOR_LIB2 "/"RUBY_SITEARCH
@@ -75,8 +81,10 @@ const char ruby_initial_load_paths[] =
@@ -76,8 +82,10 @@ const char ruby_initial_load_paths[] =
RUBY_SITE_THIN_ARCHLIB "\0"
#endif
RUBY_SITE_ARCHLIB "\0"
@ -102,7 +102,7 @@ index 59d4e5e..641dc33 100644
#ifndef NO_RUBY_VENDOR_LIB
RUBY_VENDOR_LIB2 "\0"
@@ -84,8 +92,10 @@ const char ruby_initial_load_paths[] =
@@ -85,8 +93,10 @@ const char ruby_initial_load_paths[] =
RUBY_VENDOR_THIN_ARCHLIB "\0"
#endif
RUBY_VENDOR_ARCHLIB "\0"
@ -135,7 +135,7 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index cec8c9f..fed14d2 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -379,7 +379,7 @@ end
@@ -390,7 +390,7 @@ end
install?(:doc, :rdoc) do
if $rdocdir

View File

@ -1,6 +1,6 @@
--- ruby-1.9.3-p0/lib/mkmf.rb.debug 2011-08-11 15:07:37.000000000 +0900
+++ ruby-1.9.3-p0/lib/mkmf.rb 2012-01-29 21:34:17.000000000 +0900
@@ -1701,7 +1701,7 @@
@@ -1725,7 +1725,7 @@
SHELL = /bin/sh
# V=0 quiet, V=1 verbose. other values don't work.

View File

@ -11,7 +11,13 @@
# %global ruby_abi %{major_minor_version}.0
%global ruby_abi 1.9.1
%global ruby_archive %{name}-%{ruby_version}-p%{patch_level}
# If revision is removed/commented out, the official release build is expected.
# Keep the revision enabled for pre-releases from SVN.
%global revision 35368
%global release 1
%global ruby_archive %{name}-%{ruby_version}-%{?revision:r%{revision}}%{!?revision:p%{patch_level}}
%global ruby_libdir %{_datadir}/%{name}
%global ruby_libarchdir %{_libdir}/%{name}
@ -45,7 +51,7 @@
%global rdoc_version 3.9.5
%global bigdecimal_version 1.1.0
%global io_console_version 0.3
%global json_version 1.5.4
%global json_version 1.6.6
%global minitest_version 2.8.1
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
@ -53,12 +59,7 @@
Summary: An interpreter of object-oriented scripting language
Name: ruby
Version: %{ruby_version_patch_level}
# Note:
# As seen on perl srpm, as this (ruby) srpm contains several sub-components,
# we cannot reset the release number to 1 even when the main (ruby) version
# is updated - because it may be that the versions of sub-components don't
# change.
Release: 28%{?dist}
Release: %{?revision:0.}%{release}%{?revision:.r%{revision}}%{?dist}
Group: Development/Languages
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
License: (Ruby or BSD) and Public Domain
@ -484,8 +485,13 @@ sed -i '8 a\
%check
# TODO: Investigate the test failures.
# https://bugs.ruby-lang.org/issues/6036
make check TESTS="-v -x test_pathname.rb -x test_drbssl.rb -x test_x509cert.rb"
# OpenSSL 1.0.1 is breaking the drb test suite.
# https://bugs.ruby-lang.org/issues/6221
# TestTimeTZ failures - Resolved by r35377.
# https://bugs.ruby-lang.org/issues/6318
# TestWEBrickHTTPRequest and WEBrick::TestFileHandler fail
# https://bugs.ruby-lang.org/issues/6319
make check TESTS="-v -x test_drbssl.rb -x test_time_tz.rb -x test_httprequest.rb -x test_filehandler.rb"
%post libs -p /sbin/ldconfig