- ruby-deprecated-search-path.patch: added the deprecated installation
paths to the search path for the backward compatibility. - added a Provides: ruby(abi) to ruby-libs.
This commit is contained in:
parent
38b1bf15b2
commit
ea33ea129d
45
ruby-deprecated-search-path.patch
Normal file
45
ruby-deprecated-search-path.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
バイナリー・ファイルruby-1.8.4.orig/.ruby.c.swpとruby-1.8.4/.ruby.c.swpは違います
|
||||||
|
diff -ruN ruby-1.8.4.orig/configure.in ruby-1.8.4/configure.in
|
||||||
|
--- ruby-1.8.4.orig/configure.in 2006-04-20 12:53:38.000000000 +0900
|
||||||
|
+++ ruby-1.8.4/configure.in 2006-04-20 13:06:07.000000000 +0900
|
||||||
|
@@ -1472,10 +1472,14 @@
|
||||||
|
esac
|
||||||
|
RUBY_SITE_LIB_PATH3="${RUBY_SITE_LIB_PATH2}/${MAJOR}.${MINOR}"
|
||||||
|
RUBY_SITE_LIB_PATH2="${RUBY_SITE_LIB_PATH}/${MAJOR}.${MINOR}"
|
||||||
|
+RUBY_DEPRECATED_SITE_LIB_PATH="${SITE_DIR2}/${MAJOR}.${MINOR}"
|
||||||
|
|
||||||
|
AC_DEFINE_UNQUOTED(RUBY_LIB, "${RUBY_LIB_PATH}")
|
||||||
|
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, "${RUBY_SITE_LIB_PATH}")
|
||||||
|
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB2, "${RUBY_SITE_LIB_PATH2}")
|
||||||
|
+AC_DEFINE_UNQUOTED(RUBY_DEPRECATED_LIB, "${RUBY_LIB_PATH2}")
|
||||||
|
+AC_DEFINE_UNQUOTED(RUBY_DEPRECATED_SITE_LIB, "${SITE_DIR2}")
|
||||||
|
+AC_DEFINE_UNQUOTED(RUBY_DEPRECATED_SITE_LIB2, "${RUBY_DEPRECATED_SITE_LIB_PATH}")
|
||||||
|
|
||||||
|
AC_SUBST(arch)dnl
|
||||||
|
AC_SUBST(sitearch)dnl
|
||||||
|
diff -ruN ruby-1.8.4.orig/ruby.c ruby-1.8.4/ruby.c
|
||||||
|
--- ruby-1.8.4.orig/ruby.c 2005-12-12 09:36:52.000000000 +0900
|
||||||
|
+++ ruby-1.8.4/ruby.c 2006-04-20 12:59:50.000000000 +0900
|
||||||
|
@@ -292,13 +292,22 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_SITE_LIB2));
|
||||||
|
+#ifdef RUBY_DEPRECATED_SITE_LIB
|
||||||
|
+ ruby_incpush(RUBY_RELATIVE(RUBY_DEPRECATED_SITE_LIB2));
|
||||||
|
+#endif
|
||||||
|
#ifdef RUBY_SITE_THIN_ARCHLIB
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_SITE_THIN_ARCHLIB));
|
||||||
|
#endif
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_SITE_ARCHLIB));
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_SITE_LIB));
|
||||||
|
+#ifdef RUBY_DEPRECATED_SITE_LIB
|
||||||
|
+ ruby_incpush(RUBY_RELATIVE(RUBY_DEPRECATED_SITE_LIB));
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_LIB));
|
||||||
|
+#ifdef RUBY_DEPRECATED_LIB
|
||||||
|
+ ruby_incpush(RUBY_RELATIVE(RUBY_DEPRECATED_LIB));
|
||||||
|
+#endif
|
||||||
|
#ifdef RUBY_THIN_ARCHLIB
|
||||||
|
ruby_incpush(RUBY_RELATIVE(RUBY_THIN_ARCHLIB));
|
||||||
|
#endif
|
14
ruby.spec
14
ruby.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: ruby
|
Name: ruby
|
||||||
Version: 1.8.4
|
Version: 1.8.4
|
||||||
Release: 4.fc6.1
|
Release: 4.fc6.2
|
||||||
License: Distributable
|
License: Distributable
|
||||||
URL: http://www.ruby-lang.org/
|
URL: http://www.ruby-lang.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -25,8 +25,9 @@ Source10: ruby-mode-init.el
|
|||||||
Patch1: ruby-1.8.2-deadcode.patch
|
Patch1: ruby-1.8.2-deadcode.patch
|
||||||
Patch2: ruby-1.8.4-no-eaccess.patch
|
Patch2: ruby-1.8.4-no-eaccess.patch
|
||||||
Patch3: ruby-rubyprefix.patch
|
Patch3: ruby-rubyprefix.patch
|
||||||
Patch4: ruby-multilib.patch
|
Patch4: ruby-deprecated-search-path.patch
|
||||||
Patch5: ruby-tcltk-multilib.patch
|
Patch5: ruby-multilib.patch
|
||||||
|
Patch6: ruby-tcltk-multilib.patch
|
||||||
|
|
||||||
Summary: An interpreter of object-oriented scripting language
|
Summary: An interpreter of object-oriented scripting language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -42,6 +43,7 @@ straight-forward, and extensible.
|
|||||||
%package libs
|
%package libs
|
||||||
Summary: Libraries necessary to run Ruby.
|
Summary: Libraries necessary to run Ruby.
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
|
Provides: ruby(abi) = %{rubyxver}
|
||||||
Provides: libruby
|
Provides: libruby
|
||||||
Obsoletes: libruby
|
Obsoletes: libruby
|
||||||
|
|
||||||
@ -139,6 +141,7 @@ pushd %{name}-%{version}
|
|||||||
%ifarch ppc64 s390x sparc64 x86_64
|
%ifarch ppc64 s390x sparc64 x86_64
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
%endif
|
%endif
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -433,6 +436,11 @@ rm -rf tmp-ruby-docs
|
|||||||
%dir %{_datadir}/emacs/site-lisp/ruby-mode
|
%dir %{_datadir}/emacs/site-lisp/ruby-mode
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 20 2006 Akira TAGOH <tagoh@redhat.com>
|
||||||
|
- ruby-deprecated-search-path.patch: added the deprecated installation paths
|
||||||
|
to the search path for the backward compatibility.
|
||||||
|
- added a Provides: ruby(abi) to ruby-libs.
|
||||||
|
|
||||||
* Wed Apr 19 2006 Akira TAGOH <tagoh@redhat.com>
|
* Wed Apr 19 2006 Akira TAGOH <tagoh@redhat.com>
|
||||||
- ruby-rubyprefix.patch: moved all arch-independent modules to /usr/lib/ruby
|
- ruby-rubyprefix.patch: moved all arch-independent modules to /usr/lib/ruby
|
||||||
and keep arch-dependent modules in /usr/lib64/ruby for 64bit arch.
|
and keep arch-dependent modules in /usr/lib64/ruby for 64bit arch.
|
||||||
|
Loading…
Reference in New Issue
Block a user