Update to Ruby 2.1.2
This commit is contained in:
parent
098cd8787a
commit
d09c32278d
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@ ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
||||
/ruby-2.0.0-p247.tar.bz2
|
||||
/ruby-2.0.0-p353.tar.bz2
|
||||
/ruby-2.1.1.tar.bz2
|
||||
/ruby-2.1.2.tar.bz2
|
||||
|
@ -1,33 +0,0 @@
|
||||
From d5c45b5fb11748acbfc9ee6c7dbfeb04408de53d Mon Sep 17 00:00:00 2001
|
||||
From: naruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Sat, 1 Mar 2014 09:02:36 +0000
|
||||
Subject: [PATCH] merge revision(s) 44370: [Backport #9576]
|
||||
|
||||
hash.c: extra states
|
||||
|
||||
* hash.c (rb_hash_reject): use words "extra states".
|
||||
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@45227 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
hash.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/hash.c b/hash.c
|
||||
index 66cd94b..9a5814a 100644
|
||||
--- a/hash.c
|
||||
+++ b/hash.c
|
||||
@@ -1178,7 +1178,7 @@ struct shift_var {
|
||||
#endif
|
||||
}
|
||||
}
|
||||
-#if HASH_REJECT_COPY_MISC_ATTRIBUTES
|
||||
+#if HASH_REJECT_COPY_EXTRA_STATES
|
||||
result = rb_hash_dup_empty(hash);
|
||||
#else
|
||||
result = rb_hash_new();
|
||||
diff --git a/version.h b/version.h
|
||||
index 8c8f900..59c80e3 100644
|
||||
--
|
||||
1.9.1
|
||||
|
12
ruby.spec
12
ruby.spec
@ -1,7 +1,7 @@
|
||||
%global major_version 2
|
||||
%global minor_version 1
|
||||
%global teeny_version 1
|
||||
%global patch_level 76
|
||||
%global teeny_version 2
|
||||
%global patch_level 95
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -44,7 +44,7 @@
|
||||
%global io_console_version 0.4.2
|
||||
%global json_version 1.8.1
|
||||
%global minitest_version 4.7.5
|
||||
%global psych_version 2.0.3
|
||||
%global psych_version 2.0.5
|
||||
%global rake_version 10.1.0
|
||||
%global rdoc_version 4.1.0
|
||||
|
||||
@ -115,8 +115,6 @@ Patch12: ruby-1.9.3-mkmf-verbose.patch
|
||||
# in support for ABRT.
|
||||
# http://bugs.ruby-lang.org/issues/8566
|
||||
Patch17: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# https://www.ruby-lang.org/en/news/2014/03/10/regression-of-hash-reject-in-ruby-2-1-1/
|
||||
Patch18: ruby-2.1.2-p79-hash.c-extra-states.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||
@ -377,7 +375,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
||||
%patch8 -p1
|
||||
%patch12 -p1
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -869,6 +866,9 @@ OPENSSL_ENABLE_MD5_VERIFY=1 make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Tue May 20 2014 Josef Stribny <jstribny@redhat.com> - 2.1.2-21
|
||||
- Update to Ruby 2.1.2
|
||||
|
||||
* Tue May 06 2014 Vít Ondruch <vondruch@redhat.com> - 2.1.1-20
|
||||
- Remove useless exclude (rhbz#1065897).
|
||||
- Extract load macro into external file and include it.
|
||||
|
Loading…
Reference in New Issue
Block a user