Upgrade to Ruby 2.0.0 (r39357).

This commit is contained in:
Vít Ondruch 2013-02-21 14:36:05 +01:00
parent 03c34a7e1f
commit cdd0186c31
7 changed files with 21 additions and 17 deletions

View File

@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
index 418b0cb..d26fe5b 100644 index 418b0cb..d26fe5b 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -3320,6 +3320,8 @@ AC_SUBST(vendorarchdir)dnl @@ -3362,6 +3362,8 @@ AC_SUBST(vendorarchdir)dnl
configure_args=$ac_configure_args configure_args=$ac_configure_args
AC_SUBST(configure_args)dnl AC_SUBST(configure_args)dnl

View File

@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
index d6af000..1c094a3 100644 index d6af000..1c094a3 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -3188,6 +3188,10 @@ AC_SUBST(rubylibprefix) @@ -3217,6 +3217,10 @@ AC_SUBST(rubylibprefix)
rubylibdir='${rubylibprefix}/${ruby_version}' rubylibdir='${rubylibprefix}/${ruby_version}'
rubyarchdir=${multiarch+'${rubyarchprefix}/${ruby_version}'}${multiarch-'${rubylibdir}/${arch}'} rubyarchdir=${multiarch+'${rubyarchprefix}/${ruby_version}'}${multiarch-'${rubylibdir}/${arch}'}

View File

@ -14,9 +14,9 @@ diff --git a/configure.in b/configure.in
index 1627d12..e064b2b 100644 index 1627d12..e064b2b 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -3256,6 +3256,13 @@ AC_ARG_WITH(vendorarchdir, @@ -3292,6 +3292,13 @@ AC_ARG_WITH(vendorarchdir,
[vendorarchdir=$withval], [vendorarchdir=$withval],
[vendorarchdir=${multiarch+'${rubyarchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}]) [vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
+AC_ARG_WITH(rubygemsdir, +AC_ARG_WITH(rubygemsdir,
+ AS_HELP_STRING([--with-rubygemsdir=DIR], [custom rubygems directory]), + AS_HELP_STRING([--with-rubygemsdir=DIR], [custom rubygems directory]),
@ -25,10 +25,10 @@ index 1627d12..e064b2b 100644
+ AC_DEFINE_UNQUOTED(RUBYGEMS_DIR,"$rubygemsdir" !<verconf>!) + AC_DEFINE_UNQUOTED(RUBYGEMS_DIR,"$rubygemsdir" !<verconf>!)
+fi +fi
+ +
if test "${LOAD_RELATIVE+set}"; then unexpand_shvar rubylibprefix exec_prefix libdir RUBY_BASE_NAME
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE) unexpand_shvar rubyarchprefix exec_prefix libdir arch RUBY_BASE_NAME archlibdir rubylibprefix
RUBY_EXEC_PREFIX='""' unexpand_shvar rubysitearchprefix exec_prefix libdir sitearch arch RUBY_BASE_NAME archlibdir sitearchlibdir rubylibprefix
@@ -3316,6 +3323,7 @@ AC_SUBST(sitearchdir)dnl @@ -3358,6 +3365,7 @@ AC_SUBST(sitearchdir)dnl
AC_SUBST(vendordir)dnl AC_SUBST(vendordir)dnl
AC_SUBST(vendorlibdir)dnl AC_SUBST(vendorlibdir)dnl
AC_SUBST(vendorarchdir)dnl AC_SUBST(vendorarchdir)dnl

View File

@ -13,7 +13,7 @@ diff --git a/configure.in b/configure.in
index 5850bbf..7604bb8 100644 index 5850bbf..7604bb8 100644
--- a/configure.in --- a/configure.in
+++ b/configure.in +++ b/configure.in
@@ -3265,6 +3265,9 @@ shvar_to_cpp RIDIR "${ridir}" @@ -3306,6 +3306,9 @@ unexpand_shvar exec_prefix prefix
if test ${RUBY_LIB_VERSION_STYLE+set}; then if test ${RUBY_LIB_VERSION_STYLE+set}; then
AC_DEFINE_UNQUOTED(RUBY_LIB_VERSION_STYLE, $RUBY_LIB_VERSION_STYLE !<verconf>!) AC_DEFINE_UNQUOTED(RUBY_LIB_VERSION_STYLE, $RUBY_LIB_VERSION_STYLE !<verconf>!)
else else

View File

@ -13,7 +13,7 @@
#%%global milestone preview2 #%%global milestone preview2
# Keep the revision enabled for pre-releases from SVN. # Keep the revision enabled for pre-releases from SVN.
%global revision 39237 %global revision 39357
%global ruby_archive %{name}-%{ruby_version} %global ruby_archive %{name}-%{ruby_version}
@ -42,7 +42,7 @@
%global ruby_vendorlibdir %{_datadir}/ruby/%{ruby_vendordir} %global ruby_vendorlibdir %{_datadir}/ruby/%{ruby_vendordir}
%global ruby_vendorarchdir %{_libdir}/ruby/%{ruby_vendordir} %global ruby_vendorarchdir %{_libdir}/ruby/%{ruby_vendordir}
%global rubygems_version 2.0.0.rc.2 %global rubygems_version 2.0.0
# The RubyGems library has to stay out of Ruby directory three, since the # The RubyGems library has to stay out of Ruby directory three, since the
# RubyGems should be share by all Ruby implementations. # RubyGems should be share by all Ruby implementations.
@ -59,7 +59,7 @@
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM. # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
# http://redmine.ruby-lang.org/issues/5313 # http://redmine.ruby-lang.org/issues/5313
%global irb_version %{ruby_version_patch_level} %global irb_version %{ruby_version_patch_level}
%global rdoc_version 4.0.0.rc.2.1 %global rdoc_version 4.0.0
%global bigdecimal_version 1.1.0 %global bigdecimal_version 1.1.0
%global io_console_version 0.4.1 %global io_console_version 0.4.1
%global json_version 1.7.7 %global json_version 1.7.7
@ -557,6 +557,10 @@ DISABLE_TESTS="-x test_dl2.rb $DISABLE_TESTS"
DISABLE_TESTS="-x test_io.rb $DISABLE_TESTS" DISABLE_TESTS="-x test_io.rb $DISABLE_TESTS"
%endif %endif
# The TestRbConfig errors, which does not respect configuration options.
# http://bugs.ruby-lang.org/issues/7902
DISABLE_TESTS="-x test_rbconfig.rb $DISABLE_TESTS"
make check TESTS="-v $DISABLE_TESTS" make check TESTS="-v $DISABLE_TESTS"
%post libs -p /sbin/ldconfig %post libs -p /sbin/ldconfig

View File

@ -131,7 +131,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 780a88b..6543130 100644 index 780a88b..6543130 100644
--- a/lib/rubygems/installer.rb --- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb +++ b/lib/rubygems/installer.rb
@@ -535,13 +535,13 @@ class Gem::Installer @@ -536,13 +536,13 @@ class Gem::Installer
:bin_dir => nil, :bin_dir => nil,
:env_shebang => false, :env_shebang => false,
:force => false, :force => false,

View File

@ -85,7 +85,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 780a88b..854c177 100644 index 780a88b..854c177 100644
--- a/lib/rubygems/installer.rb --- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb +++ b/lib/rubygems/installer.rb
@@ -642,7 +642,7 @@ TEXT @@ -645,7 +645,7 @@ TEXT
say "This could take a while..." say "This could take a while..."
end end
@ -178,7 +178,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 854c177..f1f2ad7 100644 index 854c177..f1f2ad7 100644
--- a/lib/rubygems/installer.rb --- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb +++ b/lib/rubygems/installer.rb
@@ -642,7 +642,7 @@ TEXT @@ -645,7 +645,7 @@ TEXT
say "This could take a while..." say "This could take a while..."
end end
@ -304,7 +304,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index f1f2ad7..e1577fc 100644 index f1f2ad7..e1577fc 100644
--- a/lib/rubygems/installer.rb --- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb +++ b/lib/rubygems/installer.rb
@@ -642,7 +642,7 @@ TEXT @@ -645,7 +645,7 @@ TEXT
say "This could take a while..." say "This could take a while..."
end end
@ -360,7 +360,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index e1577fc..1492c68 100644 index e1577fc..1492c68 100644
--- a/lib/rubygems/installer.rb --- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb +++ b/lib/rubygems/installer.rb
@@ -642,7 +642,7 @@ TEXT @@ -645,7 +645,7 @@ TEXT
say "This could take a while..." say "This could take a while..."
end end