- Update to 1.8.7 p330
- ext/tk updated to the newest header
This commit is contained in:
parent
8a9a71d5bd
commit
ca286f57ff
2
.gitignore
vendored
2
.gitignore
vendored
@ -2,3 +2,5 @@ ruby-1.8.7-p299.tar.bz2
|
||||
ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
||||
/ruby-1.8.7-p302.tar.bz2
|
||||
/ruby-rev54f344095916f83a2755a177f94e65a1c390a612-ext_tk.tar.gz
|
||||
/ruby-1.8.7-p330.tar.bz2
|
||||
/ruby-revf30eca26639ce538339bc488c7ed1fd397b0c13f-ext_tk.tar.gz
|
||||
|
33
ruby-1.8.7-p330-multilib.patch
Normal file
33
ruby-1.8.7-p330-multilib.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- ruby-1.8.7-p330/mkconfig.rb.multilib 2010-11-24 16:38:41.000000000 +0900
|
||||
+++ ruby-1.8.7-p330/mkconfig.rb 2010-12-26 02:16:32.000000000 +0900
|
||||
@@ -40,6 +40,7 @@
|
||||
has_patchlevel = false
|
||||
continued_name = nil
|
||||
continued_line = nil
|
||||
+lib_64 = ''
|
||||
File.foreach "config.status" do |line|
|
||||
next if /^#/ =~ line
|
||||
name = nil
|
||||
@@ -102,13 +103,21 @@
|
||||
when "PATCHLEVEL"
|
||||
has_patchlevel = true
|
||||
end
|
||||
+
|
||||
+ # If the target architecture is one of the following,
|
||||
+ # ppc64 s390x sparc64 x86_64
|
||||
+ # then use "lib64", not "lib" in prefix.
|
||||
+ if name == "target_cpu" and (/64"$/ =~ val or val == '"s390x"')
|
||||
+ lib_64 = '64'
|
||||
+ end
|
||||
end
|
||||
# break if /^CEOF/
|
||||
end
|
||||
|
||||
drive = File::PATH_SEPARATOR == ';'
|
||||
|
||||
-prefix = '/lib/ruby/' + RUBY_VERSION.sub(/\.\d+$/, '') + '/' + RUBY_PLATFORM
|
||||
+prefix = "/lib#{lib_64}/ruby/" \
|
||||
+ + RUBY_VERSION.sub(/\.\d+$/, '') + '/' + RUBY_PLATFORM
|
||||
print " TOPDIR = File.dirname(__FILE__).chomp!(#{prefix.dump})\n"
|
||||
print " DESTDIR = ", (drive ? "TOPDIR && TOPDIR[/\\A[a-z]:/i] || " : ""), "'' unless defined? DESTDIR\n"
|
||||
print " CONFIG = {}\n"
|
14
ruby.spec
14
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global rubyxver 1.8
|
||||
%global rubyver 1.8.7
|
||||
%global _patchlevel 302
|
||||
%global _patchlevel 330
|
||||
|
||||
%global dotpatchlevel %{?_patchlevel:.%{_patchlevel}}
|
||||
%global patchlevel %{?_patchlevel:-p%{_patchlevel}}
|
||||
@ -12,12 +12,12 @@
|
||||
%{!?sitearchbase: %global sitearchbase %{vendorarchbase}/site_ruby}
|
||||
|
||||
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/')
|
||||
# Sun Aug 22 15:24:07 2010 +0000
|
||||
%global ruby_tk_git_revision 54f344095916f83a2755a177f94e65a1c390a612
|
||||
# Sun Dec 25 17:00:00 2010 +0000
|
||||
%global ruby_tk_git_revision f30eca26639ce538339bc488c7ed1fd397b0c13f
|
||||
|
||||
Name: ruby
|
||||
Version: %{rubyver}%{?dotpatchlevel}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# Please check if ruby upstream changes this to "Ruby or GPLv2+"
|
||||
License: Ruby or GPLv2
|
||||
URL: http://www.ruby-lang.org/
|
||||
@ -52,7 +52,7 @@ Source100: ruby-rev%{ruby_tk_git_revision}-ext_tk.tar.gz
|
||||
# Patches 23, 29, and 33 brought over from ruby 1.8.6
|
||||
# (updated to apply against 1.8.7 source)
|
||||
# If building against a 64bit arch, use 64bit libdir
|
||||
Patch23: ruby-1.8.7-multilib.patch
|
||||
Patch23: ruby-1.8.7-p330-multilib.patch
|
||||
# Mark all i.86 arch's (eg i586, i686, etc) as i386
|
||||
Patch29: ruby-1.8.7-always-use-i386.patch
|
||||
# Use shared libs as opposed to static for mkmf
|
||||
@ -522,6 +522,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/ri
|
||||
|
||||
%changelog
|
||||
* Sun Dec 26 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.7.330-1
|
||||
- Update to 1.8.7 p330
|
||||
- ext/tk updated to the newest header
|
||||
|
||||
* Thu Nov 4 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.7.302-2
|
||||
- Avoid multilib conflict on -libs subpackage (bug 649174)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
a6a9e37079ed8cf8726b455dad3de939 ruby-1.8.7-p302.tar.bz2
|
||||
8f0b8b855f6b18592ac7a76a73c8ec6c ruby-rev54f344095916f83a2755a177f94e65a1c390a612-ext_tk.tar.gz
|
||||
2689719fb42c8cf0aa336f8c8933f413 ruby-1.8.7-p330.tar.bz2
|
||||
fcc35655da3047f64650a526c179ade8 ruby-revf30eca26639ce538339bc488c7ed1fd397b0c13f-ext_tk.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user