Remove useless nosse2 patch.
This commit is contained in:
parent
8dd648e754
commit
c5abc51c7c
@ -1,41 +0,0 @@
|
|||||||
diff -up ruby-2.1.5/configure.in.nosse2 ruby-2.1.5/configure.in
|
|
||||||
--- ruby-2.1.5/configure.in.nosse2 2014-12-26 16:31:57.696889054 -0700
|
|
||||||
+++ ruby-2.1.5/configure.in 2014-12-26 16:32:25.187718930 -0700
|
|
||||||
@@ -860,22 +860,6 @@ if test "$GCC" = yes; then
|
|
||||||
for oflag in -fno-fast-math; do
|
|
||||||
RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
|
|
||||||
done
|
|
||||||
- AS_CASE(["$target"],
|
|
||||||
- [*-darwin*], [
|
|
||||||
- # doesn't seem necessary on Mac OS X
|
|
||||||
- ],
|
|
||||||
- [[i[4-6]86*|i386*mingw*]], [
|
|
||||||
- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
|
|
||||||
- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
|
|
||||||
- ])
|
|
||||||
- AS_CASE(["$XCFLAGS"],
|
|
||||||
- [[*-msse2*]], [
|
|
||||||
- RUBY_TRY_CFLAGS(-mstackrealign, [
|
|
||||||
- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
|
|
||||||
- ])
|
|
||||||
- ])
|
|
||||||
- ]
|
|
||||||
- )
|
|
||||||
fi
|
|
||||||
|
|
||||||
AC_ARG_WITH(opt-dir,
|
|
||||||
diff -up ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 ruby-2.1.5/test/ruby/test_sprintf.rb
|
|
||||||
--- ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 2014-09-03 09:25:51.000000000 -0600
|
|
||||||
+++ ruby-2.1.5/test/ruby/test_sprintf.rb 2014-12-26 16:31:57.699889035 -0700
|
|
||||||
@@ -194,8 +194,9 @@ class TestSprintf < Test::Unit::TestCase
|
|
||||||
sprintf("%20.0f", 36893488147419107329.0))
|
|
||||||
assert_equal(" Inf", sprintf("% 0e", 1.0/0.0), "moved from btest/knownbug")
|
|
||||||
assert_equal(" -0.", sprintf("%#10.0f", -0.5), "[ruby-dev:42552]")
|
|
||||||
- assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
|
|
||||||
- assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
|
|
||||||
+ # out of spec
|
|
||||||
+ #assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
|
|
||||||
+ #assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
|
|
||||||
end
|
|
||||||
|
|
||||||
def test_float_hex
|
|
Loading…
Reference in New Issue
Block a user