Fix FTBFS, Specify tcl/tk 8.6, Add upstream patch to build with libffi 3.1
This commit is contained in:
parent
96581d5c96
commit
c31c7edb69
26
.gitignore
vendored
26
.gitignore
vendored
@ -1,25 +1 @@
|
|||||||
ruby-1.8.7-p299.tar.bz2
|
/ruby-2.*.tar.bz2
|
||||||
ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
|
||||||
/ruby-1.8.7-p302.tar.bz2
|
|
||||||
/ruby-rev54f344095916f83a2755a177f94e65a1c390a612-ext_tk.tar.gz
|
|
||||||
/ruby-1.8.7-p330.tar.bz2
|
|
||||||
/ruby-revf30eca26639ce538339bc488c7ed1fd397b0c13f-ext_tk.tar.gz
|
|
||||||
/ruby-1.8.7-p334.tar.bz2
|
|
||||||
/ruby-1.8.7-p352.tar.bz2
|
|
||||||
/ruby-revc2dfaa7d40531aef3706bcc16f38178b0c6633ee-ext_tk.tar.gz
|
|
||||||
/ruby-1.8.7-p357.tar.bz2
|
|
||||||
/ruby-1.9.3-p0.tar.gz
|
|
||||||
/ruby-1.9.3-p125.tar.gz
|
|
||||||
/ruby-1.9.3-p194.tar.gz
|
|
||||||
/ruby-1.9.3-p286.tar.gz
|
|
||||||
/ruby-1.9.3-p327.tar.gz
|
|
||||||
/ruby-1.9.3-p362.tar.gz
|
|
||||||
/ruby-1.9.3-p374.tar.gz
|
|
||||||
/ruby-1.9.3-p385.tar.gz
|
|
||||||
/ruby-2.0.0-r39387.tar.gz
|
|
||||||
/ruby-2.0.0-p0.tar.gz
|
|
||||||
/ruby-2.0.0-p195.tar.bz2
|
|
||||||
/ruby-2.0.0-p247.tar.bz2
|
|
||||||
/ruby-2.0.0-p353.tar.bz2
|
|
||||||
/ruby-2.1.1.tar.bz2
|
|
||||||
/ruby-2.1.2.tar.bz2
|
|
||||||
|
14
ruby-r46485-libffi31.patch
Normal file
14
ruby-r46485-libffi31.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Index: ext/fiddle/extconf.rb
|
||||||
|
===================================================================
|
||||||
|
--- ext/fiddle/extconf.rb (revision 46484)
|
||||||
|
+++ ext/fiddle/extconf.rb (revision 46485)
|
||||||
|
@@ -7,7 +7,8 @@
|
||||||
|
pkg_config("libffi")
|
||||||
|
if ver = pkg_config("libffi", "modversion")
|
||||||
|
ver = ver.gsub(/-rc\d+/, '') # If ver contains rc version, just ignored.
|
||||||
|
- $defs.push(%{-DRUBY_LIBFFI_MODVERSION=#{ '%d%03d%03d' % ver.split('.') }})
|
||||||
|
+ ver = (ver.split('.') + [0,0])[0,3]
|
||||||
|
+ $defs.push(%{-DRUBY_LIBFFI_MODVERSION=#{ '%d%03d%03d' % ver }})
|
||||||
|
end
|
||||||
|
|
||||||
|
unless have_header('ffi.h')
|
30
ruby.spec
30
ruby.spec
@ -27,7 +27,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global release 22
|
%global release 23
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||||
|
|
||||||
%global rubygems_version 2.2.2
|
%global rubygems_version 2.2.2
|
||||||
@ -63,7 +63,7 @@
|
|||||||
Summary: An interpreter of object-oriented scripting language
|
Summary: An interpreter of object-oriented scripting language
|
||||||
Name: ruby
|
Name: ruby
|
||||||
Version: %{ruby_version}
|
Version: %{ruby_version}
|
||||||
Release: %{release_string}.2
|
Release: %{release_string}
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
|
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
|
||||||
License: (Ruby or BSD) and Public Domain
|
License: (Ruby or BSD) and Public Domain
|
||||||
@ -102,19 +102,22 @@ Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
|
|||||||
Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
|
Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
|
||||||
# Force multiarch directories for i.86 to be always named i386. This solves
|
# Force multiarch directories for i.86 to be always named i386. This solves
|
||||||
# some differencies in build between Fedora and RHEL.
|
# some differencies in build between Fedora and RHEL.
|
||||||
Patch3: ruby-2.1.0-always-use-i386.patch
|
Patch2: ruby-2.1.0-always-use-i386.patch
|
||||||
# Fixes random WEBRick test failures.
|
# Fixes random WEBRick test failures.
|
||||||
# https://bugs.ruby-lang.org/issues/6573.
|
# https://bugs.ruby-lang.org/issues/6573.
|
||||||
Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
|
Patch3: ruby-1.9.3.p195-fix-webrick-tests.patch
|
||||||
# Allows to install RubyGems into custom directory, outside of Ruby's tree.
|
# Allows to install RubyGems into custom directory, outside of Ruby's tree.
|
||||||
# http://redmine.ruby-lang.org/issues/5617
|
# http://redmine.ruby-lang.org/issues/5617
|
||||||
Patch8: ruby-2.1.0-custom-rubygems-location.patch
|
Patch4: ruby-2.1.0-custom-rubygems-location.patch
|
||||||
# Make mkmf verbose by default
|
# Make mkmf verbose by default
|
||||||
Patch12: ruby-1.9.3-mkmf-verbose.patch
|
Patch5: ruby-1.9.3-mkmf-verbose.patch
|
||||||
# Adds support for '--with-prelude' configuration option. This allows to built
|
# Adds support for '--with-prelude' configuration option. This allows to built
|
||||||
# in support for ABRT.
|
# in support for ABRT.
|
||||||
# http://bugs.ruby-lang.org/issues/8566
|
# http://bugs.ruby-lang.org/issues/8566
|
||||||
Patch17: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||||
|
# Fix build with libffi 3.1
|
||||||
|
# https://bugs.ruby-lang.org/issues/9897
|
||||||
|
Patch7: ruby-r46485-libffi31.patch
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -370,11 +373,12 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
|||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch8 -p1
|
%patch6 -p1
|
||||||
%patch12 -p1
|
%patch7 -p0
|
||||||
%patch17 -p1
|
|
||||||
|
|
||||||
# Provide an example of usage of the tapset:
|
# Provide an example of usage of the tapset:
|
||||||
cp -a %{SOURCE3} .
|
cp -a %{SOURCE3} .
|
||||||
@ -401,6 +405,7 @@ autoconf
|
|||||||
--with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
|
--with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
|
||||||
--with-rubygemsdir='%{rubygems_dir}' \
|
--with-rubygemsdir='%{rubygems_dir}' \
|
||||||
--with-ruby-pc='%{name}.pc' \
|
--with-ruby-pc='%{name}.pc' \
|
||||||
|
--with-tcltkversion=8.6 \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
--enable-shared \
|
--enable-shared \
|
||||||
--with-ruby-version='' \
|
--with-ruby-version='' \
|
||||||
@ -866,6 +871,11 @@ OPENSSL_ENABLE_MD5_VERIFY=1 make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{ruby_libdir}/tkextlib
|
%{ruby_libdir}/tkextlib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 24 2014 Peter Robinson <pbrobinson@fedoraproject.org> 2.1.2-23
|
||||||
|
- Fix FTBFS
|
||||||
|
- Specify tcl/tk 8.6
|
||||||
|
- Add upstream patch to build with libffi 3.1
|
||||||
|
|
||||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user