1.8.6.368-1
This commit is contained in:
parent
168ffcfeea
commit
c11147cfd2
@ -1,5 +1,4 @@
|
|||||||
ruby-1.8.6-p287.tar.bz2
|
ruby-refm-rdp-1.8.2-ja-html.tar.gz
|
||||||
ruby-refm-rdp-1.8.1-ja-html.tar.gz
|
|
||||||
rubyfaq-990927.tar.gz
|
rubyfaq-990927.tar.gz
|
||||||
rubyfaq-jp-990927.tar.gz
|
rubyfaq-jp-990927.tar.gz
|
||||||
ruby-refm-rdp-1.8.2-ja-html.tar.gz
|
ruby-1.8.6-p368.tar.bz2
|
||||||
|
@ -1,3 +1,4 @@
|
|||||||
ruby-1_8_6_287-4_fc10:HEAD:ruby-1.8.6.287-4.fc10.src.rpm:1237096558
|
ruby-1_8_6_287-4_fc10:HEAD:ruby-1.8.6.287-4.fc10.src.rpm:1237096558
|
||||||
ruby-1_8_6_287-5_fc10:HEAD:ruby-1.8.6.287-5.fc10.src.rpm:1237096677
|
ruby-1_8_6_287-5_fc10:HEAD:ruby-1.8.6.287-5.fc10.src.rpm:1237096677
|
||||||
ruby-1_8_6_287-7_fc11:HEAD:ruby-1.8.6.287-7.fc11.src.rpm:1237351812
|
ruby-1_8_6_287-7_fc11:HEAD:ruby-1.8.6.287-7.fc11.src.rpm:1237351812
|
||||||
|
ruby-1_8_6_368-1_fc11:HEAD:ruby-1.8.6.368-1.fc11.src.rpm:1243759307
|
||||||
|
@ -98,16 +98,3 @@ diff -ur ruby-1.8.6-p287.orig/ext/openssl/openssl_missing.c ruby-1.8.6-p287/ext/
|
|||||||
if (key) {
|
if (key) {
|
||||||
i = strlen(key);
|
i = strlen(key);
|
||||||
i = (i > num) ? num : i;
|
i = (i > num) ? num : i;
|
||||||
diff -ur ruby-1.8.6-p287.orig/ext/openssl/openssl_missing.h ruby-1.8.6-p287/ext/openssl/openssl_missing.h
|
|
||||||
--- ruby-1.8.6-p287.orig/ext/openssl/openssl_missing.h 2008-08-04 06:43:34.000000000 +0200
|
|
||||||
+++ ruby-1.8.6-p287/ext/openssl/openssl_missing.h 2009-03-15 05:33:56.000000000 +0100
|
|
||||||
@@ -120,8 +120,6 @@
|
|
||||||
int BN_mod_sqr(BIGNUM *r, const BIGNUM *a, const BIGNUM *m, BN_CTX *ctx);
|
|
||||||
int BN_mod_add(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
|
|
||||||
int BN_mod_sub(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
|
|
||||||
-int BN_rand_range(BIGNUM *r, BIGNUM *range);
|
|
||||||
-int BN_pseudo_rand_range(BIGNUM *r, BIGNUM *range);
|
|
||||||
char *CONF_get1_default_config_file(void);
|
|
||||||
int PEM_def_callback(char *buf, int num, int w, void *key);
|
|
||||||
|
|
||||||
Only in ruby-1.8.6-p287/ext/openssl: .openssl_missing.h.swp
|
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
diff -pruN ruby-1.8.6-p111.orig/ext/socket/socket.c ruby-1.8.6-p111/ext/socket/socket.c
|
|
||||||
--- ruby-1.8.6-p111.orig/ext/socket/socket.c 2007-05-23 00:08:43.000000000 +0900
|
|
||||||
+++ ruby-1.8.6-p111/ext/socket/socket.c 2008-02-19 11:24:22.000000000 +0900
|
|
||||||
@@ -893,10 +893,10 @@ port_str(port, pbuf, len)
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifndef NI_MAXHOST
|
|
||||||
-# define 1025
|
|
||||||
+# define NI_MAXHOST 1025
|
|
||||||
#endif
|
|
||||||
#ifndef NI_MAXSERV
|
|
||||||
-# define 32
|
|
||||||
+# define NI_MAXSERV 32
|
|
||||||
#endif
|
|
||||||
|
|
||||||
static struct addrinfo*
|
|
14
ruby.spec
14
ruby.spec
@ -1,6 +1,6 @@
|
|||||||
%define rubyxver 1.8
|
%define rubyxver 1.8
|
||||||
%define rubyver 1.8.6
|
%define rubyver 1.8.6
|
||||||
%define _patchlevel 287
|
%define _patchlevel 368
|
||||||
%define dotpatchlevel %{?_patchlevel:.%{_patchlevel}}
|
%define dotpatchlevel %{?_patchlevel:.%{_patchlevel}}
|
||||||
%define patchlevel %{?_patchlevel:-p%{_patchlevel}}
|
%define patchlevel %{?_patchlevel:-p%{_patchlevel}}
|
||||||
%define arcver %{rubyver}%{?patchlevel}
|
%define arcver %{rubyver}%{?patchlevel}
|
||||||
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: ruby
|
Name: ruby
|
||||||
Version: %{rubyver}%{?dotpatchlevel}
|
Version: %{rubyver}%{?dotpatchlevel}
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Ruby or GPLv2
|
License: Ruby or GPLv2
|
||||||
URL: http://www.ruby-lang.org/
|
URL: http://www.ruby-lang.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -38,7 +38,8 @@ Patch20: ruby-rubyprefix.patch
|
|||||||
Patch21: ruby-deprecated-sitelib-search-path.patch
|
Patch21: ruby-deprecated-sitelib-search-path.patch
|
||||||
Patch22: ruby-deprecated-search-path.patch
|
Patch22: ruby-deprecated-search-path.patch
|
||||||
Patch23: ruby-multilib.patch
|
Patch23: ruby-multilib.patch
|
||||||
Patch25: ruby-1.8.6.111-gcc43.patch
|
# Needed in 1.8.6-p287, no longer needed in 1.8.6-p368?
|
||||||
|
#Patch25: ruby-1.8.6.111-gcc43.patch
|
||||||
Patch26: ruby-1.8.6-rexml-CVE-2008-3790.patch
|
Patch26: ruby-1.8.6-rexml-CVE-2008-3790.patch
|
||||||
Patch27: ruby-1.8.6-p287-CVE-2008-5189.patch
|
Patch27: ruby-1.8.6-p287-CVE-2008-5189.patch
|
||||||
Patch28: ruby-1.8.6-p287-remove-ssl-rand-range.patch
|
Patch28: ruby-1.8.6-p287-remove-ssl-rand-range.patch
|
||||||
@ -167,8 +168,8 @@ pushd %{name}-%{arcver}
|
|||||||
%patch22 -p1
|
%patch22 -p1
|
||||||
%patch23 -p1
|
%patch23 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch25 -p1
|
#%patch25 -p1
|
||||||
%patch26 -p1
|
#%patch26 -p1
|
||||||
%patch27 -p0
|
%patch27 -p0
|
||||||
%patch28 -p1
|
%patch28 -p1
|
||||||
%patch29 -p1
|
%patch29 -p1
|
||||||
@ -530,6 +531,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_emacs_sitestartdir}/ruby-mode-init.el
|
%{_emacs_sitestartdir}/ruby-mode-init.el
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun May 31 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 1.8.6.368-1
|
||||||
|
- New upstream release (p368)
|
||||||
|
|
||||||
* Sat Apr 11 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.287-8
|
* Sat Apr 11 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.287-8
|
||||||
- Merge Review fix (#226381)
|
- Merge Review fix (#226381)
|
||||||
|
|
||||||
|
5
sources
5
sources
@ -1,5 +1,4 @@
|
|||||||
80b5f3db12531d36e6c81fac6d05dda9 ruby-1.8.6-p287.tar.bz2
|
b6dd396f513efeb7864685c840f9643a ruby-refm-rdp-1.8.2-ja-html.tar.gz
|
||||||
d65e3a216d6d345a2a6f1aa8758c2f75 ruby-refm-rdp-1.8.1-ja-html.tar.gz
|
|
||||||
634c25b14e19925d10af3720d72e8741 rubyfaq-990927.tar.gz
|
634c25b14e19925d10af3720d72e8741 rubyfaq-990927.tar.gz
|
||||||
4fcec898f51d8371cc42d0a013940469 rubyfaq-jp-990927.tar.gz
|
4fcec898f51d8371cc42d0a013940469 rubyfaq-jp-990927.tar.gz
|
||||||
b6dd396f513efeb7864685c840f9643a ruby-refm-rdp-1.8.2-ja-html.tar.gz
|
623447c6d8c973193aae565a5538ccfc ruby-1.8.6-p368.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user