- Change mkmf.rb to use LIBRUBYARG_SHARED so that have_library() works
without libruby-static.a (bug 428384) - And move libruby-static.a to -static subpackage
This commit is contained in:
parent
fd1c994027
commit
bab6007ffb
11
ruby-1.8.6-p383-mkmf-use-shared.patch
Normal file
11
ruby-1.8.6-p383-mkmf-use-shared.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ruby-1.8.6-p383/lib/mkmf.rb.static 2009-03-31 18:19:39.000000000 +0900
|
||||||
|
+++ ruby-1.8.6-p383/lib/mkmf.rb 2009-12-09 15:03:19.000000000 +0900
|
||||||
|
@@ -275,7 +275,7 @@
|
||||||
|
'LDFLAGS' => "#$LDFLAGS #{ldflags}",
|
||||||
|
'LIBPATH' => libpathflag(libpath),
|
||||||
|
'LOCAL_LIBS' => "#$LOCAL_LIBS #$libs",
|
||||||
|
- 'LIBS' => "#$LIBRUBYARG_STATIC #{opt} #$LIBS")
|
||||||
|
+ 'LIBS' => "#$LIBRUBYARG_SHARED #{opt} #$LIBS")
|
||||||
|
Config::expand(TRY_LINK.dup, conf)
|
||||||
|
end
|
||||||
|
|
32
ruby.spec
32
ruby.spec
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: ruby
|
Name: ruby
|
||||||
Version: %{rubyver}%{?dotpatchlevel}
|
Version: %{rubyver}%{?dotpatchlevel}
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: Ruby or GPLv2
|
License: Ruby or GPLv2
|
||||||
URL: http://www.ruby-lang.org/
|
URL: http://www.ruby-lang.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -53,8 +53,9 @@ Patch28: ruby-1.8.6-p287-remove-ssl-rand-range.patch
|
|||||||
Patch29: ruby-always-use-i386.patch
|
Patch29: ruby-always-use-i386.patch
|
||||||
Patch30: ruby-openssl-1.0.patch
|
Patch30: ruby-openssl-1.0.patch
|
||||||
Patch31: ruby-1.8.6-p369-ri-gem_multipath.patch
|
Patch31: ruby-1.8.6-p369-ri-gem_multipath.patch
|
||||||
# Patch from ruby_1_8 branch
|
# Patch32 from ruby_1_8 branch
|
||||||
Patch32: ruby-1.8head-irb-save-history.patch
|
Patch32: ruby-1.8head-irb-save-history.patch
|
||||||
|
Patch33: ruby-1.8.6-p383-mkmf-use-shared.patch
|
||||||
|
|
||||||
Summary: An interpreter of object-oriented scripting language
|
Summary: An interpreter of object-oriented scripting language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -85,12 +86,20 @@ This package includes the libruby, necessary to run Ruby.
|
|||||||
Summary: A Ruby development environment
|
Summary: A Ruby development environment
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
Provides: %{name}-libs-static = %{version}-%{release}
|
#Provides: %{name}-libs-static = %{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Header files and libraries for building a extension library for the
|
Header files and libraries for building a extension library for the
|
||||||
Ruby or an application embedded Ruby.
|
Ruby or an application embedded Ruby.
|
||||||
|
|
||||||
|
%package static
|
||||||
|
Summary: Static libraries for Ruby development environment
|
||||||
|
Group: Development/Languages
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
|
%description static
|
||||||
|
Static libraries for for building a extension library for the
|
||||||
|
Ruby or an application embedded Ruby.
|
||||||
|
|
||||||
%package tcltk
|
%package tcltk
|
||||||
Summary: Tcl/Tk interface for scripting language Ruby
|
Summary: Tcl/Tk interface for scripting language Ruby
|
||||||
@ -187,6 +196,7 @@ pushd %{name}-%{arcver}
|
|||||||
%patch30 -p2
|
%patch30 -p2
|
||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
%patch32 -p0
|
%patch32 -p0
|
||||||
|
%patch33 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -217,6 +227,11 @@ export CFLAGS
|
|||||||
%endif
|
%endif
|
||||||
--with-ruby-prefix=%{_prefix}/lib
|
--with-ruby-prefix=%{_prefix}/lib
|
||||||
|
|
||||||
|
# For example ext/socket/extconf.rb uses try_run (for getaddrinfo test),
|
||||||
|
# which executes conftest and setting LD_LIBRARY_PATH for libruby.so is
|
||||||
|
# needed.
|
||||||
|
export LD_LIBRARY_PATH=$(pwd)
|
||||||
|
|
||||||
make RUBY_INSTALL_NAME=ruby %{?_smp_mflags} COPY="cp -p" %{?_smp_mflags}
|
make RUBY_INSTALL_NAME=ruby %{?_smp_mflags} COPY="cp -p" %{?_smp_mflags}
|
||||||
%ifarch ia64
|
%ifarch ia64
|
||||||
# Miscompilation? Buggy code?
|
# Miscompilation? Buggy code?
|
||||||
@ -408,9 +423,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{name}-%{arcver}/README.EXT
|
%doc %{name}-%{arcver}/README.EXT
|
||||||
%lang(ja) %doc %{name}-%{arcver}/README.EXT.ja
|
%lang(ja) %doc %{name}-%{arcver}/README.EXT.ja
|
||||||
%{_libdir}/libruby.so
|
%{_libdir}/libruby.so
|
||||||
%{_libdir}/libruby-static.a
|
#%%{_libdir}/libruby-static.a
|
||||||
%{_libdir}/ruby/%{rubyxver}/*/*.h
|
%{_libdir}/ruby/%{rubyxver}/*/*.h
|
||||||
|
|
||||||
|
%files static
|
||||||
|
%defattr(-, root, root, -)
|
||||||
|
%{_libdir}/libruby-static.a
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%doc %{name}-%{arcver}/README
|
%doc %{name}-%{arcver}/README
|
||||||
@ -553,6 +572,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_emacs_sitestartdir}/ruby-mode-init.el
|
%{_emacs_sitestartdir}/ruby-mode-init.el
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 9 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.383-5
|
||||||
|
- Change mkmf.rb to use LIBRUBYARG_SHARED so that have_library() works
|
||||||
|
without libruby-static.a (bug 428384)
|
||||||
|
- And move libruby-static.a to -static subpackage
|
||||||
|
|
||||||
* Thu Oct 29 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.383-4
|
* Thu Oct 29 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.383-4
|
||||||
- Use bison to regenerate parse.c to keep the original format of error
|
- Use bison to regenerate parse.c to keep the original format of error
|
||||||
messages (bug 530275 comment 4)
|
messages (bug 530275 comment 4)
|
||||||
|
Loading…
Reference in New Issue
Block a user