Upgrade to Ruby 2.0.0 (r38732).

This commit is contained in:
Vít Ondruch 2012-12-20 16:46:57 +01:00
parent 4574488d84
commit a91606d4ba
7 changed files with 23 additions and 24 deletions

View File

@ -15,7 +15,7 @@ diff --git a/Makefile.in b/Makefile.in
index 690ff8e..8c7dd98 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -39,6 +39,9 @@ arch = @arch@
@@ -41,6 +41,9 @@ arch = @arch@
archdir = @archdir@
sitearch = @sitearch@
sitedir = @sitedir@
@ -29,7 +29,7 @@ diff --git a/configure.in b/configure.in
index 8e4aaec..c65e0c7 100644
--- a/configure.in
+++ b/configure.in
@@ -3178,6 +3178,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
@@ -3197,6 +3197,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
dir="${SITE_DIR}"
done
@ -45,7 +45,7 @@ index 8e4aaec..c65e0c7 100644
AC_ARG_WITH(vendordir,
AS_HELP_STRING([--with-vendordir=DIR], [vendor libraries in DIR [[RUBY_LIB_PREFIX/vendor_ruby]], "no" to disable vendor directory]),
[vendordir=$withval],
@@ -3187,19 +3196,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -3206,19 +3215,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDOR_DIR}"
done
@ -78,7 +78,7 @@ index 8e4aaec..c65e0c7 100644
fi
pat=`echo "$RUBY_LIB_PREFIX/" | tr -c '\012' .`'\(.*\)'
@@ -3217,6 +3239,13 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
@@ -3236,6 +3258,13 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
[
RUBY_SITE_LIB_PATH="\"${RUBY_SITE_LIB_PATH}\""
])
@ -92,7 +92,7 @@ index 8e4aaec..c65e0c7 100644
AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_VENDOR_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_VENDOR_LIB_PATH\" : \"$pat\"`"'"'
@@ -3224,6 +3253,13 @@ AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
@@ -3243,6 +3272,13 @@ AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
[
RUBY_VENDOR_LIB_PATH="\"${RUBY_VENDOR_LIB_PATH}\""
])
@ -106,7 +106,7 @@ index 8e4aaec..c65e0c7 100644
pat=`echo "$RUBY_EXEC_PREFIX/" | tr -c '\012' .`'\(.*\)'
AS_CASE(["$RUBY_LIB_PREFIX"],
["$RUBY_EXEC_PREFIX/"*], [
@@ -3245,11 +3281,13 @@ if test "x$SITE_DIR" = xno; then
@@ -3264,11 +3300,13 @@ if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, ${RUBY_SITE_LIB_PATH} !<verconf>!)
@ -120,7 +120,7 @@ index 8e4aaec..c65e0c7 100644
fi
AC_SUBST(arch)dnl
@@ -3257,7 +3295,9 @@ AC_SUBST(sitearch)dnl
@@ -3276,7 +3314,9 @@ AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl
AC_SUBST(archdir)dnl
AC_SUBST(sitedir)dnl

View File

@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
index c65e0c7..748edc9 100644
--- a/configure.in
+++ b/configure.in
@@ -3302,6 +3302,8 @@ AC_SUBST(vendorarchdir)dnl
@@ -3321,6 +3321,8 @@ AC_SUBST(vendorarchdir)dnl
configure_args=$ac_configure_args
AC_SUBST(configure_args)dnl

View File

@ -14,7 +14,7 @@ diff --git a/Makefile.in b/Makefile.in
index 78d7139..690ff8e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -36,6 +36,7 @@ libexecdir = @libexecdir@
@@ -38,6 +38,7 @@ libexecdir = @libexecdir@
datarootdir = @datarootdir@
datadir = @datadir@
arch = @arch@
@ -26,7 +26,7 @@ diff --git a/configure.in b/configure.in
index db3641b..8e4aaec 100644
--- a/configure.in
+++ b/configure.in
@@ -3160,6 +3160,15 @@ else
@@ -3179,6 +3179,15 @@ else
RUBY_LIB_VERSION="\"${ruby_version}\""
fi
@ -42,7 +42,7 @@ index db3641b..8e4aaec 100644
AC_ARG_WITH(sitedir,
AS_HELP_STRING([--with-sitedir=DIR], [site libraries in DIR [[RUBY_LIB_PREFIX/site_ruby]], "no" to disable site directory]),
[sitedir=$withval],
@@ -3182,16 +3191,25 @@ if test "${LOAD_RELATIVE+set}"; then
@@ -3201,16 +3210,25 @@ if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
RUBY_LIB_PREFIX="`eval echo "$RUBY_LIB_PREFIX" | sed 's|^NONE/|/|;s|^'"$prefix"'/|/|'`"
@ -68,7 +68,7 @@ index db3641b..8e4aaec 100644
AS_CASE(["$RUBY_SITE_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_SITE_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_SITE_LIB_PATH\" : \"$pat\"`"'"'
@@ -3222,6 +3240,7 @@ else
@@ -3241,6 +3259,7 @@ else
fi
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, "${RUBY_EXEC_PREFIX}")
AC_DEFINE_UNQUOTED(RUBY_LIB_PREFIX, ${RUBY_LIB_PREFIX} !<verconf>!)
@ -76,7 +76,7 @@ index db3641b..8e4aaec 100644
if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
@@ -3236,6 +3255,7 @@ fi
@@ -3255,6 +3274,7 @@ fi
AC_SUBST(arch)dnl
AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl

View File

@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
index 748edc9..6a16745 100644
--- a/configure.in
+++ b/configure.in
@@ -3205,6 +3205,13 @@ until VENDORARCH_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDORARCH_D
@@ -3224,6 +3224,13 @@ until VENDORARCH_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDORARCH_D
dir="${VENDORARCH_DIR}"
done
@ -29,7 +29,7 @@ index 748edc9..6a16745 100644
if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
@@ -3298,6 +3305,7 @@ AC_SUBST(sitedir)dnl
@@ -3317,6 +3324,7 @@ AC_SUBST(sitedir)dnl
AC_SUBST(sitearchdir)dnl
AC_SUBST(vendordir)dnl
AC_SUBST(vendorarchdir)dnl

View File

@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
index f2d22ef..db3641b 100644
--- a/configure.in
+++ b/configure.in
@@ -3327,6 +3327,17 @@ else
@@ -3346,6 +3346,17 @@ else
fi
AC_SUBST(USE_RUBYGEMS)

View File

@ -17,7 +17,7 @@
#%%global milestone preview2
# Keep the revision enabled for pre-releases from SVN.
%global revision 38422
%global revision 38732
%global ruby_archive %{name}-%{ruby_version}
@ -46,7 +46,7 @@
%global ruby_vendorlibdir %{_datadir}/ruby/%{ruby_vendordir}
%global ruby_vendorarchdir %{_libdir}/ruby/%{ruby_vendordir}
%global rubygems_version 2.0.0.preview2
%global rubygems_version 2.0.0.preview3.1
# The RubyGems library has to stay out of Ruby directory three, since the
# RubyGems should be share by all Ruby implementations.
@ -59,11 +59,11 @@
# http://rpm.org/ticket/78
%global gem_extdir %{_exec_prefix}/lib{,64}/gems
%global rake_version 0.9.5
%global rake_version 0.9.6
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
# http://redmine.ruby-lang.org/issues/5313
%global irb_version %{ruby_version_patch_level}
%global rdoc_version 4.0.0.preview2.1
%global rdoc_version 4.0.0.preview3.1
%global bigdecimal_version 1.1.0
%global io_console_version 0.3
%global json_version 1.7.5
@ -729,7 +729,6 @@ make check TESTS="-v $DISABLE_TESTS"
%{ruby_libarchdir}/racc/cparse.so
%{ruby_libarchdir}/rbconfig.rb
%{ruby_libarchdir}/readline.so
%{ruby_libarchdir}/refinement.so
%{ruby_libarchdir}/ripper.so
%{ruby_libarchdir}/sdbm.so
%{ruby_libarchdir}/socket.so

View File

@ -85,7 +85,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 74d803d..0063c7f 100644
--- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb
@@ -649,7 +649,7 @@ TEXT
@@ -641,7 +641,7 @@ TEXT
say "This could take a while..."
end
@ -178,7 +178,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 0063c7f..83b8fd5 100644
--- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb
@@ -649,7 +649,7 @@ TEXT
@@ -641,7 +641,7 @@ TEXT
say "This could take a while..."
end
@ -226,7 +226,7 @@ diff --git a/lib/rubygems/uninstaller.rb b/lib/rubygems/uninstaller.rb
index cc32ea4..94d78e0 100644
--- a/lib/rubygems/uninstaller.rb
+++ b/lib/rubygems/uninstaller.rb
@@ -234,6 +234,7 @@ class Gem::Uninstaller
@@ -246,6 +246,7 @@ class Gem::Uninstaller
File.writable?(spec.base_dir)
FileUtils.rm_rf spec.full_gem_path