Fix generated rdoc template issues.
Resolves: rhbz#1612026
This commit is contained in:
parent
2e08562f7c
commit
a56754b350
34
ruby-2.6.0-rdoc-6.0.1-fix-template-typo.patch
Normal file
34
ruby-2.6.0-rdoc-6.0.1-fix-template-typo.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From d05e6269d4a4dfd701f5ddb3ae34306cba891511 Mon Sep 17 00:00:00 2001
|
||||
From: Jun Aruga <jaruga@redhat.com>
|
||||
Date: Fri, 3 Aug 2018 11:35:55 +0200
|
||||
Subject: [PATCH] Fix indent and typo from moveTimout to moveTimeout.
|
||||
|
||||
---
|
||||
lib/rdoc/generator/template/json_index/js/navigation.js | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/lib/rdoc/generator/template/json_index/js/navigation.js b/lib/rdoc/generator/template/json_index/js/navigation.js
|
||||
index e4126812..43c5118a 100644
|
||||
--- a/lib/rdoc/generator/template/json_index/js/navigation.js
|
||||
+++ b/lib/rdoc/generator/template/json_index/js/navigation.js
|
||||
@@ -59,9 +59,8 @@ Navigation = new function() {
|
||||
}
|
||||
break;
|
||||
case 13: //Event.KEY_RETURN:
|
||||
- if (this.$current)
|
||||
- e.preventDefault();
|
||||
- this.select(this.$current);
|
||||
+ if (this.$current) e.preventDefault();
|
||||
+ this.select(this.$current);
|
||||
break;
|
||||
}
|
||||
if (e.ctrlKey && e.shiftKey) this.select(this.$current);
|
||||
@@ -80,7 +79,7 @@ Navigation = new function() {
|
||||
var go = function() {
|
||||
if (!_this.moveTimeout) return;
|
||||
_this[isDown ? 'moveDown' : 'moveUp']();
|
||||
- _this.moveTimout = setTimeout(go, 100);
|
||||
+ _this.moveTimeout = setTimeout(go, 100);
|
||||
}
|
||||
this.moveTimeout = setTimeout(go, 200);
|
||||
}
|
11
ruby.spec
11
ruby.spec
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 97
|
||||
%global release 99
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
# The RubyGems library has to stay out of Ruby directory three, since the
|
||||
@ -145,6 +145,9 @@ Patch15: ruby-2.6.0-library-options-to-MAINLIBS.patch
|
||||
# Do not require C++ compiler.
|
||||
# https://github.com/rubygems/rubygems/pull/2367
|
||||
Patch16: ruby-2.5.1-Avoid-need-of-C++-compiler-to-pass-the-test-suite.patch
|
||||
# https://github.com/ruby/rdoc/commit/d05e6269d4a4dfd701f5ddb3ae34306cba891511
|
||||
Patch20: ruby-2.6.0-rdoc-6.0.1-fix-template-typo.patch
|
||||
|
||||
# Fix some OpenSSL 1.1.1 test failures.
|
||||
# https://github.com/ruby/openssl/pull/202
|
||||
Patch17: ruby-2.5.1-Test-fixes-for-OpenSSL-1.1.1.patch
|
||||
@ -540,6 +543,7 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
%patch19 -p1
|
||||
%patch20 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -1093,6 +1097,11 @@ OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file OPENSSL_CONF='' \
|
||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||
|
||||
%changelog
|
||||
* Tue Aug 28 2018 Jun Aruga <jaruga@redhat.com> - 2.5.1-99
|
||||
- Fix generated rdoc template issues.
|
||||
* ruby-2.6.0-rdoc-6.0.1-fix-template-typo.patch
|
||||
Resolves: rhbz#1612026
|
||||
|
||||
* Mon Aug 13 2018 Vít Ondruch <vondruch@redhat.com> - 2.5.1-97
|
||||
- Fix TLS 1.3 issues.
|
||||
* ruby-2.6.0-fix-test-failure-with-TLS-1.3.patch
|
||||
|
Loading…
Reference in New Issue
Block a user