Update to 1.9.3 p374
- Fix provided variables in pkgconfig (bug 789532: Vít Ondruch <vondruch@redhat.com>)
This commit is contained in:
parent
8703f41ded
commit
957db76127
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
|||||||
/ruby-1.9.3-p286.tar.gz
|
/ruby-1.9.3-p286.tar.gz
|
||||||
/ruby-1.9.3-p327.tar.gz
|
/ruby-1.9.3-p327.tar.gz
|
||||||
/ruby-1.9.3-p362.tar.gz
|
/ruby-1.9.3-p362.tar.gz
|
||||||
|
/ruby-1.9.3-p374.tar.gz
|
||||||
|
@ -1,45 +0,0 @@
|
|||||||
Mon Jan 7 15:50:25 2013 Nobuyoshi Nakada <nobu@ruby-lang.org>
|
|
||||||
|
|
||||||
* vm.c (rb_vm_make_proc): save the proc made from the given block so
|
|
||||||
that it will not get collected. [ruby-core:50545] [Bug #7507]
|
|
||||||
|
|
||||||
diff --git a/vm.c b/vm.c
|
|
||||||
index 4dd242f..70e8d3b 100644
|
|
||||||
--- a/vm.c
|
|
||||||
+++ b/vm.c
|
|
||||||
@@ -468,10 +468,18 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
static VALUE vm_make_proc_from_block(rb_thread_t *th, rb_block_t *block);
|
|
||||||
+static VALUE vm_make_env_object(rb_thread_t * th, rb_control_frame_t *cfp, VALUE *blockprocptr);
|
|
||||||
|
|
||||||
VALUE
|
|
||||||
rb_vm_make_env_object(rb_thread_t * th, rb_control_frame_t *cfp)
|
|
||||||
{
|
|
||||||
+ VALUE blockprocval;
|
|
||||||
+ return vm_make_env_object(th, cfp, &blockprocval);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static VALUE
|
|
||||||
+vm_make_env_object(rb_thread_t *th, rb_control_frame_t *cfp, VALUE *blockprocptr)
|
|
||||||
+{
|
|
||||||
VALUE envval;
|
|
||||||
VALUE *lfp;
|
|
||||||
rb_block_t *blockptr;
|
|
||||||
@@ -489,6 +497,7 @@
|
|
||||||
rb_proc_t *p;
|
|
||||||
GetProcPtr(blockprocval, p);
|
|
||||||
lfp[0] = GC_GUARDED_PTR(&p->block);
|
|
||||||
+ *blockprocptr = blockprocval;
|
|
||||||
}
|
|
||||||
|
|
||||||
envval = vm_make_env_each(th, cfp, cfp->dfp, cfp->lfp);
|
|
||||||
@@ -559,7 +568,7 @@
|
|
||||||
rb_bug("rb_vm_make_proc: Proc value is already created.");
|
|
||||||
}
|
|
||||||
|
|
||||||
- envval = rb_vm_make_env_object(th, cfp);
|
|
||||||
+ envval = vm_make_env_object(th, cfp, &blockprocval);
|
|
||||||
|
|
||||||
if (PROCDEBUG) {
|
|
||||||
check_env_value(envval);
|
|
@ -0,0 +1,35 @@
|
|||||||
|
From bf4959bc763167b2245a5f4c699fcb72afead5a5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||||
|
Date: Fri, 18 Jan 2013 15:51:49 +0100
|
||||||
|
Subject: [PATCH] Expand ruby.pc variable by configuration process.
|
||||||
|
|
||||||
|
---
|
||||||
|
template/ruby.pc.in | 12 ++++++------
|
||||||
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/template/ruby.pc.in b/template/ruby.pc.in
|
||||||
|
index 2d6716c..25e42f3 100644
|
||||||
|
--- a/template/ruby.pc.in
|
||||||
|
+++ b/template/ruby.pc.in
|
||||||
|
@@ -25,12 +25,12 @@ LIBS=@LIBS@
|
||||||
|
DLDFLAGS=@DLDFLAGS@
|
||||||
|
ruby=${bindir}/${RUBY_INSTALL_NAME}@EXEEXT@
|
||||||
|
rubylibprefix=@rubylibprefix@
|
||||||
|
-rubylibdir=${rubylibprefix}/${ruby_version}
|
||||||
|
-vendordir=${rubylibprefix}/vendor_ruby
|
||||||
|
-sitedir=${rubylibprefix}/site_ruby
|
||||||
|
-rubyarchdir=${rubylibdir}/${arch}
|
||||||
|
-vendorarchdir=${vendordir}/${sitearch}
|
||||||
|
-sitearchdir=${sitedir}/${sitearch}
|
||||||
|
+rubylibdir=@rubylibprefix@
|
||||||
|
+vendordir=@vendordir@
|
||||||
|
+sitedir=@sitedir@
|
||||||
|
+rubyarchdir=@archdir@
|
||||||
|
+vendorarchdir=@vendorarchdir@
|
||||||
|
+sitearchdir=@sitearchdir@
|
||||||
|
rubyhdrdir=@rubyhdrdir@
|
||||||
|
vendorhdrdir=@vendorhdrdir@
|
||||||
|
sitehdrdir=@sitehdrdir@
|
||||||
|
--
|
||||||
|
1.8.0.2
|
||||||
|
|
18
ruby.spec
18
ruby.spec
@ -1,7 +1,7 @@
|
|||||||
%global major_version 1
|
%global major_version 1
|
||||||
%global minor_version 9
|
%global minor_version 9
|
||||||
%global teeny_version 3
|
%global teeny_version 3
|
||||||
%global patch_level 362
|
%global patch_level 374
|
||||||
|
|
||||||
%global major_minor_version %{major_version}.%{minor_version}
|
%global major_minor_version %{major_version}.%{minor_version}
|
||||||
|
|
||||||
@ -56,7 +56,7 @@ Version: %{ruby_version_patch_level}
|
|||||||
# we cannot reset the release number to 1 even when the main (ruby) version
|
# we cannot reset the release number to 1 even when the main (ruby) version
|
||||||
# is updated - because it may be that the versions of sub-components don't
|
# is updated - because it may be that the versions of sub-components don't
|
||||||
# change.
|
# change.
|
||||||
Release: 26%{?dist}
|
Release: 27%{?dist}
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
|
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
|
||||||
License: (Ruby or BSD) and Public Domain
|
License: (Ruby or BSD) and Public Domain
|
||||||
@ -103,7 +103,11 @@ Patch12: ruby-1.9.3-mkmf-verbose.patch
|
|||||||
# http://bugs.ruby-lang.org/issues/7629
|
# http://bugs.ruby-lang.org/issues/7629
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=895173
|
# https://bugzilla.redhat.com/show_bug.cgi?id=895173
|
||||||
# save the proc made from the given block
|
# save the proc made from the given block
|
||||||
Patch13: ruby-1.9.3-p327-PR7629-save-proc.patch
|
# Fixed in p374
|
||||||
|
#Patch13: ruby-1.9.3-p327-PR7629-save-proc.patch
|
||||||
|
# Fixes issues mentioned in rhbz#789532, comment 8.
|
||||||
|
# TODO: Should be probably upstreamed with #5281.
|
||||||
|
Patch14: ruby-2.0.0-Expand-ruby.pc-variable-by-configuration-process.patch
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -350,7 +354,8 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
|||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
#%%patch11 -p1
|
#%%patch11 -p1
|
||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
%patch13 -p1
|
#%%patch13 -p1
|
||||||
|
%patch14 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -773,6 +778,11 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{ruby_libdir}/tkextlib
|
%{ruby_libdir}/tkextlib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 19 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.9.3.374-27
|
||||||
|
- Update to 1.9.3 p374
|
||||||
|
- Fix provided variables in pkgconfig (bug 789532:
|
||||||
|
Vít Ondruch <vondruch@redhat.com>)
|
||||||
|
|
||||||
* Fri Jan 18 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.9.3.362-26
|
* Fri Jan 18 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.9.3.362-26
|
||||||
- Provide non-versioned pkgconfig file (bug 789532)
|
- Provide non-versioned pkgconfig file (bug 789532)
|
||||||
- Use db5 on F-19 (bug 894022)
|
- Use db5 on F-19 (bug 894022)
|
||||||
|
Loading…
Reference in New Issue
Block a user