Fix RbConfig::CONFIG['exec_prefix'] returns empty string (rhbz#924851).
This commit is contained in:
parent
8f31ccc919
commit
61fb1adee2
@ -1,27 +0,0 @@
|
||||
From 2e15c6bdac1c145cce0c21677477ced8df26718b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 8 Feb 2013 18:20:50 +0100
|
||||
Subject: [PATCH] Add configuration arch specific dir flag.
|
||||
|
||||
---
|
||||
configure.in | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index d6af000..1c094a3 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3217,6 +3217,10 @@ AC_SUBST(rubylibprefix)
|
||||
rubylibdir='${rubylibprefix}/${ruby_version}'
|
||||
rubyarchdir=${multiarch+'${rubyarchprefix}/${ruby_version}'}${multiarch-'${rubylibdir}/${arch}'}
|
||||
|
||||
+AC_ARG_WITH(rubyarchdir,
|
||||
+ AS_HELP_STRING([--with-rubyarchdir=DIR], [architecture specific ruby libraries [[LIBDIR/RUBY_BASE_NAME/ARCH]]]),
|
||||
+ [rubyarchdir=$withval])
|
||||
+
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
--
|
||||
1.8.1.2
|
||||
|
15
ruby.spec
15
ruby.spec
@ -26,7 +26,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 5
|
||||
%global release 6
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
%global ruby_libdir %{_datadir}/%{name}
|
||||
@ -95,8 +95,6 @@ Source3: ruby-exercise.stp
|
||||
|
||||
# http://bugs.ruby-lang.org/issues/7807
|
||||
Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
|
||||
# http://bugs.ruby-lang.org/issues/7808
|
||||
Patch1: ruby-1.9.3-arch-specific-dir.patch
|
||||
# Force multiarch directories for i.86 to be always named i386. This solves
|
||||
# some differencies in build between Fedora and RHEL.
|
||||
Patch3: ruby-1.9.3-always-use-i386.patch
|
||||
@ -383,7 +381,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
||||
%setup -q -n %{ruby_archive}
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
@ -403,17 +400,21 @@ autoconf
|
||||
|
||||
%configure \
|
||||
--with-rubylibprefix='%{ruby_libdir}' \
|
||||
--with-rubyarchdir='%{ruby_libarchdir}' \
|
||||
--with-rubyarchprefix='%{ruby_libarchdir}' \
|
||||
--with-sitedir='%{ruby_sitelibdir}' \
|
||||
--with-sitearchdir='%{ruby_sitearchdir}' \
|
||||
--with-vendordir='%{ruby_vendorlibdir}' \
|
||||
--with-vendorarchdir='%{ruby_vendorarchdir}' \
|
||||
--with-rubyhdrdir='%{_includedir}' \
|
||||
--with-rubyarchhdrdir='$(archincludedir)' \
|
||||
--with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
|
||||
--with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
|
||||
--with-rubygemsdir='%{rubygems_dir}' \
|
||||
--with-ruby-pc='%{name}.pc' \
|
||||
--disable-rpath \
|
||||
--enable-shared \
|
||||
--with-ruby-version='' \
|
||||
--enable-multiarch \
|
||||
|
||||
|
||||
|
||||
@ -421,7 +422,6 @@ autoconf
|
||||
# compiler options.
|
||||
make %{?_smp_mflags} COPY="cp -p" Q=
|
||||
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make install DESTDIR=%{buildroot}
|
||||
@ -871,6 +871,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Fri Mar 22 2013 Vít Ondruch <vondruch@redhat.com> - 2.0.0.0-6
|
||||
- Fix RbConfig::CONFIG['exec_prefix'] returns empty string (rhbz#924851).
|
||||
|
||||
* Thu Mar 21 2013 Vít Ondruch <vondruch@redhat.com> - 2.0.0.0-5
|
||||
- Make Ruby buildable without rubypick.
|
||||
- Prevent random test failures.
|
||||
|
Loading…
Reference in New Issue
Block a user