Rebase patches.

This commit is contained in:
Vít Ondruch 2012-11-19 14:32:58 +01:00
parent 43f936f6e3
commit 6193662f24
3 changed files with 79 additions and 78 deletions

View File

@ -1,21 +1,21 @@
From b0a875862d14244ca41cd1e1e9090f87757aaeb9 Mon Sep 17 00:00:00 2001
From be687364922657501e861e9f53f8ec647a73fe00 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
Date: Mon, 5 Sep 2011 13:10:47 +0200
Subject: [PATCH] Added configuration flags for site and vendor architecture
specific directories.
---
Makefile.in | 3 +++
configure.in | 40 ++++++++++++++++++++++++++++++++++++++++
tool/mkconfig.rb | 8 ++++++--
version.c | 4 ++++
Makefile.in | 3 +++
configure.in | 40 ++++++++++++++++++++++++++++++++++++++++
tool/mkconfig.rb | 8 ++++++--
version.c | 4 ++++
4 files changed, 53 insertions(+), 2 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..f57e4c4 100644
index 690ff8e..8c7dd98 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -38,6 +38,9 @@ datadir = @datadir@
@@ -39,6 +39,9 @@ arch = @arch@
archdir = @archdir@
sitearch = @sitearch@
sitedir = @sitedir@
@ -26,10 +26,10 @@ index bcdaf5f..f57e4c4 100644
TESTUI = console
diff --git a/configure.in b/configure.in
index 83e5d76..31532bd 100644
index 8e4aaec..c65e0c7 100644
--- a/configure.in
+++ b/configure.in
@@ -3029,6 +3029,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
@@ -3169,6 +3169,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
dir="${SITE_DIR}"
done
@ -45,7 +45,7 @@ index 83e5d76..31532bd 100644
AC_ARG_WITH(vendordir,
AS_HELP_STRING([--with-vendordir=DIR], [vendor libraries in DIR [[RUBY_LIB_PREFIX/vendor_ruby]], "no" to disable vendor directory]),
[vendordir=$withval],
@@ -3038,19 +3047,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -3178,19 +3187,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDOR_DIR}"
done
@ -78,7 +78,7 @@ index 83e5d76..31532bd 100644
fi
pat=`echo "$RUBY_LIB_PREFIX/" | tr -c '\012' .`'\(.*\)'
@@ -3068,12 +3090,26 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
@@ -3208,6 +3230,13 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
[
RUBY_SITE_LIB_PATH="\"${RUBY_SITE_LIB_PATH}\""
])
@ -92,20 +92,21 @@ index 83e5d76..31532bd 100644
AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_VENDOR_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_VENDOR_LIB_PATH\" : \"$pat\"`"'"'
],
@@ -3215,6 +3244,13 @@ AS_CASE(["$RUBY_VENDOR_LIB_PATH"],
[
RUBY_VENDOR_LIB_PATH="\"${RUBY_VENDOR_LIB_PATH}\""
+ ])
])
+AS_CASE(["$RUBY_VENDOR_ARCHLIB_PATH"],
+ ["$RUBY_LIB_PREFIX/"*], [
+ RUBY_VENDOR_ARCHLIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_VENDOR_ARCHLIB_PATH\" : \"$pat\"`"'"'
+ ],
+ [
+ RUBY_VENDOR_ARCHLIB_PATH="\"${RUBY_VENDOR_ARCHLIB_PATH}\""
])
+ ])
pat=`echo "$RUBY_EXEC_PREFIX/" | tr -c '\012' .`'\(.*\)'
AS_CASE(["$RUBY_LIB_PREFIX"],
@@ -3096,19 +3132,23 @@ if test "x$SITE_DIR" = xno; then
["$RUBY_EXEC_PREFIX/"*], [
@@ -3236,11 +3272,13 @@ if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, ${RUBY_SITE_LIB_PATH} !<verconf>!)
@ -119,7 +120,7 @@ index 83e5d76..31532bd 100644
fi
AC_SUBST(arch)dnl
AC_SUBST(sitearch)dnl
@@ -3248,7 +3286,9 @@ AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl
AC_SUBST(archdir)dnl
AC_SUBST(sitedir)dnl
@ -130,10 +131,10 @@ index 83e5d76..31532bd 100644
configure_args=$ac_configure_args
AC_SUBST(configure_args)dnl
diff --git a/tool/mkconfig.rb b/tool/mkconfig.rb
index b707c4b..6230720 100755
index 03c3332..79b8e44 100755
--- a/tool/mkconfig.rb
+++ b/tool/mkconfig.rb
@@ -44,6 +44,8 @@ v_others = []
@@ -44,6 +44,8 @@ continued_name = nil
continued_line = nil
path_version = "/$(ruby_version)"
archdir_override = "$(vendorlibdir)/$(sitearch)"
@ -166,7 +167,7 @@ index b707c4b..6230720 100755
print <<EOS
CONFIG["topdir"] = File.dirname(__FILE__)
diff --git a/version.c b/version.c
index 59d4e5e..2558aa0 100644
index a117059..962f39f 100644
--- a/version.c
+++ b/version.c
@@ -51,8 +51,12 @@
@ -183,5 +184,5 @@ index 59d4e5e..2558aa0 100644
#define RUBY_THIN_ARCHLIB RUBY_LIB "/"RUBY_THINARCH
#define RUBY_SITE_THIN_ARCHLIB RUBY_SITE_LIB2 "/"RUBY_THINARCH
--
1.7.6.1
1.8.0

View File

@ -1,20 +1,20 @@
From df4253a5b79b63f16f215f2c19f1b9666c4ca01e Mon Sep 17 00:00:00 2001
From 50d6113cc3752d1810d58b78d9d009662e143041 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
Date: Thu, 8 Sep 2011 15:30:05 +0200
Subject: [PATCH] Add configuration arch specific dir flag.
---
Makefile.in | 1 +
configure.in | 20 ++++++++++++++++++++
tool/mkconfig.rb | 4 +++-
version.c | 2 ++
4 files changed, 26 insertions(+), 1 deletions(-)
Makefile.in | 1 +
configure.in | 20 ++++++++++++++++++++
tool/mkconfig.rb | 4 +++-
version.c | 2 ++
4 files changed, 26 insertions(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..d61b2ee 100644
index 78d7139..690ff8e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -35,6 +35,7 @@ libexecdir = @libexecdir@
@@ -36,6 +36,7 @@ libexecdir = @libexecdir@
datarootdir = @datarootdir@
datadir = @datadir@
arch = @arch@
@ -23,10 +23,10 @@ index bcdaf5f..d61b2ee 100644
sitedir = @sitedir@
ruby_version = @ruby_version@
diff --git a/configure.in b/configure.in
index 83e5d76..e6dc38c 100644
index db3641b..8e4aaec 100644
--- a/configure.in
+++ b/configure.in
@@ -3011,6 +3011,15 @@ else
@@ -3151,6 +3151,15 @@ else
RUBY_LIB_VERSION="\"${ruby_version}\""
fi
@ -42,7 +42,7 @@ index 83e5d76..e6dc38c 100644
AC_ARG_WITH(sitedir,
AS_HELP_STRING([--with-sitedir=DIR], [site libraries in DIR [[RUBY_LIB_PREFIX/site_ruby]], "no" to disable site directory]),
[sitedir=$withval],
@@ -3033,16 +3042,25 @@ if test "${LOAD_RELATIVE+set}"; then
@@ -3173,16 +3182,25 @@ if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
RUBY_LIB_PREFIX="`eval echo "$RUBY_LIB_PREFIX" | sed 's|^NONE/|/|;s|^'"$prefix"'/|/|'`"
@ -68,7 +68,7 @@ index 83e5d76..e6dc38c 100644
AS_CASE(["$RUBY_SITE_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_SITE_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_SITE_LIB_PATH\" : \"$pat\"`"'"'
@@ -3073,6 +3091,7 @@
@@ -3213,6 +3231,7 @@ else
fi
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, "${RUBY_EXEC_PREFIX}")
AC_DEFINE_UNQUOTED(RUBY_LIB_PREFIX, ${RUBY_LIB_PREFIX} !<verconf>!)
@ -76,7 +76,7 @@ index 83e5d76..e6dc38c 100644
if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
@@ -3087,6 +3106,7 @@ fi
@@ -3227,6 +3246,7 @@ fi
AC_SUBST(arch)dnl
AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl
@ -85,10 +85,10 @@ index 83e5d76..e6dc38c 100644
AC_SUBST(vendordir)dnl
diff --git a/tool/mkconfig.rb b/tool/mkconfig.rb
index b707c4b..9780ef2 100755
index d9e26c1..03c3332 100755
--- a/tool/mkconfig.rb
+++ b/tool/mkconfig.rb
@@ -43,6 +43,7 @@ v_others = []
@@ -43,6 +43,7 @@ vars = {}
continued_name = nil
continued_line = nil
path_version = "/$(ruby_version)"
@ -114,7 +114,7 @@ index b707c4b..9780ef2 100755
print <<EOS unless v_disabled["sitedir"]
CONFIG["sitelibdir"] = "$(sitedir)#{path_version}"
diff --git a/version.c b/version.c
index 59d4e5e..915a0a2 100644
index 05e5069..a117059 100644
--- a/version.c
+++ b/version.c
@@ -48,7 +48,9 @@
@ -128,5 +128,5 @@ index 59d4e5e..915a0a2 100644
#define RUBY_VENDOR_ARCHLIB RUBY_VENDOR_LIB2 "/"RUBY_SITEARCH
#ifdef RUBY_THINARCH
--
1.7.6.1
1.8.0

View File

@ -1,19 +1,21 @@
From fa1a50ad10814f724b8713865dc222724cb955ab Mon Sep 17 00:00:00 2001
From 23cfbaa371f82d0b4652c9e37189a2be82fa3d4c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
Date: Thu, 25 Aug 2011 14:33:51 +0200
Subject: [PATCH] Allow to disable versioned paths.
---
configure.in | 11 +++++++++++
tool/mkconfig.rb | 9 ++++++---
version.c | 10 ++++++++++
3 files changed, 27 insertions(+), 3 deletions(-)
configure.in | 11 +++++++++++
lib/rdoc/ri/paths.rb | 4 ++--
tool/mkconfig.rb | 9 ++++++---
tool/rbinstall.rb | 2 +-
version.c | 10 ++++++++++
5 files changed, 30 insertions(+), 6 deletions(-)
diff --git a/configure.in b/configure.in
index e742e74..86cb68f 100644
index f2d22ef..db3641b 100644
--- a/configure.in
+++ b/configure.in
@@ -3178,6 +3178,17 @@ else
@@ -3318,6 +3318,17 @@ else
fi
AC_SUBST(USE_RUBYGEMS)
@ -31,8 +33,24 @@ index e742e74..86cb68f 100644
arch_hdrdir="${EXTOUT}/include/${arch}/ruby"
AS_MKDIR_P("${arch_hdrdir}")
config_h="${arch_hdrdir}/config.h"
diff --git a/lib/rdoc/ri/paths.rb b/lib/rdoc/ri/paths.rb
index a3c65bf..a4e8559 100644
--- a/lib/rdoc/ri/paths.rb
+++ b/lib/rdoc/ri/paths.rb
@@ -11,9 +11,9 @@ module RDoc::RI::Paths
version = RbConfig::CONFIG['ruby_version']
base = if RbConfig::CONFIG.key? 'ridir' then
- File.join RbConfig::CONFIG['ridir'], version
+ File.join [RbConfig::CONFIG['ridir'], RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil].compact
else
- File.join RbConfig::CONFIG['datadir'], 'ri', version
+ File.join [RbConfig::CONFIG['datadir'], 'ri', RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil].compact
end
SYSDIR = File.join base, "system"
diff --git a/tool/mkconfig.rb b/tool/mkconfig.rb
index a2221f0..47d8c8f 100755
index f9d97d3..d9e26c1 100755
--- a/tool/mkconfig.rb
+++ b/tool/mkconfig.rb
@@ -42,6 +42,7 @@ v_others = []
@ -71,8 +89,21 @@ index a2221f0..47d8c8f 100755
CONFIG["vendorarchdir"] = "$(vendorlibdir)/$(sitearch)"
EOS
print <<EOS
diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index f5facca..17294a2 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -392,7 +392,7 @@ end
install?(:doc, :rdoc) do
if $rdocdir
- ridatadir = File.join(CONFIG['ridir'], CONFIG['ruby_version'], "system")
+ ridatadir = File.join([CONFIG['ridir'], RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil, "system"].compact)
prepare "rdoc", ridatadir
install_recursive($rdocdir, ridatadir, :mode => $data_mode)
end
diff --git a/version.c b/version.c
index 59d4e5e..641dc33 100644
index 26e275a..05e5069 100644
--- a/version.c
+++ b/version.c
@@ -39,9 +39,15 @@
@ -114,36 +145,5 @@ index 59d4e5e..641dc33 100644
RUBY_LIB "\0"
#ifdef RUBY_THIN_ARCHLIB
--
1.7.7.3
diff --git a/lib/rdoc/ri/paths.rb b/lib/rdoc/ri/paths.rb
index a3c65bf..0575730 100644
--- a/lib/rdoc/ri/paths.rb
+++ b/lib/rdoc/ri/paths.rb
@@ -11,9 +11,9 @@ module RDoc::RI::Paths
version = RbConfig::CONFIG['ruby_version']
base = if RbConfig::CONFIG.key? 'ridir' then
- File.join RbConfig::CONFIG['ridir'], version
+ File.join [RbConfig::CONFIG['ridir'], RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil].compact
else
- File.join RbConfig::CONFIG['datadir'], 'ri', version
+ File.join [RbConfig::CONFIG['datadir'], 'ri', RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil].compact
end
SYSDIR = File.join base, "system"
diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index cec8c9f..fed14d2 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -392,7 +392,7 @@ end
install?(:doc, :rdoc) do
if $rdocdir
- ridatadir = File.join(CONFIG['ridir'], CONFIG['ruby_version'], "system")
+ ridatadir = File.join([CONFIG['ridir'], RbConfig::CONFIG['USE_VERSIONED_PATHS'] == 'YES' ? version : nil, "system"].compact)
prepare "rdoc", ridatadir
install_recursive($rdocdir, ridatadir, :mode => $data_mode)
end
--
1.7.6
1.8.0