Update to Ruby 2.4.1.
This commit is contained in:
parent
4571daf34e
commit
5c42276905
@ -1,36 +0,0 @@
|
||||
From 7c1b30a602ab109d8d5388d7dfb3c5b180ba24e1 Mon Sep 17 00:00:00 2001
|
||||
From: naruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Mon, 23 Jan 2017 16:58:27 +0000
|
||||
Subject: [PATCH] Prevent GC by volatile [Bug #13150]
|
||||
|
||||
test/ruby/test_marshal.rb test_context_switch (load) and test_gc (dump)
|
||||
are failed on FreeBSD 10.3 and gcc7 (FreeBSD Ports Collection) 7.0.0
|
||||
20170115 (experimental); RB_GC_GUARD looks not worked well.
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@57410 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
marshal.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/marshal.c b/marshal.c
|
||||
index a9926ac..d628daa 100644
|
||||
--- a/marshal.c
|
||||
+++ b/marshal.c
|
||||
@@ -1024,7 +1024,7 @@ VALUE
|
||||
rb_marshal_dump_limited(VALUE obj, VALUE port, int limit)
|
||||
{
|
||||
struct dump_arg *arg;
|
||||
- VALUE wrapper; /* used to avoid memory leak in case of exception */
|
||||
+ volatile VALUE wrapper; /* used to avoid memory leak in case of exception */
|
||||
|
||||
wrapper = TypedData_Make_Struct(rb_cData, struct dump_arg, &dump_arg_data, arg);
|
||||
arg->dest = 0;
|
||||
@@ -2038,7 +2038,7 @@ rb_marshal_load_with_proc(VALUE port, VALUE proc)
|
||||
{
|
||||
int major, minor, infection = 0;
|
||||
VALUE v;
|
||||
- VALUE wrapper; /* used to avoid memory leak in case of exception */
|
||||
+ volatile VALUE wrapper; /* used to avoid memory leak in case of exception */
|
||||
struct load_arg *arg;
|
||||
|
||||
v = rb_check_string_type(port);
|
@ -1,36 +0,0 @@
|
||||
From ff3496b0116ed2ed589d000b7bfca3d8288b009c Mon Sep 17 00:00:00 2001
|
||||
From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Mon, 9 Jan 2017 02:55:39 +0000
|
||||
Subject: [PATCH] vm_insnhelper.c: block argument at tailcall
|
||||
|
||||
* vm_insnhelper.c (vm_call_iseq_setup_tailcall): check interrupts
|
||||
after set up the new frame, not the passed block to be clobbered
|
||||
by invoked finalizers and so on. [ruby-core:78981] [Bug #13107]
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@57293 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
vm_insnhelper.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/vm_insnhelper.c b/vm_insnhelper.c
|
||||
index b580412..662a2d6 100644
|
||||
--- a/vm_insnhelper.c
|
||||
+++ b/vm_insnhelper.c
|
||||
@@ -1538,8 +1538,6 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
|
||||
vm_pop_frame(th, cfp, cfp->ep);
|
||||
cfp = th->cfp;
|
||||
|
||||
- RUBY_VM_CHECK_INTS(th);
|
||||
-
|
||||
sp_orig = sp = cfp->sp;
|
||||
|
||||
/* push self */
|
||||
@@ -1558,6 +1556,8 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
|
||||
iseq->body->stack_max);
|
||||
|
||||
cfp->sp = sp_orig;
|
||||
+ RUBY_VM_CHECK_INTS(th);
|
||||
+
|
||||
return Qundef;
|
||||
}
|
||||
|
21
ruby.spec
21
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 2
|
||||
%global minor_version 4
|
||||
%global teeny_version 0
|
||||
%global teeny_version 1
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 78
|
||||
%global release 79
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
# The RubyGems library has to stay out of Ruby directory three, since the
|
||||
@ -29,8 +29,8 @@
|
||||
%global rubygems_dir %{_datadir}/rubygems
|
||||
|
||||
# Bundled libraries versions
|
||||
%global rubygems_version 2.6.8
|
||||
%global molinillo_version 0.5.3
|
||||
%global rubygems_version 2.6.11
|
||||
%global molinillo_version 0.5.7
|
||||
|
||||
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
|
||||
# http://redmine.ruby-lang.org/issues/5313
|
||||
@ -42,7 +42,7 @@
|
||||
%global json_version 2.0.2
|
||||
%global minitest_version 5.10.1
|
||||
%global net_telnet_version 0.1.1
|
||||
%global openssl_version 2.0.2
|
||||
%global openssl_version 2.0.3
|
||||
%global power_assert_version 0.4.1
|
||||
%global psych_version 2.2.2
|
||||
%global rake_version 12.0.0
|
||||
@ -128,12 +128,6 @@ Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# hardening features of glibc (rhbz#1361037).
|
||||
# https://bugs.ruby-lang.org/issues/12666
|
||||
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
|
||||
# This fixed rubygem-mongo build failures and may be something else as well.
|
||||
# https://bugs.ruby-lang.org/issues/13107
|
||||
Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch
|
||||
# Fix GCC 7.x compatibility (rhbz#1417590).
|
||||
# https://bugs.ruby-lang.org/issues/13150
|
||||
Patch11: ruby-2.4.0-Prevent-GC-by-volatile.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Suggests: rubypick
|
||||
@ -513,8 +507,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -1029,6 +1021,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||
|
||||
%changelog
|
||||
* Mon Apr 03 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.1-79
|
||||
- Update to Ruby 2.4.1.
|
||||
|
||||
* Thu Feb 23 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.0-78
|
||||
- Fix OpenSSL symlinks.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ruby-2.4.0.tar.xz) = 975a5388592adc038461e0acebb6c0efee242891b2ea8621476401458efe2bc0fdd317d3bf99beb745b0b3808410efdff33862da29c95c027f457943721e3ab6
|
||||
SHA512 (ruby-2.4.1.tar.xz) = e6fd290b6edd166348b70f0f1c56f7ed9d956c4c1eb91d97d0548041ca4196b9b75ec1ad35c745bdbfd4de195899093e7205d7f02b014ecf1c48e6f31cf25903
|
||||
|
Loading…
Reference in New Issue
Block a user