Upgrade to Ruby 3.2.1.
Resolves: rhbz#2168292
This commit is contained in:
parent
65acd291de
commit
59f62d6bc9
@ -227,7 +227,7 @@ diff --git a/test/rubygems/test_gem.rb b/test/rubygems/test_gem.rb
|
||||
index b25068405d..e9fef4a311 100644
|
||||
--- a/test/rubygems/test_gem.rb
|
||||
+++ b/test/rubygems/test_gem.rb
|
||||
@@ -1395,7 +1395,8 @@ def test_self_use_paths
|
||||
@@ -1337,7 +1337,8 @@ def test_self_use_paths
|
||||
|
||||
def test_self_user_dir
|
||||
parts = [@userhome, ".gem", Gem.ruby_engine]
|
||||
@ -237,7 +237,7 @@ index b25068405d..e9fef4a311 100644
|
||||
|
||||
FileUtils.mkdir_p File.join(parts)
|
||||
|
||||
@@ -1471,7 +1472,7 @@ def test_self_vendor_dir
|
||||
@@ -1413,7 +1414,7 @@ def test_self_vendor_dir
|
||||
vendordir(File.join(@tempdir, "vendor")) do
|
||||
expected =
|
||||
File.join RbConfig::CONFIG["vendordir"], "gems",
|
||||
|
@ -32,7 +32,7 @@ index d0558697d7..e73841aae7 100644
|
||||
RUNNABLE = $(LIBRUBY_RELATIVE:no=un)-runnable
|
||||
runnable: $(RUNNABLE) prog $(tooldir)/mkrunnable.rb PHONY
|
||||
$(Q) $(MINIRUBY) $(tooldir)/mkrunnable.rb -v $(EXTOUT)
|
||||
@@ -1457,7 +1456,6 @@ test-syntax-suggest-precheck: $(TEST_RUNNABLE)-test-syntax-suggest-precheck
|
||||
@@ -1456,7 +1455,6 @@ test-syntax-suggest-precheck: $(TEST_RUNNABLE)-test-syntax-suggest-precheck
|
||||
no-test-syntax-suggest-precheck:
|
||||
yes-test-syntax-suggest-precheck: main
|
||||
|
||||
@ -40,7 +40,7 @@ index d0558697d7..e73841aae7 100644
|
||||
no-test-syntax-suggest-prepare: no-test-syntax-suggest-precheck
|
||||
yes-test-syntax-suggest-prepare: yes-test-syntax-suggest-precheck
|
||||
$(ACTIONS_GROUP)
|
||||
@@ -1467,15 +1465,13 @@ yes-test-syntax-suggest-prepare: yes-test-syntax-suggest-precheck
|
||||
@@ -1466,15 +1464,13 @@ yes-test-syntax-suggest-prepare: yes-test-syntax-suggest-precheck
|
||||
|
||||
RSPECOPTS =
|
||||
SYNTAX_SUGGEST_SPECS =
|
||||
|
@ -23,7 +23,7 @@ index 27f6a9d89d..8021f03a58 100644
|
||||
$(ECHO) check succeeded
|
||||
-$(Q) : : "run only on sh"; \
|
||||
if [ x"$(GIT)" != x ] && $(CHDIR) "$(srcdir)" && \
|
||||
@@ -1465,9 +1464,8 @@ yes-test-syntax-suggest-prepare: yes-test-syntax-suggest-precheck
|
||||
@@ -1464,9 +1463,8 @@ yes-test-syntax-suggest-prepare: yes-test-syntax-suggest-precheck
|
||||
|
||||
RSPECOPTS =
|
||||
SYNTAX_SUGGEST_SPECS =
|
||||
|
17
ruby.spec
17
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 3
|
||||
%global minor_version 2
|
||||
%global teeny_version 0
|
||||
%global teeny_version 1
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -27,13 +27,13 @@
|
||||
%global rubygems_dir %{_datadir}/rubygems
|
||||
|
||||
# Bundled libraries versions
|
||||
%global rubygems_version 3.4.1
|
||||
%global rubygems_version 3.4.6
|
||||
%global rubygems_molinillo_version 0.8.0
|
||||
%global rubygems_optparse_version 0.3.0
|
||||
%global rubygems_tsort_version 0.1.0
|
||||
|
||||
# Default gems.
|
||||
%global bundler_version 2.4.1
|
||||
%global bundler_version 2.4.6
|
||||
%global bundler_connection_pool_version 2.3.0
|
||||
%global bundler_fileutils_version 1.7.0
|
||||
%global bundler_pub_grub_version 0.5.0
|
||||
@ -101,7 +101,7 @@
|
||||
Summary: An interpreter of object-oriented scripting language
|
||||
Name: ruby
|
||||
Version: %{ruby_version}%{?development_release}
|
||||
Release: 178%{?dist}
|
||||
Release: 179%{?dist}
|
||||
# BSD-3-Clause: missing/{crypt,mt19937,setproctitle}.c
|
||||
# ISC: missing/strl{cat,cpy}.c
|
||||
# Public Domain for example for: include/ruby/st.h, strftime.c, missing/*, ...
|
||||
@ -1007,11 +1007,6 @@ DISABLE_TESTS="$DISABLE_TESTS -n !/Fiddle::TestFunction#test_argument_count/"
|
||||
mv test/ruby/test_jit.rb{,.disable} || :
|
||||
%endif
|
||||
|
||||
# Disable `TestGCCompact#test_moving_objects_between_size_pools` due to:
|
||||
# `NoMethodError: undefined method `>=' for nil:NilClass` error.
|
||||
# https://bugs.ruby-lang.org/issues/19248
|
||||
DISABLE_TESTS="$DISABLE_TESTS -n !/TestGCCompact#test_moving_objects_between_size_pools/"
|
||||
|
||||
# Give an option to increase the timeout in tests.
|
||||
# https://bugs.ruby-lang.org/issues/16921
|
||||
%{?test_timeout_scale:RUBY_TEST_TIMEOUT_SCALE="%{test_timeout_scale}"} \
|
||||
@ -1572,6 +1567,10 @@ DISABLE_TESTS="$DISABLE_TESTS -n !/TestGCCompact#test_moving_objects_between_siz
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 09 2023 Vít Ondruch <vondruch@redhat.com> - 3.2.1-179
|
||||
- Upgrade to Ruby 3.2.1.
|
||||
Resolves: rhbz#2168292
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org>
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ruby-3.2.0.tar.xz) = 733ecc6709470ee16916deeece9af1c76220ae95d17b2681116aff7f381d99bc3124b1b11b1c2336b2b29e468e91b90f158d5ae5fca810c6cf32a0b6234ae08e
|
||||
SHA512 (ruby-3.2.1.tar.xz) = 69caadab9be6b56905ea4fc92fa0e36704f9fa6a0e7e7f4c6bdb79e9cbe8dc57c524f96d9c18802d61aa1ca578fed2e9758692f9d701bf0dba938f0206b721b3
|
||||
|
Loading…
Reference in New Issue
Block a user