Backport trunk@53455 to make ruby-qt build
This commit is contained in:
parent
5ed2c68dc5
commit
55ecc214e1
31
ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch
Normal file
31
ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 98e565ec78cb4a07ffde8589ac4581fca31e9c17 Mon Sep 17 00:00:00 2001
|
||||
From: mrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Thu, 7 Jan 2016 13:35:32 +0000
|
||||
Subject: [PATCH] * ruby.h: undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
||||
and HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P on C++. [ruby-core:72736]
|
||||
[Bug #11962]
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53455 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
ChangeLog | 6 ++++++
|
||||
include/ruby/ruby.h | 7 +++++++
|
||||
2 files changed, 13 insertions(+)
|
||||
|
||||
diff --git a/include/ruby/ruby.h b/include/ruby/ruby.h
|
||||
index 7aabf5b..82dca14 100644
|
||||
--- a/include/ruby/ruby.h
|
||||
+++ b/include/ruby/ruby.h
|
||||
@@ -26,6 +26,13 @@ extern "C" {
|
||||
#include RUBY_EXTCONF_H
|
||||
#endif
|
||||
|
||||
+#if defined(__cplusplus)
|
||||
+/* __builtin_choose_expr and __builtin_types_compatible aren't available
|
||||
+ * on C++. See https://gcc.gnu.org/onlinedocs/gcc/Other-Builtins.html */
|
||||
+# undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
||||
+# undef HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P
|
||||
+#endif
|
||||
+
|
||||
#include "defines.h"
|
||||
|
||||
#define NORETURN_STYLE_NEW 1
|
10
ruby.spec
10
ruby.spec
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 52
|
||||
%global release 53
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
# The RubyGems library has to stay out of Ruby directory three, since the
|
||||
@ -122,6 +122,10 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# Use miniruby to regenerate prelude.c.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# 98e565ec78cb4a07ffde8589ac4581fca31e9c17
|
||||
# https://bugs.ruby-lang.org/issues/11962
|
||||
# https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/53455
|
||||
Patch8: ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Suggests: rubypick
|
||||
@ -465,6 +469,7 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -941,6 +946,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Fri Jan 15 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.3.0-53
|
||||
- Backport trunk@53455 to make ruby-qt build
|
||||
|
||||
* Wed Jan 06 2016 Vít Ondruch <vondruch@redhat.com> - 2.3.0-52
|
||||
- Explicitly require RDoc, since weak dependencies are ignored by default.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user