Merge remote-tracking branch 'origin/master' into f18
This commit is contained in:
commit
53c4a0f73f
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
||||
/ruby-1.9.3-p125.tar.gz
|
||||
/ruby-1.9.3-p194.tar.gz
|
||||
/ruby-1.9.3-p286.tar.gz
|
||||
/ruby-1.9.3-p327.tar.gz
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- ruby-1.9.3-p286/test/ruby/test_io.rb.devtty 2012-10-12 17:37:54.000000000 +0900
|
||||
+++ ruby-1.9.3-p286/test/ruby/test_io.rb 2012-10-13 14:00:24.000000000 +0900
|
||||
@@ -2068,6 +2068,11 @@
|
||||
return if /linux/ !~ RUBY_PLATFORM
|
||||
return if /^i.?86|^x86_64/ !~ RUBY_PLATFORM
|
||||
return unless File.exist?('/dev/tty')
|
||||
+ begin
|
||||
+ File.open('/dev/tty') {|f|}
|
||||
+ rescue Errno::ENXIO
|
||||
+ return
|
||||
+ end
|
||||
|
||||
File.open('/dev/tty') { |f|
|
||||
tiocgwinsz=0x5413
|
24
ruby.spec
24
ruby.spec
@ -1,7 +1,7 @@
|
||||
%global major_version 1
|
||||
%global minor_version 9
|
||||
%global teeny_version 3
|
||||
%global patch_level 286
|
||||
%global patch_level 327
|
||||
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
@ -56,7 +56,7 @@ Version: %{ruby_version_patch_level}
|
||||
# we cannot reset the release number to 1 even when the main (ruby) version
|
||||
# is updated - because it may be that the versions of sub-components don't
|
||||
# change.
|
||||
Release: 19%{?dist}
|
||||
Release: 20%{?dist}
|
||||
Group: Development/Languages
|
||||
# Public Domain for example for: include/ruby/st.h, strftime.c, ...
|
||||
License: (Ruby or BSD) and Public Domain
|
||||
@ -78,9 +78,6 @@ Patch4: ruby-1.9.3-fix-s390x-build.patch
|
||||
# Fix the uninstaller, so that it doesn't say that gem doesn't exist
|
||||
# when it exists outside of the GEM_HOME (already fixed in the upstream)
|
||||
Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
|
||||
# http://redmine.ruby-lang.org/issues/5135 - see comment 29
|
||||
# Fixed in ruby 1.9.3p286
|
||||
#Patch6: ruby-1.9.3-webrick-test-fix.patch
|
||||
# Already fixed upstream:
|
||||
# https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
|
||||
Patch7: ruby-1.9.3-bignum-test-fix.patch
|
||||
@ -90,13 +87,10 @@ Patch8: ruby-1.9.3-custom-rubygems-location.patch
|
||||
# Add support for installing binary extensions according to FHS.
|
||||
# https://github.com/rubygems/rubygems/issues/210
|
||||
Patch9: rubygems-1.8.11-binary-extensions.patch
|
||||
# Patch from trunk for CVE-4464, CVE-4466
|
||||
# http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=37068
|
||||
# Fixed in ruby 1.9.3p286
|
||||
#Patch10: ruby-1.9.3-backport-from-trunk-rev37068.patch
|
||||
# Opening /dev/tty fails with ENXIO (ref: man 2 open) on koji.
|
||||
# Let's rescue this
|
||||
Patch10: ruby-1.9.3-p286-open-devtty-on-koji.patch
|
||||
# Fixed in ruby 1.9.3 p327
|
||||
#Patch10: ruby-1.9.3-p286-open-devtty-on-koji.patch
|
||||
# Make mkmf verbose by default
|
||||
Patch12: ruby-1.9.3-mkmf-verbose.patch
|
||||
|
||||
@ -335,11 +329,10 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
#%%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
#%%patch10 -p1
|
||||
%patch12 -p1
|
||||
|
||||
%build
|
||||
@ -746,10 +739,15 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Sat Nov 10 2012 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.9.3.327-1
|
||||
- Update to 1.9.3.327
|
||||
- Fix Hash-flooding DoS vulnerability on MurmurHash function
|
||||
(CVE-2012-5371)
|
||||
|
||||
* Sat Oct 13 2012 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.9.3.286-19
|
||||
- Update to 1.9.3 p286
|
||||
- Don't create files when NUL-containing path name is passed
|
||||
(bug 865940)
|
||||
(bug 865940, CVE-2012-4522)
|
||||
|
||||
* Thu Oct 04 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 1.9.3.194-18
|
||||
- Patch from trunk for CVE-2012-4464, CVE-2012-4466
|
||||
|
Loading…
Reference in New Issue
Block a user