Upgrade to Ruby 2.0.0 (r37421).

This commit is contained in:
Vít Ondruch 2012-11-05 16:38:52 +01:00
parent 223ff9d8e4
commit 4531f33ec9
8 changed files with 36 additions and 38 deletions

View File

@ -15,7 +15,7 @@ diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..f57e4c4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -37,6 +37,9 @@ datadir = @datadir@
@@ -38,6 +38,9 @@ datadir = @datadir@
archdir = @archdir@
sitearch = @sitearch@
sitedir = @sitedir@
@ -29,7 +29,7 @@ diff --git a/configure.in b/configure.in
index 83e5d76..31532bd 100644
--- a/configure.in
+++ b/configure.in
@@ -2866,6 +2866,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
@@ -3028,6 +3028,15 @@ until SITE_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${SITE_DIR}"; do
dir="${SITE_DIR}"
done
@ -45,7 +45,7 @@ index 83e5d76..31532bd 100644
AC_ARG_WITH(vendordir,
AS_HELP_STRING([--with-vendordir=DIR], [vendor libraries in DIR [[RUBY_LIB_PREFIX/vendor_ruby]], "no" to disable vendor directory]),
[vendordir=$withval],
@@ -2875,19 +2884,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -3037,19 +3046,32 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDOR_DIR}"
done
@ -78,7 +78,7 @@ index 83e5d76..31532bd 100644
fi
pat=`echo "$RUBY_LIB_PREFIX/" | tr -c '\012' .`'\(.*\)'
@@ -2905,12 +2927,26 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
@@ -3067,12 +3089,26 @@ AS_CASE(["$RUBY_SITE_LIB_PATH"],
[
RUBY_SITE_LIB_PATH="\"${RUBY_SITE_LIB_PATH}\""
])
@ -105,7 +105,7 @@ index 83e5d76..31532bd 100644
])
pat=`echo "$RUBY_EXEC_PREFIX/" | tr -c '\012' .`'\(.*\)'
AS_CASE(["$RUBY_LIB_PREFIX"],
@@ -2933,19 +2969,23 @@ if test "x$SITE_DIR" = xno; then
@@ -3095,19 +3131,23 @@ if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
AC_DEFINE_UNQUOTED(RUBY_SITE_LIB, ${RUBY_SITE_LIB_PATH} !<verconf>!)

View File

@ -1,6 +1,6 @@
--- a/configure.in.orig 2011-10-18 08:56:21.587594685 +0200
+++ b/configure.in 2011-10-18 08:56:59.751593321 +0200
@@ -2990,6 +2990,8 @@
@@ -3152,6 +3152,8 @@
configure_args=$ac_configure_args
AC_SUBST(configure_args)dnl

View File

@ -14,7 +14,7 @@ diff --git a/Makefile.in b/Makefile.in
index bcdaf5f..d61b2ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -34,6 +34,7 @@ libexecdir = @libexecdir@
@@ -35,6 +35,7 @@ libexecdir = @libexecdir@
datarootdir = @datarootdir@
datadir = @datadir@
arch = @arch@
@ -26,7 +26,7 @@ diff --git a/configure.in b/configure.in
index 83e5d76..e6dc38c 100644
--- a/configure.in
+++ b/configure.in
@@ -2848,6 +2848,15 @@ else
@@ -3010,6 +3010,15 @@ else
RUBY_LIB_VERSION="\"${ruby_version}\""
fi
@ -42,7 +42,7 @@ index 83e5d76..e6dc38c 100644
AC_ARG_WITH(sitedir,
AS_HELP_STRING([--with-sitedir=DIR], [site libraries in DIR [[RUBY_LIB_PREFIX/site_ruby]], "no" to disable site directory]),
[sitedir=$withval],
@@ -2870,16 +2879,25 @@ if test "${LOAD_RELATIVE+set}"; then
@@ -3032,16 +3041,25 @@ if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
RUBY_LIB_PREFIX="`eval echo "$RUBY_LIB_PREFIX" | sed 's|^NONE/|/|;s|^'"$prefix"'/|/|'`"
@ -68,7 +68,7 @@ index 83e5d76..e6dc38c 100644
AS_CASE(["$RUBY_SITE_LIB_PATH"],
["$RUBY_LIB_PREFIX/"*], [
RUBY_SITE_LIB_PATH='RUBY_LIB_PREFIX"/'"`expr \"$RUBY_SITE_LIB_PATH\" : \"$pat\"`"'"'
@@ -2910,6 +2928,7 @@
@@ -3072,6 +3090,7 @@
fi
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, "${RUBY_EXEC_PREFIX}")
AC_DEFINE_UNQUOTED(RUBY_LIB_PREFIX, ${RUBY_LIB_PREFIX} !<verconf>!)
@ -76,7 +76,7 @@ index 83e5d76..e6dc38c 100644
if test "x$SITE_DIR" = xno; then
AC_DEFINE(NO_RUBY_SITE_LIB, [] !<verconf>!)
else
@@ -2924,6 +2943,7 @@ fi
@@ -3086,6 +3105,7 @@ fi
AC_SUBST(arch)dnl
AC_SUBST(sitearch)dnl
AC_SUBST(ruby_version)dnl

View File

@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
index b1bc951..91c5d0d 100644
--- a/configure.in
+++ b/configure.in
@@ -2893,6 +2893,13 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
@@ -3055,6 +3055,13 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
dir="${VENDORARCH_DIR}"
done
@ -29,7 +29,7 @@ index b1bc951..91c5d0d 100644
if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=""
@@ -2986,6 +2993,7 @@ AC_SUBST(sitearch)dnl
@@ -3148,6 +3155,7 @@ AC_SUBST(sitearch)dnl
AC_SUBST(sitearchdir)dnl
AC_SUBST(vendordir)dnl
AC_SUBST(vendorarchdir)dnl
@ -53,7 +53,7 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index 6bfc73e..31dc446 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -311,6 +311,7 @@ sitelibdir = CONFIG["sitelibdir"]
@@ -313,6 +313,7 @@ sitelibdir = CONFIG["sitelibdir"]
sitearchlibdir = CONFIG["sitearchdir"]
vendorlibdir = CONFIG["vendorlibdir"]
vendorarchlibdir = CONFIG["vendorarchdir"]
@ -61,7 +61,7 @@ index 6bfc73e..31dc446 100755
mandir = CONFIG["mandir", true]
docdir = CONFIG["docdir", true]
configure_args = Shellwords.shellwords(CONFIG["configure_args"])
@@ -498,7 +499,15 @@ end
@@ -500,7 +501,15 @@ end
install?(:local, :comm, :lib) do
prepare "library scripts", rubylibdir
noinst = %w[README* *.txt *.rdoc]

View File

@ -13,7 +13,7 @@ diff --git a/configure.in b/configure.in
index e742e74..86cb68f 100644
--- a/configure.in
+++ b/configure.in
@@ -3018,6 +3018,17 @@ else
@@ -3177,6 +3177,17 @@ else
fi
AC_SUBST(USE_RUBYGEMS)
@ -135,7 +135,7 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
index cec8c9f..fed14d2 100755
--- a/tool/rbinstall.rb
+++ b/tool/rbinstall.rb
@@ -390,7 +390,7 @@ end
@@ -392,7 +392,7 @@ end
install?(:doc, :rdoc) do
if $rdocdir

View File

@ -1,6 +1,6 @@
--- ruby-1.9.3-p0/lib/mkmf.rb.debug 2011-08-11 15:07:37.000000000 +0900
+++ ruby-1.9.3-p0/lib/mkmf.rb 2012-01-29 21:34:17.000000000 +0900
@@ -1725,7 +1725,7 @@
@@ -1746,7 +1746,7 @@
SHELL = /bin/sh
# V=0 quiet, V=1 verbose. other values don't work.

View File

@ -13,7 +13,7 @@
# If revision is removed/commented out, the official release build is expected.
# Keep the revision enabled for pre-releases from SVN.
%global revision 36887
%global revision 37421
%global release 1
@ -54,7 +54,7 @@
%global bigdecimal_version 1.1.0
%global io_console_version 0.3
%global json_version 1.7.1
%global minitest_version 3.3.0
%global minitest_version 3.4.0
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
@ -111,10 +111,6 @@ Patch12: ruby-1.9.3-mkmf-verbose.patch
# TODO: Should be probably upstreamed with #5281.
Patch14: ruby-2.0.0-Expand-ruby.pc-variable-by-configuration-process.patch
# This patch breaks a test suite, so revert it for now.
# https://bugs.ruby-lang.org/issues/6971
Patch100: ruby-2.0-r36832-rb_float_value-optimization.patch
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: ruby(rubygems) >= %{rubygems_version}
# Make the bigdecimal gem a runtime dependency of Ruby to avoid problems
@ -339,6 +335,10 @@ output.
# TODO:
# %%pacakge -n rubygem-psych
# TODO:
# %%pacakge -n rubygem-test-unit
%package tcltk
Summary: Tcl/Tk interface for scripting language Ruby
Group: Development/Languages
@ -365,8 +365,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
#%%patch13 -p1
%patch14 -p1
%patch100 -p1 -R
%build
autoconf

View File

@ -11,7 +11,7 @@ diff --git a/lib/rubygems/specification.rb b/lib/rubygems/specification.rb
index 97db19e..263e7d3 100644
--- a/lib/rubygems/specification.rb
+++ b/lib/rubygems/specification.rb
@@ -843,6 +843,12 @@ class Gem::Specification
@@ -859,6 +859,12 @@ class Gem::Specification
File.join full_gem_path, path
end
@ -24,7 +24,7 @@ index 97db19e..263e7d3 100644
# gem directories must come after -I and ENV['RUBYLIB']
insert_index = Gem.load_path_insert_index
@@ -954,16 +960,16 @@ class Gem::Specification
@@ -970,16 +976,16 @@ class Gem::Specification
def contains_requirable_file? file
root = full_gem_path
@ -48,7 +48,7 @@ index 97db19e..263e7d3 100644
end
##
@@ -1273,6 +1279,23 @@ class Gem::Specification
@@ -1295,6 +1301,23 @@ class Gem::Specification
end
##
@ -90,7 +90,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 74d803d..0063c7f 100644
--- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb
@@ -499,7 +499,7 @@ TEXT
@@ -509,7 +509,7 @@ TEXT
def build_extensions
return if spec.extensions.empty?
say "Building native extensions. This could take a while..."
@ -103,7 +103,7 @@ diff --git a/lib/rubygems/specification.rb b/lib/rubygems/specification.rb
index 263e7d3..d31b93b 100644
--- a/lib/rubygems/specification.rb
+++ b/lib/rubygems/specification.rb
@@ -1283,16 +1283,15 @@ class Gem::Specification
@@ -1305,16 +1305,15 @@ class Gem::Specification
# eg: /usr/local/lib/ruby/1.8/exts/mygem-1.0
def ext_dir
@ -140,7 +140,7 @@ diff --git a/lib/rubygems/specification.rb b/lib/rubygems/specification.rb
index d31b93b..e65ea2d 100644
--- a/lib/rubygems/specification.rb
+++ b/lib/rubygems/specification.rb
@@ -843,11 +843,7 @@ class Gem::Specification
@@ -859,11 +859,7 @@ class Gem::Specification
File.join full_gem_path, path
end
@ -153,7 +153,7 @@ index d31b93b..e65ea2d 100644
# gem directories must come after -I and ENV['RUBYLIB']
insert_index = Gem.load_path_insert_index
@@ -1291,7 +1287,10 @@ class Gem::Specification
@@ -1313,7 +1309,10 @@ class Gem::Specification
# gem directory. eg: /usr/local/lib/ruby/1.8/gems
def exts_dir
@ -183,7 +183,7 @@ diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
index 0063c7f..83b8fd5 100644
--- a/lib/rubygems/installer.rb
+++ b/lib/rubygems/installer.rb
@@ -499,7 +499,7 @@ TEXT
@@ -509,7 +509,7 @@ TEXT
def build_extensions
return if spec.extensions.empty?
say "Building native extensions. This could take a while..."
@ -196,7 +196,7 @@ diff --git a/lib/rubygems/specification.rb b/lib/rubygems/specification.rb
index e65ea2d..8be2ade 100644
--- a/lib/rubygems/specification.rb
+++ b/lib/rubygems/specification.rb
@@ -843,7 +843,7 @@ class Gem::Specification
@@ -859,7 +859,7 @@ class Gem::Specification
File.join full_gem_path, path
end
@ -205,7 +205,7 @@ index e65ea2d..8be2ade 100644
# gem directories must come after -I and ENV['RUBYLIB']
insert_index = Gem.load_path_insert_index
@@ -1279,7 +1279,7 @@ class Gem::Specification
@@ -1301,7 +1301,7 @@ class Gem::Specification
# eg: /usr/local/lib/ruby/1.8/exts/mygem-1.0
def ext_dir
@ -257,7 +257,7 @@ diff --git a/lib/rubygems/defaults.rb b/lib/rubygems/defaults.rb
index 20b4198..6d8711f 100644
--- a/lib/rubygems/defaults.rb
+++ b/lib/rubygems/defaults.rb
@@ -87,6 +87,17 @@ module Gem
@@ -94,6 +94,17 @@ module Gem
end
##
@ -279,7 +279,7 @@ diff --git a/lib/rubygems/specification.rb b/lib/rubygems/specification.rb
index 8be2ade..f54210a 100644
--- a/lib/rubygems/specification.rb
+++ b/lib/rubygems/specification.rb
@@ -1287,10 +1287,7 @@ class Gem::Specification
@@ -1309,10 +1309,7 @@ class Gem::Specification
# gem directory. eg: /usr/local/lib/ruby/1.8/gems
def exts_dir