Update to Ruby 2.1.5.
This commit is contained in:
parent
79beb34d80
commit
1610d07dcd
@ -11,7 +11,7 @@ diff --git a/lib/mkmf.rb b/lib/mkmf.rb
|
|||||||
index 682eb46..e6b1445 100644
|
index 682eb46..e6b1445 100644
|
||||||
--- a/lib/mkmf.rb
|
--- a/lib/mkmf.rb
|
||||||
+++ b/lib/mkmf.rb
|
+++ b/lib/mkmf.rb
|
||||||
@@ -1828,7 +1828,7 @@ SRC
|
@@ -1829,7 +1829,7 @@ SRC
|
||||||
SHELL = /bin/sh
|
SHELL = /bin/sh
|
||||||
|
|
||||||
# V=0 quiet, V=1 verbose. other values don't work.
|
# V=0 quiet, V=1 verbose. other values don't work.
|
||||||
|
@ -38,7 +38,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 0e371e2..d4f1dcb 100644
|
index 0e371e2..d4f1dcb 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3841,6 +3841,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
@@ -3914,6 +3914,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||||
AC_SUBST(sitearchhdrdir)dnl
|
AC_SUBST(sitearchhdrdir)dnl
|
||||||
AC_SUBST(vendorarchhdrdir)dnl
|
AC_SUBST(vendorarchhdrdir)dnl
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 37d9a62..553d4d0 100644
|
index 37d9a62..553d4d0 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3071,6 +3071,11 @@ if test ${multiarch+set}; then
|
@@ -3143,6 +3143,11 @@ if test ${multiarch+set}; then
|
||||||
fi
|
fi
|
||||||
|
|
||||||
archlibdir='${libdir}/${arch}'
|
archlibdir='${libdir}/${arch}'
|
||||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 17ed3ed..5843651 100644
|
index 17ed3ed..5843651 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3645,8 +3645,6 @@ AS_CASE(["$target_os"],
|
@@ -3718,8 +3718,6 @@ AS_CASE(["$target_os"],
|
||||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -23,7 +23,7 @@ index 17ed3ed..5843651 100644
|
|||||||
|
|
||||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||||
AC_ARG_WITH(rubyarchprefix,
|
AC_ARG_WITH(rubyarchprefix,
|
||||||
@@ -3676,6 +3674,7 @@ AC_ARG_WITH(ruby-version,
|
@@ -3749,6 +3747,7 @@ AC_ARG_WITH(ruby-version,
|
||||||
[ruby_version=full])
|
[ruby_version=full])
|
||||||
unset RUBY_LIB_VERSION
|
unset RUBY_LIB_VERSION
|
||||||
unset RUBY_LIB_VERSION_STYLE
|
unset RUBY_LIB_VERSION_STYLE
|
||||||
@ -31,7 +31,7 @@ index 17ed3ed..5843651 100644
|
|||||||
AS_CASE(["$ruby_version"],
|
AS_CASE(["$ruby_version"],
|
||||||
[full], [RUBY_LIB_VERSION_STYLE='3 /* full */'],
|
[full], [RUBY_LIB_VERSION_STYLE='3 /* full */'],
|
||||||
[minor], [RUBY_LIB_VERSION_STYLE='2 /* minor */'])
|
[minor], [RUBY_LIB_VERSION_STYLE='2 /* minor */'])
|
||||||
@@ -3692,30 +3691,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
@@ -3765,30 +3764,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
||||||
ruby_version="`$CPP -I. -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
|
ruby_version="`$CPP -I. -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
|
||||||
eval $ruby_version
|
eval $ruby_version
|
||||||
elif test -z "${ruby_version}"; then
|
elif test -z "${ruby_version}"; then
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 553d4d0..03a4152 100644
|
index 553d4d0..03a4152 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3757,6 +3757,8 @@ AC_SUBST(vendorarchdir)dnl
|
@@ -3830,6 +3830,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||||
|
|
||||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 03a4152..0e371e2 100644
|
index 03a4152..0e371e2 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3731,6 +3731,10 @@ AC_ARG_WITH(vendorarchdir,
|
@@ -3804,6 +3804,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||||
[vendorarchdir=$withval],
|
[vendorarchdir=$withval],
|
||||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||||
|
|
||||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
|||||||
if test "${LOAD_RELATIVE+set}"; then
|
if test "${LOAD_RELATIVE+set}"; then
|
||||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||||
RUBY_EXEC_PREFIX=''
|
RUBY_EXEC_PREFIX=''
|
||||||
@@ -3754,6 +3754,7 @@ AC_SUBST(sitearchdir)dnl
|
@@ -3827,6 +3831,7 @@ AC_SUBST(sitearchdir)dnl
|
||||||
AC_SUBST(vendordir)dnl
|
AC_SUBST(vendordir)dnl
|
||||||
AC_SUBST(vendorlibdir)dnl
|
AC_SUBST(vendorlibdir)dnl
|
||||||
AC_SUBST(vendorarchdir)dnl
|
AC_SUBST(vendorarchdir)dnl
|
||||||
|
38
ruby-2.2.0-Don-t-use-obsolete-SSLv3-for-tests.patch
Normal file
38
ruby-2.2.0-Don-t-use-obsolete-SSLv3-for-tests.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From 75ca3a364e2e35a53a385eab08bebdcb08baeace Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||||
|
Date: Fri, 21 Nov 2014 16:02:52 +0100
|
||||||
|
Subject: [PATCH] Don't use obsolete SSLv3 for tests.
|
||||||
|
|
||||||
|
SSLv23 should be the most liberal settings according to upstream
|
||||||
|
documentation:
|
||||||
|
|
||||||
|
https://www.openssl.org/docs/ssl/SSL_CTX_new.html
|
||||||
|
---
|
||||||
|
test/openssl/test_ssl_session.rb | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/test/openssl/test_ssl_session.rb b/test/openssl/test_ssl_session.rb
|
||||||
|
index 8066ef1..2f3e578 100644
|
||||||
|
--- a/test/openssl/test_ssl_session.rb
|
||||||
|
+++ b/test/openssl/test_ssl_session.rb
|
||||||
|
@@ -273,7 +273,7 @@ __EOS__
|
||||||
|
|
||||||
|
def test_ctx_client_session_cb
|
||||||
|
called = {}
|
||||||
|
- ctx = OpenSSL::SSL::SSLContext.new("SSLv3")
|
||||||
|
+ ctx = OpenSSL::SSL::SSLContext.new
|
||||||
|
ctx.session_cache_mode = OpenSSL::SSL::SSLContext::SESSION_CACHE_CLIENT
|
||||||
|
|
||||||
|
ctx.session_new_cb = lambda { |ary|
|
||||||
|
@@ -345,7 +345,7 @@ __EOS__
|
||||||
|
last_client_session = nil
|
||||||
|
3.times do
|
||||||
|
sock = TCPSocket.new("127.0.0.1", port)
|
||||||
|
- ssl = OpenSSL::SSL::SSLSocket.new(sock, OpenSSL::SSL::SSLContext.new("SSLv3"))
|
||||||
|
+ ssl = OpenSSL::SSL::SSLSocket.new(sock, OpenSSL::SSL::SSLContext.new(:SSLv23_server))
|
||||||
|
ssl.sync_close = true
|
||||||
|
ssl.session = last_client_session if last_client_session
|
||||||
|
ssl.connect
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
15
ruby.spec
15
ruby.spec
@ -1,6 +1,6 @@
|
|||||||
%global major_version 2
|
%global major_version 2
|
||||||
%global minor_version 1
|
%global minor_version 1
|
||||||
%global teeny_version 4
|
%global teeny_version 5
|
||||||
%global major_minor_version %{major_version}.%{minor_version}
|
%global major_minor_version %{major_version}.%{minor_version}
|
||||||
|
|
||||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||||
@ -21,7 +21,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global release 24
|
%global release 25
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||||
|
|
||||||
%global rubygems_version 2.2.2
|
%global rubygems_version 2.2.2
|
||||||
@ -106,6 +106,9 @@ Patch5: ruby-1.9.3-mkmf-verbose.patch
|
|||||||
# in support for ABRT.
|
# in support for ABRT.
|
||||||
# http://bugs.ruby-lang.org/issues/8566
|
# http://bugs.ruby-lang.org/issues/8566
|
||||||
Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||||
|
# Test are broken due to SSLv3 disabled in Fedora.
|
||||||
|
# https://bugs.ruby-lang.org/issues/10046
|
||||||
|
Patch7: ruby-2.2.0-Don-t-use-obsolete-SSLv3-for-tests.patch
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -366,6 +369,7 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
|||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
|
%patch7 -p1
|
||||||
|
|
||||||
# Provide an example of usage of the tapset:
|
# Provide an example of usage of the tapset:
|
||||||
cp -a %{SOURCE3} .
|
cp -a %{SOURCE3} .
|
||||||
@ -566,6 +570,10 @@ sed -i '/^ def test_machine_stackoverflow/,/^ end/ s/^/#/' test/ruby/test_exce
|
|||||||
sed -i '/assert(OpenSSL::Cipher::Cipher.new(name).is_a?(OpenSSL::Cipher::Cipher))/i \
|
sed -i '/assert(OpenSSL::Cipher::Cipher.new(name).is_a?(OpenSSL::Cipher::Cipher))/i \
|
||||||
next if /wrap/ =~ name' test/openssl/test_cipher.rb
|
next if /wrap/ =~ name' test/openssl/test_cipher.rb
|
||||||
|
|
||||||
|
# Test is broken due to SSLv3 disabled in Fedora.
|
||||||
|
# https://bugs.ruby-lang.org/issues/10046
|
||||||
|
sed -i '/def test_ctx_server_session_cb$/,/^ end$/ s/^/#/' test/openssl/test_ssl_session.rb
|
||||||
|
|
||||||
make check TESTS="-v $DISABLE_TESTS"
|
make check TESTS="-v $DISABLE_TESTS"
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
@ -862,6 +870,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{ruby_libdir}/tkextlib
|
%{ruby_libdir}/tkextlib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 20 2014 Vít Ondruch <vondruch@redhat.com> - 2.1.5-25
|
||||||
|
- Update to Ruby 2.1.5.
|
||||||
|
|
||||||
* Fri Oct 31 2014 Vít Ondruch <vondruch@redhat.com> - 2.1.4-24
|
* Fri Oct 31 2014 Vít Ondruch <vondruch@redhat.com> - 2.1.4-24
|
||||||
- Update to Ruby 2.1.4.
|
- Update to Ruby 2.1.4.
|
||||||
- Include only vendor directories, not their content (rhbz#1114071).
|
- Include only vendor directories, not their content (rhbz#1114071).
|
||||||
|
Loading…
Reference in New Issue
Block a user