Update to Ruby 2.3.1
* Remove Patch8: ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch; subsumed * Remove Patch10: ruby-2.3.1-remove-tests-depending-on-europe-moscow.patch; subsumed also removed "UTC=TZ " tests prefix
This commit is contained in:
parent
be3f377da7
commit
026310447d
@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 0e371e2..d4f1dcb 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4334,6 +4334,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
@@ -4374,6 +4374,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
AC_SUBST(sitearchhdrdir)dnl
|
||||
AC_SUBST(vendorarchhdrdir)dnl
|
||||
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 37d9a62..553d4d0 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3592,6 +3592,11 @@ if test ${multiarch+set}; then
|
||||
@@ -3632,6 +3632,11 @@ if test ${multiarch+set}; then
|
||||
fi
|
||||
|
||||
archlibdir='${libdir}/${arch}'
|
||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
||||
index db37cd6..ce8d149 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4188,7 +4188,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
@@ -4228,7 +4228,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||
|
||||
if test -z "${ruby_version_dir_name}"; then
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 553d4d0..03a4152 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4252,6 +4252,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
@@ -4292,6 +4292,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||
|
||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 03a4152..0e371e2 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4224,6 +4224,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
@@ -4264,6 +4264,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4248,6 +4252,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4288,6 +4292,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
|
@ -12,7 +12,7 @@ diff --git a/Makefile.in b/Makefile.in
|
||||
index 76b61f5..2432884 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -307,7 +307,7 @@ reconfig config.status: $(srcdir)/$(CONFIGURE) $(srcdir)/enc/Makefile.in \
|
||||
@@ -309,7 +309,7 @@ reconfig config.status: $(srcdir)/$(CONFIGURE) $(srcdir)/enc/Makefile.in \
|
||||
@PWD= MINIRUBY="$(MINIRUBY)"; export MINIRUBY; \
|
||||
set $(SHELL) $($@-args); $(reconfig-exec-$(V))
|
||||
|
||||
|
@ -20,7 +20,7 @@ diff --git a/configure.in b/configure.in
|
||||
index db37cd6..6e73fae 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4137,9 +4137,6 @@ AS_CASE(["$target_os"],
|
||||
@@ -4177,9 +4177,6 @@ AS_CASE(["$target_os"],
|
||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||
])
|
||||
|
||||
@ -30,7 +30,7 @@ index db37cd6..6e73fae 100644
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
@@ -4162,58 +4159,64 @@ AC_ARG_WITH(ridir,
|
||||
@@ -4202,58 +4199,64 @@ AC_ARG_WITH(ridir,
|
||||
AC_SUBST(ridir)
|
||||
AC_SUBST(RI_BASE_NAME)
|
||||
|
||||
@ -124,7 +124,7 @@ index db37cd6..6e73fae 100644
|
||||
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
@@ -4230,6 +4233,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
@@ -4270,6 +4273,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
AC_SUBST(arch)dnl
|
||||
AC_SUBST(sitearch)dnl
|
||||
AC_SUBST(ruby_version)dnl
|
||||
@ -286,7 +286,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 6e73fae..c842725 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -274,7 +274,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
@@ -275,7 +275,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`
|
||||
AC_SUBST(RUBY_BASE_NAME)
|
||||
AC_SUBST(RUBYW_BASE_NAME)
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 98e565ec78cb4a07ffde8589ac4581fca31e9c17 Mon Sep 17 00:00:00 2001
|
||||
From: mrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Thu, 7 Jan 2016 13:35:32 +0000
|
||||
Subject: [PATCH] * ruby.h: undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
||||
and HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P on C++. [ruby-core:72736]
|
||||
[Bug #11962]
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53455 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
ChangeLog | 6 ++++++
|
||||
include/ruby/ruby.h | 7 +++++++
|
||||
2 files changed, 13 insertions(+)
|
||||
|
||||
diff --git a/include/ruby/ruby.h b/include/ruby/ruby.h
|
||||
index 7aabf5b..82dca14 100644
|
||||
--- a/include/ruby/ruby.h
|
||||
+++ b/include/ruby/ruby.h
|
||||
@@ -26,6 +26,13 @@ extern "C" {
|
||||
#include RUBY_EXTCONF_H
|
||||
#endif
|
||||
|
||||
+#if defined(__cplusplus)
|
||||
+/* __builtin_choose_expr and __builtin_types_compatible aren't available
|
||||
+ * on C++. See https://gcc.gnu.org/onlinedocs/gcc/Other-Builtins.html */
|
||||
+# undef HAVE_BUILTIN___BUILTIN_CHOOSE_EXPR_CONSTANT_P
|
||||
+# undef HAVE_BUILTIN___BUILTIN_TYPES_COMPATIBLE_P
|
||||
+#endif
|
||||
+
|
||||
#include "defines.h"
|
||||
|
||||
#define NORETURN_STYLE_NEW 1
|
@ -1,60 +0,0 @@
|
||||
From c5c60ded6dbb6256640b0308a45c42da8c7fe071 Mon Sep 17 00:00:00 2001
|
||||
From: akr <akr@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Fri, 22 Apr 2016 12:20:06 +0000
|
||||
Subject: [PATCH] * test/ruby/test_time_tz.rb: Tests depends on Europe/Moscow
|
||||
removed to avoid test failures due to the tzdata change.
|
||||
https://github.com/eggert/tz/commit/8ee11a301cf173afb0c76e0315b9f9ec8ebb9d95
|
||||
Found by naruse.
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@54706 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
ChangeLog | 7 +++++++
|
||||
test/ruby/test_time_tz.rb | 13 -------------
|
||||
2 files changed, 7 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 3b96a9b..965f296 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,10 @@
|
||||
+Fri Apr 22 21:00:44 2016 Tanaka Akira <akr@fsij.org>
|
||||
+
|
||||
+ * test/ruby/test_time_tz.rb: Tests depends on Europe/Moscow removed
|
||||
+ to avoid test failures due to the tzdata change.
|
||||
+ https://github.com/eggert/tz/commit/8ee11a301cf173afb0c76e0315b9f9ec8ebb9d95
|
||||
+ Found by naruse.
|
||||
+
|
||||
Thu Dec 24 23:01:57 2015 SHIBATA Hiroshi <hsbt@ruby-lang.org>
|
||||
|
||||
* NEWS: added entry for CGI.escapeHTML optimization.
|
||||
diff --git a/test/ruby/test_time_tz.rb b/test/ruby/test_time_tz.rb
|
||||
index f5d4690..b40b1ac 100644
|
||||
--- a/test/ruby/test_time_tz.rb
|
||||
+++ b/test/ruby/test_time_tz.rb
|
||||
@@ -170,13 +170,6 @@ def test_europe_lisbon
|
||||
}
|
||||
end if has_lisbon_tz
|
||||
|
||||
- def test_europe_moscow
|
||||
- with_tz(tz="Europe/Moscow") {
|
||||
- assert_time_constructor(tz, "1992-03-29 00:00:00 +0400", :local, [1992,3,28,23,0,0])
|
||||
- assert_time_constructor(tz, "1992-03-29 00:59:59 +0400", :local, [1992,3,28,23,59,59])
|
||||
- }
|
||||
- end
|
||||
-
|
||||
def test_pacific_kiritimati
|
||||
with_tz(tz="Pacific/Kiritimati") {
|
||||
assert_time_constructor(tz, "1994-12-31 23:59:59 -1000", :local, [1994,12,31,23,59,59])
|
||||
@@ -356,12 +349,6 @@ def self.gen_zdump_test(data)
|
||||
Europe/London Sun Aug 10 01:00:00 1947 UTC = Sun Aug 10 02:00:00 1947 BST isdst=1 gmtoff=3600
|
||||
Europe/London Sun Nov 2 01:59:59 1947 UTC = Sun Nov 2 02:59:59 1947 BST isdst=1 gmtoff=3600
|
||||
Europe/London Sun Nov 2 02:00:00 1947 UTC = Sun Nov 2 02:00:00 1947 GMT isdst=0 gmtoff=0
|
||||
-Europe/Moscow Sat Jan 18 23:59:59 1992 UTC = Sun Jan 19 01:59:59 1992 MSK isdst=0 gmtoff=7200
|
||||
-Europe/Moscow Sun Jan 19 00:00:00 1992 UTC = Sun Jan 19 03:00:00 1992 MSK isdst=0 gmtoff=10800
|
||||
-Europe/Moscow Sat Mar 28 19:59:59 1992 UTC = Sat Mar 28 22:59:59 1992 MSK isdst=0 gmtoff=10800
|
||||
-Europe/Moscow Sat Mar 28 20:00:00 1992 UTC = Sun Mar 29 00:00:00 1992 MSD isdst=1 gmtoff=14400
|
||||
-Europe/Moscow Sat Sep 26 18:59:59 1992 UTC = Sat Sep 26 22:59:59 1992 MSD isdst=1 gmtoff=14400
|
||||
-Europe/Moscow Sat Sep 26 19:00:00 1992 UTC = Sat Sep 26 22:00:00 1992 MSK isdst=0 gmtoff=10800
|
||||
Pacific/Kiritimati Sun Jan 1 09:59:59 1995 UTC = Sat Dec 31 23:59:59 1994 LINT isdst=0 gmtoff=-36000
|
||||
Pacific/Kiritimati Sun Jan 1 10:00:00 1995 UTC = Mon Jan 2 00:00:00 1995 LINT isdst=0 gmtoff=50400
|
||||
End
|
27
ruby.spec
27
ruby.spec
@ -3,7 +3,7 @@
|
||||
|
||||
%global major_version 2
|
||||
%global minor_version 3
|
||||
%global teeny_version 0
|
||||
%global teeny_version 1
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -58,10 +58,6 @@
|
||||
|
||||
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
|
||||
|
||||
%if 0%{?fedora} >= 19
|
||||
%global with_rubypick 1
|
||||
%endif
|
||||
|
||||
Summary: An interpreter of object-oriented scripting language
|
||||
Name: %{?scl_prefix}ruby
|
||||
Version: %{ruby_version}
|
||||
@ -125,16 +121,9 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# Use miniruby to regenerate prelude.c.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# 98e565ec78cb4a07ffde8589ac4581fca31e9c17
|
||||
# https://bugs.ruby-lang.org/issues/11962
|
||||
# https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/53455
|
||||
Patch8: ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch
|
||||
# Disable colorized ./configure due to missing macro AS_FUNCTION_DESCRIBE in Autoconf
|
||||
# http://git.savannah.gnu.org/cgit/autoconf.git/tree/lib/m4sugar/m4sh.m4?id=d99fef0e1e8e7a4c04b97fc4c6e0ffb01463622c
|
||||
Patch9: ruby-2.3.0-Disable-colorized-configure.patch
|
||||
# Remove tests depending on europe/moscow to avoid failures due to tzdata change
|
||||
# https://github.com/eggert/tz/commit/8ee11a301cf173afb0c76e0315b9f9ec8ebb9d95
|
||||
Patch10: ruby-2.3.1-remove-tests-depending-on-europe-moscow.patch
|
||||
|
||||
Requires: %{?scl_prefix}%{pkg_name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: %{?scl_prefix}ruby(rubygems) >= %{rubygems_version}
|
||||
@ -474,9 +463,7 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
# Allow to use autoconf 2.63.
|
||||
sed -i '/AC_PREREQ/ s/(.*)/(2.62)/' configure.in
|
||||
@ -670,7 +657,7 @@ DISABLE_TESTS=""
|
||||
# Once seen: http://koji.fedoraproject.org/koji/taskinfo?taskID=12556650
|
||||
DISABLE_TESTS="$DISABLE_TESTS -x test_fork.rb"
|
||||
|
||||
TZ=UTC make check TESTS="-v $DISABLE_TESTS"
|
||||
make check TESTS="-v $DISABLE_TESTS"
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
@ -883,8 +870,6 @@ TZ=UTC make check TESTS="-v $DISABLE_TESTS"
|
||||
%config(noreplace) %{_root_sysconfdir}/rpm/macros.rubygems%{?scl:.%{scl}}
|
||||
|
||||
%files -n %{?scl_prefix}rubygem-rake
|
||||
# TODO: file is missing
|
||||
#%{ruby_libdir}/rake*
|
||||
%{_bindir}/rake
|
||||
%{gem_dir}/gems/rake-%{rake_version}
|
||||
%{gem_dir}/specifications/rake-%{rake_version}.gemspec
|
||||
@ -973,8 +958,14 @@ TZ=UTC make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Fri Aug 12 2016 Pavel Valena <pvalena@redhat.com> - 2.3.0-62
|
||||
* Fri Aug 12 2016 Pavel Valena <pvalena@redhat.com> - 2.3.1-62
|
||||
- Fix support for dependent^2 SCLs
|
||||
- Update to Ruby 2.3.1
|
||||
* Remove Patch8:
|
||||
ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch; subsumed
|
||||
* Remove Patch10:
|
||||
ruby-2.3.1-remove-tests-depending-on-europe-moscow.patch; subsumed
|
||||
also removed "UTC=TZ " tests prefix
|
||||
|
||||
* Mon Jul 25 2016 Pavel Valena <pvalena@redhat.com> - 2.3.0-61
|
||||
- Add %%{scl}-runtime to Requires in libs subpackage
|
||||
|
Loading…
Reference in New Issue
Block a user