- Again use -O2 optimization level
- i586 should search i386-linux directory
This commit is contained in:
parent
281b4a6f51
commit
01a3f0d013
11
ruby-always-use-i386.patch
Normal file
11
ruby-always-use-i386.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ruby-1.8.6-p287/configure.in.i386 2009-03-16 00:55:15.000000000 +0900
|
||||||
|
+++ ruby-1.8.6-p287/configure.in 2009-03-16 01:42:41.000000000 +0900
|
||||||
|
@@ -1662,6 +1662,8 @@
|
||||||
|
configure_args=$ac_configure_args
|
||||||
|
AC_SUBST(configure_args)dnl
|
||||||
|
|
||||||
|
+target_cpu=`echo $target_cpu | sed s/i.86/i386/`
|
||||||
|
+
|
||||||
|
if test "$fat_binary" != no ; then
|
||||||
|
arch="fat-${target_os}"
|
||||||
|
|
12
ruby.spec
12
ruby.spec
@ -8,11 +8,11 @@
|
|||||||
# This is required to ensure that noarch files puts under /usr/lib/... for
|
# This is required to ensure that noarch files puts under /usr/lib/... for
|
||||||
# multilib because ruby library is installed under /usr/{lib,lib64}/ruby anyway.
|
# multilib because ruby library is installed under /usr/{lib,lib64}/ruby anyway.
|
||||||
%define sitedir2 %{_prefix}/lib/ruby/site_ruby
|
%define sitedir2 %{_prefix}/lib/ruby/site_ruby
|
||||||
%define _normalized_cpu %(echo `echo %{_target_cpu} | sed 's/^ppc/powerpc/'`)
|
%define _normalized_cpu %(echo `echo %{_target_cpu} | sed 's/^ppc/powerpc/' | sed -e 's|i.86|i386|'`)
|
||||||
|
|
||||||
Name: ruby
|
Name: ruby
|
||||||
Version: %{rubyver}%{?dotpatchlevel}
|
Version: %{rubyver}%{?dotpatchlevel}
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: Ruby or GPLv2
|
License: Ruby or GPLv2
|
||||||
URL: http://www.ruby-lang.org/
|
URL: http://www.ruby-lang.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -37,6 +37,7 @@ Patch25: ruby-1.8.6.111-gcc43.patch
|
|||||||
Patch26: ruby-1.8.6-rexml-CVE-2008-3790.patch
|
Patch26: ruby-1.8.6-rexml-CVE-2008-3790.patch
|
||||||
Patch27: ruby-1.8.6-p287-CVE-2008-5189.patch
|
Patch27: ruby-1.8.6-p287-CVE-2008-5189.patch
|
||||||
Patch28: ruby-1.8.6-p287-remove-ssl-rand-range.patch
|
Patch28: ruby-1.8.6-p287-remove-ssl-rand-range.patch
|
||||||
|
Patch29: ruby-always-use-i386.patch
|
||||||
|
|
||||||
Summary: An interpreter of object-oriented scripting language
|
Summary: An interpreter of object-oriented scripting language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -158,6 +159,7 @@ pushd %{name}-%{arcver}
|
|||||||
%patch26 -p1
|
%patch26 -p1
|
||||||
%patch27 -p0
|
%patch27 -p0
|
||||||
%patch28 -p1
|
%patch28 -p1
|
||||||
|
%patch29 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -169,7 +171,7 @@ autoconf
|
|||||||
|
|
||||||
rb_cv_func_strtod=no
|
rb_cv_func_strtod=no
|
||||||
export rb_cv_func_strtod
|
export rb_cv_func_strtod
|
||||||
CFLAGS="$RPM_OPT_FLAGS -Wall -O0 -fno-strict-aliasing"
|
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||||
export CFLAGS
|
export CFLAGS
|
||||||
%configure \
|
%configure \
|
||||||
--with-sitedir='%{sitedir}' \
|
--with-sitedir='%{sitedir}' \
|
||||||
@ -510,6 +512,10 @@ rm -rf tmp-ruby-docs
|
|||||||
%{_datadir}/emacs/site-lisp/site-start.d/ruby-mode-init.el
|
%{_datadir}/emacs/site-lisp/site-start.d/ruby-mode-init.el
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 16 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.8.6.287-6
|
||||||
|
- Again use -O2 optimization level
|
||||||
|
- i586 should search i386-linux directory
|
||||||
|
|
||||||
* Thu Mar 05 2009 Jeroen van Meeuwen <kanarip@fedoraproject.org> - 1.8.6.287-5
|
* Thu Mar 05 2009 Jeroen van Meeuwen <kanarip@fedoraproject.org> - 1.8.6.287-5
|
||||||
- Rebuild for gcc4.4
|
- Rebuild for gcc4.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user