947b598027
Resolves: rhbz#1213035 - Dropped autoconf and doc-fix patches (all upstreamed) - Included systemd rrdcached service and socket from upstream - General documentation (like NEWS) moved to basic package
27 lines
1.2 KiB
Diff
27 lines
1.2 KiB
Diff
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
|
|
index 76e9144..bdfee3b 100644
|
|
--- a/bindings/Makefile.am
|
|
+++ b/bindings/Makefile.am
|
|
@@ -30,8 +30,9 @@ install-data-local:
|
|
&& $(MAKE) install ) \
|
|
|| true
|
|
$(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
|
|
- && ( cd ${builddir}/ruby \
|
|
- && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install ) \
|
|
+ && ( $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ${builddir}/ruby \
|
|
+ && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) \
|
|
+ hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install ) \
|
|
|| true
|
|
$(AM_V_GEN)test -d ${builddir}/python/build \
|
|
&& ( cd ${builddir}/python \
|
|
@@ -52,7 +53,8 @@ ruby:
|
|
EPREFIX=$(exec_prefix) \
|
|
ABS_TOP_SRCDIR=${abs_top_srcdir} \
|
|
ABS_TOP_BUILDDIR=${abs_top_builddir} \
|
|
- $(RUBY_MAKE_OPTIONS) RUBYARCHDIR= )
|
|
+ $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" \
|
|
+ rubyhdrdir="$(includedir)" includedir="$(includedir)" RUBYARCHDIR= )
|
|
|
|
# rules for building the pyton module
|
|
python:
|