New version

Resolves: rhbz#1213035
- Dropped autoconf and doc-fix patches (all upstreamed)
- Included systemd rrdcached service and socket from upstream
- General documentation (like NEWS) moved to basic package
This commit is contained in:
Jaroslav Škarvada 2015-04-21 11:56:18 +02:00
parent 37ced68a17
commit 947b598027
9 changed files with 127 additions and 442 deletions

View File

@ -1,21 +0,0 @@
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index c4fdc10..247fe58 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -22,14 +22,12 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
$(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
$(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
- $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ $(AM_V_GEN)test -f ruby/Makefile && $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install || true
$(AM_V_GEN)test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
# rules for building the ruby module
-# RUBYARCHDIR= is to work around in a makefile quirk not sure
-# it is is the right thing todo, but it makes rrdtool build on freebsd as well
ruby: Makefile
- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) RUBYARCHDIR=
+ cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)"
# rules for building the pyton module
python: Makefile

View File

@ -1,29 +0,0 @@
diff --git a/bindings/tcl/Makefile.am b/bindings/tcl/Makefile.am
index 265191d..35ce191 100644
--- a/bindings/tcl/Makefile.am
+++ b/bindings/tcl/Makefile.am
@@ -27,8 +27,9 @@ tclpkgdir = @TCL_PACKAGE_DIR@
tclpkg_DATA = pkgIndex.tcl
tclpkg_SCRIPTS = ifOctets.tcl
else
-pkgdata_DATA = pkgIndex.tcl
-pkgdata_SCRIPTS = ifOctets.tcl
+pkgindexdir = $(pkglibdir)
+pkgindex_DATA = pkgIndex.tcl
+pkgindex_SCRIPTS = ifOctets.tcl
endif
# Automake doen't like `tclrrd$(VERSION)$(TCL_SHLIB_SUFFIX)' as
diff --git a/configure.ac b/configure.ac
index 9e93459..3ef1bef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -774,7 +774,7 @@ LUA_EOF
done
fi
- LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+ LUA_RRD_LIBDIR="$libdir/lua/$lua_vdot"
# if lua 5.0 can't find compat-5.1, force installation of
# compat-5.1.lua together with RRDtool.
if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then

View File

@ -1,298 +0,0 @@
diff --git a/doc/rrdtool.1 b/doc/rrdtool.1
index 0e9c3ca..10079cc 100644
--- a/doc/rrdtool.1
+++ b/doc/rrdtool.1
@@ -187,6 +187,10 @@ Operationally equivalent to \fBupdate\fR except for output. Check rrdupdate.
.IX Item "graph"
Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check rrdgraph.
+.IP "\fBgraphv\fR" 8
+.IX Item "graphv"
+Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check rrdgraph.
.IP "\fBdump\fR" 8
.IX Item "dump"
Dump the contents of an \s-1RRD\s0 in plain \s-1ASCII.\s0 In connection with restore
@@ -202,13 +206,20 @@ uses fetch to retrieve its data from an \s-1RRD.\s0 Check rrdfetch.
.IP "\fBtune\fR" 8
.IX Item "tune"
Alter setup of an \s-1RRD.\s0 Check rrdtune.
+.IP "\fBfirst\fR" 8
+.IX Item "first"
+Find the first update time of an \s-1RRD\s0. Check rrdfirst.
.IP "\fBlast\fR" 8
.IX Item "last"
Find the last update time of an \s-1RRD.\s0 Check rrdlast.
+.IP "\fBlastupdate\fR" 8
+.IX Item "lastupdate"
+Find the last update time of an \s-1RRD\s0. It also returns the value stored for each
+datum in the most recent update. Check rrdlastupdate.
.IP "\fBinfo\fR" 8
.IX Item "info"
Get information about an \s-1RRD.\s0 Check rrdinfo.
-.IP "\fBrrdresize\fR" 8
+.IP "\fBresize\fR" 8
.IX Item "rrdresize"
Change the size of individual RRAs. This is dangerous! Check rrdresize.
.IP "\fBxport\fR" 8
@@ -217,10 +228,6 @@ Export data retrieved from one or several RRDs. Check rrdxport.
.IP "\fBflushcached\fR" 8
.IX Item "flushcached"
Flush the values for a specific \s-1RRD\s0 file from memory. Check rrdflushcached.
-.IP "\fBrrdcgi\fR" 8
-.IX Item "rrdcgi"
-This is a standalone tool for producing \s-1RRD\s0 graphs on the fly. Check
-rrdcgi.
.SS "\s-1HOW DOES RRDTOOL WORK\s0?"
.IX Subsection "HOW DOES RRDTOOL WORK?"
.IP "Data Acquisition" 8
diff --git a/doc/rrdtool.html b/doc/rrdtool.html
index 404b140..5c40029 100644
--- a/doc/rrdtool.html
+++ b/doc/rrdtool.html
@@ -59,6 +59,13 @@
<p>Create a graph from data stored in one or several RRDs. Apart from generating graphs, data can also be extracted to stdout. Check <a href="./rrdgraph.html">rrdgraph</a>.</p>
</dd>
+<dt><strong><a name="graphv" class="item"><strong>graphv</strong></a></strong></dt>
+
+<dd>
+<p>Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check <a href="././rrdgraph.html">the rrdgraph manpage</a>.</p>
+</dd>
+
<dt id="dump"><b>dump</b></dt>
<dd>
@@ -83,19 +90,31 @@
<p>Alter setup of an RRD. Check <a href="./rrdtune.html">rrdtune</a>.</p>
</dd>
+<dt><strong><a name="first" class="item"><strong>first</strong></a></strong></dt>
+
+<dd>
+<p>Find the first update time of an RRD. Check <a href="././rrdfirst.html">the rrdfirst manpage</a>.</p>
+</dd>
<dt id="last"><b>last</b></dt>
<dd>
<p>Find the last update time of an RRD. Check <a href="./rrdlast.html">rrdlast</a>.</p>
</dd>
+<dt><strong><a name="lastupdate" class="item"><strong>lastupdate</strong></a></strong></dt>
+
+<dd>
+<p>Find the last update time of an RRD. It also returns the value stored for each
+datum in the most recent update. Check <a href="././rrdlastupdate.html">the rrdlastupdate manpage</a>.</p>
+</dd>
+
<dt id="info"><b>info</b></dt>
<dd>
<p>Get information about an RRD. Check <a href="./rrdinfo.html">rrdinfo</a>.</p>
</dd>
-<dt id="rrdresize"><b>rrdresize</b></dt>
+<dt id="resize"><b>rrdresize</b></dt>
<dd>
<p>Change the size of individual RRAs. This is dangerous! Check <a href="./rrdresize.html">rrdresize</a>.</p>
@@ -113,12 +132,6 @@
<p>Flush the values for a specific RRD file from memory. Check <a href="./rrdflushcached.html">rrdflushcached</a>.</p>
</dd>
-<dt id="rrdcgi"><b>rrdcgi</b></dt>
-<dd>
-
-<p>This is a standalone tool for producing RRD graphs on the fly. Check <a href="./rrdcgi.html">rrdcgi</a>.</p>
-
-</dd>
</dl>
<h2 id="HOW-DOES-RRDTOOL-WORK">HOW DOES RRDTOOL WORK?</h2>
diff --git a/doc/rrdtool.pod b/doc/rrdtool.pod
index 14394cf..fc31478 100644
--- a/doc/rrdtool.pod
+++ b/doc/rrdtool.pod
@@ -58,6 +58,11 @@ Operationally equivalent to B<update> except for output. Check L<rrdupdate>.
Create a graph from data stored in one or several RRDs. Apart from
generating graphs, data can also be extracted to stdout. Check L<rrdgraph>.
+=item B<graphv>
+
+Create a graph from data stored in one or several RRDs. Same as graph, but
+metadata are printed before the graph. Check L<rrdgraph>.
+
=item B<dump>
Dump the contents of an RRD in plain ASCII. In connection with restore
@@ -77,15 +82,24 @@ uses fetch to retrieve its data from an RRD. Check L<rrdfetch>.
Alter setup of an RRD. Check L<rrdtune>.
+=item B<first>
+
+Find the first update time of an RRD. Check L<rrdfirst>.
+
=item B<last>
Find the last update time of an RRD. Check L<rrdlast>.
+=item B<lastupdate>
+
+Find the last update time of an RRD. It also returns the value stored
+for each datum in the most recent update. Check L<rrdlastupdate>.
+
=item B<info>
Get information about an RRD. Check L<rrdinfo>.
-=item B<rrdresize>
+=item B<resize>
Change the size of individual RRAs. This is dangerous! Check L<rrdresize>.
@@ -97,11 +111,6 @@ Export data retrieved from one or several RRDs. Check L<rrdxport>.
Flush the values for a specific RRD file from memory. Check L<rrdflushcached>.
-=item B<rrdcgi>
-
-This is a standalone tool for producing RRD graphs on the fly. Check
-L<rrdcgi>.
-
=back
=head2 HOW DOES RRDTOOL WORK?
diff --git a/doc/rrdtool.txt b/doc/rrdtool.txt
index 1505291..e90d29b 100644
--- a/doc/rrdtool.txt
+++ b/doc/rrdtool.txt
@@ -48,6 +48,10 @@ DDEESSCCRRIIPPTTIIOONN
from generating graphs, data can also be extracted to stdout.
Check rrdgraph.
+ ggrraapphhvv Create a graph from data stored in one or several RRDs. Same as graph, but
+ metadata are printed before the graph..
+ Check rrdgraph.
+
dduummpp Dump the contents of an RRD in plain ASCII. In connection with
restore you can use this to move an RRD from one computer
architecture to another. Check rrddump.
@@ -60,11 +64,17 @@ DDEESSCCRRIIPPTTIIOONN
ttuunnee Alter setup of an RRD. Check rrdtune.
+ ffiirrsstt Find the first update time of an RRD. Check rrdfirst.
+
llaasstt Find the last update time of an RRD. Check rrdlast.
+ llaassttuuppddaattee Find the last update time of an RRD.
+ It also returns the value stored for each datum in the most recent update.
+ Check rrdlastupdate.
+
iinnffoo Get information about an RRD. Check rrdinfo.
- rrrrddrreessiizzee
+ rreessiizzee
Change the size of individual RRAs. This is dangerous! Check
rrdresize.
@@ -74,9 +84,6 @@ DDEESSCCRRIIPPTTIIOONN
Flush the values for a specific RRD file from memory. Check
rrdflushcached.
- rrrrddccggii This is a standalone tool for producing RRD graphs on the fly.
- Check rrdcgi.
-
HHOOWW DDOOEESS RRRRDDTTOOOOLL WWOORRKK??
Data Acquisition
When monitoring the state of a system, it is convenient to have
diff --git a/doc/rrdupdate.1 b/doc/rrdupdate.1
index 85e19c8..6fb87b2 100644
--- a/doc/rrdupdate.1
+++ b/doc/rrdupdate.1
@@ -144,7 +144,7 @@ rrdupdate \- Store a new set of values into the RRD
.IX Header "SYNOPSIS"
\&\fBrrdtool\fR {\fBupdate\fR | \fBupdatev\fR} \fIfilename\fR
[\fB\-\-template\fR|\fB\-t\fR\ \fIds-name\fR[\fB:\fR\fIds-name\fR]...]
-[\fB\-\-daemon\fR\ \fIaddress\fR] [\fB\-\-\fR]
+[\fB\-\-daemon\fR|\fB\-d\fR\ \fIaddress\fR] [\fB\-\-\fR]
\&\fBN\fR|\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
\&\fIat-timestamp\fR\fB@\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]
[\fItimestamp\fR\fB:\fR\fIvalue\fR[\fB:\fR\fIvalue\fR...]\ ...]
@@ -191,7 +191,7 @@ Do not specify a value for a \s-1COMPUTE \s0\fB\s-1DST\s0\fR in the \fBupdate\fR
function. If this is done accidentally (and this can only be done
using the template switch), \fBRRDtool\fR will ignore the value specified
for the \s-1COMPUTE \s0\fB\s-1DST\s0\fR.
-.IP "\fB\-\-daemon\fR \fIaddress\fR" 8
+.IP "\fB\-\-daemon\fR|\fB\-d\fR\ \fIaddress\fR" 8
.IX Item "--daemon address"
If given, \fBRRDTool\fR will try to connect to the caching daemon rrdcached
at \fIaddress\fR and will fail if the connection cannot be established. If the
diff --git a/doc/rrdupdate.html b/doc/rrdupdate.html
index 4f88d02..b5161e3 100644
--- a/doc/rrdupdate.html
+++ b/doc/rrdupdate.html
@@ -17,7 +17,7 @@
<h1 id="SYNOPSIS">SYNOPSIS</h1>
-<p><b>rrdtool</b> {<b>update</b> | <b>updatev</b>} <i>filename</i> <span style="white-space: nowrap;">[<b>--template</b>|<b>-t</b> <i>ds-name</i>[<b>:</b><i>ds-name</i>]...]</span> <span style="white-space: nowrap;">[<b>--daemon</b> <i>address</i>]</span> [<b>--</b>] <span style="white-space: nowrap;"><b>N</b>|<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;"><i>at-timestamp</i><b>@</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;">[<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...] ...]</span></p>
+<p><b>rrdtool</b> {<b>update</b> | <b>updatev</b>} <i>filename</i> <span style="white-space: nowrap;">[<b>--template</b>|<b>-t</b> <i>ds-name</i>[<b>:</b><i>ds-name</i>]...]</span> <span style="white-space: nowrap;">[<b>--daemon</b>|<b>-d</b> <i>address</i>]</span> [<b>--</b>] <span style="white-space: nowrap;"><b>N</b>|<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;"><i>at-timestamp</i><b>@</b><i>value</i>[<b>:</b><i>value</i>...]</span> <span style="white-space: nowrap;">[<i>timestamp</i><b>:</b><i>value</i>[<b>:</b><i>value</i>...] ...]</span></p>
<h1 id="DESCRIPTION">DESCRIPTION</h1>
@@ -51,7 +51,7 @@
<p>Do not specify a value for a COMPUTE <b>DST</b> in the <b>update</b> function. If this is done accidentally (and this can only be done using the template switch), <b>RRDtool</b> will ignore the value specified for the COMPUTE <b>DST</b>.</p>
</dd>
-<dt id="daemon-address"><b>--daemon</b> <i>address</i></dt>
+<dt id="daemon-address"><b>--daemon</b>|<b>-d</b> <i>address</i></dt>
<dd>
<p>If given, <b>RRDTool</b> will try to connect to the caching daemon <a href="./rrdcached.html">rrdcached</a> at <i>address</i> and will fail if the connection cannot be established. If the connection is successfully established the values will be sent to the daemon instead of accessing the files directly.</p>
diff --git a/doc/rrdupdate.pod b/doc/rrdupdate.pod
index d09e5f0..ffdbdbc 100644
--- a/doc/rrdupdate.pod
+++ b/doc/rrdupdate.pod
@@ -6,7 +6,7 @@ rrdupdate - Store a new set of values into the RRD
B<rrdtool> {B<update> | B<updatev>} I<filename>
S<[B<--template>|B<-t> I<ds-name>[B<:>I<ds-name>]...]>
-S<[B<--daemon> I<address>]> [B<-->]
+S<[B<--daemon>|B<-d> I<address>]> [B<-->]
S<B<N>|I<timestamp>B<:>I<value>[B<:>I<value>...]>
S<I<at-timestamp>B<@>I<value>[B<:>I<value>...]>
S<[I<timestamp>B<:>I<value>[B<:>I<value>...] ...]>
@@ -60,7 +60,7 @@ function. If this is done accidentally (and this can only be done
using the template switch), B<RRDtool> will ignore the value specified
for the COMPUTE B<DST>.
-=item B<--daemon> I<address>
+=item B<--daemon>|B<-d> I<address>
If given, B<RRDTool> will try to connect to the caching daemon L<rrdcached>
at I<address> and will fail if the connection cannot be established. If the
diff --git a/doc/rrdupdate.txt b/doc/rrdupdate.txt
index 083c13f..dc66440 100644
--- a/doc/rrdupdate.txt
+++ b/doc/rrdupdate.txt
@@ -7,7 +7,7 @@ NNAAMMEE
SSYYNNOOPPSSIISS
rrrrddttooooll {uuppddaattee | uuppddaatteevv} _f_i_l_e_n_a_m_e [----tteemmppllaattee|--tt _d_s_-_n_a_m_e[::_d_s_-
- _n_a_m_e]...] [----ddaaeemmoonn _a_d_d_r_e_s_s] [----] NN|_t_i_m_e_s_t_a_m_p::_v_a_l_u_e[::_v_a_l_u_e...] _a_t_-
+ _n_a_m_e]...] [----ddaaeemmoonn|--dd _a_d_d_r_e_s_s] [----] NN|_t_i_m_e_s_t_a_m_p::_v_a_l_u_e[::_v_a_l_u_e...] _a_t_-
_t_i_m_e_s_t_a_m_p@@_v_a_l_u_e[::_v_a_l_u_e...] [_t_i_m_e_s_t_a_m_p::_v_a_l_u_e[::_v_a_l_u_e...] ...]
DDEESSCCRRIIPPTTIIOONN
@@ -54,7 +54,7 @@ DDEESSCCRRIIPPTTIIOONN
done using the template switch), RRRRDDttooooll will ignore the value
specified for the COMPUTE DDSSTT.
- ----ddaaeemmoonn _a_d_d_r_e_s_s
+ ----ddaaeemmoonn|--dd _a_d_d_r_e_s_s
If given, RRRRDDTTooooll will try to connect to the caching daemon
rrdcached at _a_d_d_r_e_s_s and will fail if the connection cannot be
established. If the connection is successfully established the

View File

@ -1,68 +0,0 @@
diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
index 690ba29..839833a 100644
--- a/bindings/lua/rrdlua.c
+++ b/bindings/lua/rrdlua.c
@@ -342,7 +342,7 @@ set_info (lua_State * L)
/**********************************************************/
-static const struct luaL_reg rrd[] = {
+static const struct luaL_Reg rrd[] = {
{"create", lua_rrd_create},
{"dump", lua_rrd_dump},
{"fetch", lua_rrd_fetch},
diff --git a/configure.ac b/configure.ac
index 3ef1bef..187e127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -736,7 +736,12 @@ LUA_EOF
LIBS=
lua_havelib=no
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
+ if test "$lua_vndot" -ge "52"; then
+ CALL_FUNC=lua_callk
+ else
+ CALL_FUNC=lua_call
+ fi
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
[lua_havelib=LUA$lua_vndot],
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,
diff --git a/rrdtool-1.4.7-lua-5.2.patch b/rrdtool-1.4.7-lua-5.2.patch
new file mode 100644
index 0000000..f597371
--- /dev/null
+++ b/rrdtool-1.4.7-lua-5.2.patch
@@ -0,0 +1,31 @@
+diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
+index 690ba29..839833a 100644
+--- a/bindings/lua/rrdlua.c
++++ b/bindings/lua/rrdlua.c
+@@ -342,7 +342,7 @@ set_info (lua_State * L)
+
+ /**********************************************************/
+
+-static const struct luaL_reg rrd[] = {
++static const struct luaL_Reg rrd[] = {
+ {"create", lua_rrd_create},
+ {"dump", lua_rrd_dump},
+ {"fetch", lua_rrd_fetch},
+diff --git a/configure.ac b/configure.ac
+index 2ff18a8..4993717 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -734,7 +734,12 @@ LUA_EOF
+ LIBS=
+ lua_havelib=no
+ LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
+- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
++ if test "$lua_vndot" -ge "52"; then
++ CALL_FUNC=lua_callk
++ else
++ CALL_FUNC=lua_call
++ fi
++ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
+ [AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
+ [lua_havelib=LUA$lua_vndot],
+ [AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,

View File

@ -0,0 +1,40 @@
diff --git a/bindings/lua/rrdlua.c b/bindings/lua/rrdlua.c
index bfbc174..b54f787 100644
--- a/bindings/lua/rrdlua.c
+++ b/bindings/lua/rrdlua.c
@@ -350,7 +350,7 @@ set_info (lua_State * L)
/**********************************************************/
-static const struct luaL_reg rrd[] = {
+static const struct luaL_Reg rrd[] = {
{"create", lua_rrd_create},
{"dump", lua_rrd_dump},
{"fetch", lua_rrd_fetch},
diff --git a/configure.ac b/configure.ac
index 6d277bf..d0d9ea0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -810,7 +810,12 @@ LUA_EOF
LIBS=
lua_havelib=no
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
+ if test "$lua_vndot" -ge "52"; then
+ CALL_FUNC=lua_callk
+ else
+ CALL_FUNC=lua_call
+ fi
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
[lua_havelib=LUA$lua_vndot],
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,
@@ -853,7 +853,7 @@ LUA_EOF
done
fi
- LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+ LUA_RRD_LIBDIR="$libdir/lua/$lua_vdot"
# if lua 5.0 can't find compat-5.1, force installation of
# compat-5.1.lua together with RRDtool.
if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then

View File

@ -0,0 +1,15 @@
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index bdfee3b..6d34847 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -38,8 +38,8 @@ install-data-local:
&& ( cd ${builddir}/python \
&& env BUILDLIBDIR=${abs_top_builddir}/src/.libs \
$(PYTHON) ${abs_srcdir}/python/setup.py install \
- --skip-build --prefix=$(DESTDIR)$(prefix) \
- --exec-prefix=$(DESTDIR)$(exec_prefix) ) \
+ --skip-build --root=$(DESTDIR) --prefix=$(prefix) \
+ --exec-prefix=$(exec_prefix)) \
|| true
# rules for building the ruby module

View File

@ -0,0 +1,26 @@
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index 76e9144..bdfee3b 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -30,8 +30,9 @@ install-data-local:
&& $(MAKE) install ) \
|| true
$(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
- && ( cd ${builddir}/ruby \
- && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install ) \
+ && ( $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ${builddir}/ruby \
+ && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) \
+ hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install ) \
|| true
$(AM_V_GEN)test -d ${builddir}/python/build \
&& ( cd ${builddir}/python \
@@ -52,7 +53,8 @@ ruby:
EPREFIX=$(exec_prefix) \
ABS_TOP_SRCDIR=${abs_top_srcdir} \
ABS_TOP_BUILDDIR=${abs_top_builddir} \
- $(RUBY_MAKE_OPTIONS) RUBYARCHDIR= )
+ $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" \
+ rubyhdrdir="$(includedir)" includedir="$(includedir)" RUBYARCHDIR= )
# rules for building the pyton module
python:

View File

@ -16,8 +16,8 @@
Summary: Round Robin Database Tool to store and display time-series data
Name: rrdtool
Version: 1.4.9
Release: 4%{?dist}
Version: 1.5.0
Release: 1%{?dist}
License: GPLv2+ with exceptions
Group: Applications/Databases
URL: http://oss.oetiker.ch/rrdtool/
@ -26,21 +26,23 @@ Source1: php4-%{svnrev}.tar.gz
Patch1: rrdtool-1.4.4-php54.patch
# disable logo for php 5.5.
Patch2: rrdtool-1.4.7-php55.patch
Patch3: rrdtool-1.4.7-ruby-2-fix.patch
Patch4: rrdtool-1.4.9-autoconf-fix.patch
Patch5: rrdtool-1.4.9-lua-5.2.patch
# patch sent upstream
Patch7: rrdtool-1.4.9-doc-fix.patch
Patch3: rrdtool-1.5.0-ruby-2-fix.patch
Patch4: rrdtool-1.5.0-lua-5.2.patch
# enable php bindings on ppc
Patch8: rrdtool-1.4.8-php-ppc-fix.patch
Patch5: rrdtool-1.4.8-php-ppc-fix.patch
# sent upstream
Patch6: rrdtool-1.5.0-python-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: dejavu-sans-mono-fonts
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
BuildRequires: gcc-c++, openssl-devel, freetype-devel
BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
BuildRequires: cairo-devel >= 1.4.6, pango-devel >= 1.17
BuildRequires: libtool, groff
BuildRequires: gettext, libxml2-devel, libdbi-devel
BuildRequires: libtool, groff, python-setuptools
BuildRequires: gettext, libxml2-devel, libdbi-devel, systemd
BuildRequires: perl-ExtUtils-MakeMaker, perl-devel, automake, autoconf
%description
@ -147,9 +149,9 @@ The %{name}-ruby package includes RRDtool bindings for Ruby.
%endif
%if %{with_lua}
%{!?luaver: %define luaver %(lua -e "print(string.sub(_VERSION, 5))")}
%define lualibdir %{_libdir}/lua/%{luaver}
%define luapkgdir %{_datadir}/lua/%{luaver}
%{!?luaver: %global luaver %(lua -e "print(string.sub(_VERSION, 5))")}
%global lualibdir %{_libdir}/lua/%{luaver}
%global luapkgdir %{_datadir}/lua/%{luaver}
%package lua
Summary: Lua RRDtool bindings
@ -173,10 +175,9 @@ The %{name}-lua package includes RRDtool bindings for Lua.
%if %{?rhel} %{?!rhel:7} > 6
%patch3 -p1 -b .ruby-2-fix
%endif
%patch4 -p1 -b .autoconf-fix
%patch5 -p1 -b .lua-52
%patch7 -p1 -b .doc-fix
%patch8 -p1 -b .php-ppc-fix
%patch4 -p1 -b .lua-52
%patch5 -p1 -b .php-ppc-fix
%patch6 -p1 -b .python-fix
# Fix to find correct python dir on lib64
%{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
@ -196,8 +197,11 @@ The %{name}-lua package includes RRDtool bindings for Lua.
# workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
cp -p /usr/lib/rpm/config.{guess,sub} php4/
# Add missing VERSION (reported upstream)
echo %{version} > VERSION
%build
./autogen.sh
./bootstrap
%configure \
--with-perl-options='INSTALLDIRS="vendor"' \
--disable-rpath \
@ -228,7 +232,7 @@ cp -p /usr/lib/rpm/config.{guess,sub} php4/
# Remove Rpath from Ruby
%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
bindings/ruby/extconf.rb
sed -i 's| extconf.rb| extconf.rb --vendor |' bindings/Makefile
sed -i 's|extconf.rb \\|extconf.rb --vendor \\|' bindings/Makefile
%endif
# Force RRDp bits where we want 'em, not sure yet why the
@ -262,7 +266,6 @@ find examples/ -name "*.pl" \
-exec %{__perl} -pi -e 's|\015||gi' {} \;
%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR="$RPM_BUILD_ROOT" install
# Install the php module
@ -317,17 +320,27 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%endif
%clean
%{__rm} -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
%systemd_post rrdcached.service rrdcached.socket
%post -p /sbin/ldconfig
%preun
%systemd_post rrdcached.service rrdcached.socket
%postun -p /sbin/ldconfig
%postun
/sbin/ldconfig
%systemd_post rrdcached.service rrdcached.socket
%files
%defattr(-,root,root,-)
%doc CONTRIBUTORS COPYRIGHT TODO NEWS CHANGES THREADS
%exclude %{_docdir}/examples
%exclude %{_docdir}/doc2/html
%exclude %{_docdir}/doc2/txt
%{_bindir}/*
%{_libdir}/*.so.*
%{_unitdir}/rrdcached.service
%{_unitdir}/rrdcached.socket
%{_datadir}/%{name}
%{_mandir}/man1/*
@ -338,9 +351,9 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
# License file is missing, upstream was notified
%files doc
%defattr(-,root,root,-)
%doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
%doc examples doc2/html doc2/txt
%files perl
@ -390,6 +403,13 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%endif
%changelog
* Mon Apr 20 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 1.5.0-1
- New version
Resolves: rhbz#1213035
- Dropped autoconf and doc-fix patches (all upstreamed)
- Included systemd rrdcached service and socket from upstream
- General documentation (like NEWS) moved to basic package
* Mon Jan 19 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.4.9-4
- Again rebuild for ruby 2.2

View File

@ -1,2 +1,2 @@
1cea5a9efd6a48ac4035b0f9c7e336cf rrdtool-1.4.9.tar.gz
bfdd4347720c67e9e4d8d4e80ba2610d rrdtool-1.5.0.tar.gz
28074a9c368af013462631959ab90558 php4-r1190.tar.gz