rrdtool/rrdtool-1.4.7-ruby-2-fix.patch
Jaroslav Škarvada 5dfb97a503 Fixed autoconf (by autoconf-fix patch)
- Added support for aarch64
  Resolves: rhbz#926455
2013-03-26 20:44:26 +01:00

22 lines
1.5 KiB
Diff

diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index c4fdc10..247fe58 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -22,14 +22,12 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
$(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
$(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
- $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ $(AM_V_GEN)test -f ruby/Makefile && $(MKDIR_P) $(DESTDIR)$(libdir)/ruby/vendor_ruby && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)" install || true
$(AM_V_GEN)test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
# rules for building the ruby module
-# RUBYARCHDIR= is to work around in a makefile quirk not sure
-# it is is the right thing todo, but it makes rrdtool build on freebsd as well
ruby: Makefile
- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) RUBYARCHDIR=
+ cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) hdrdir="$(includedir)" rubyhdrdir="$(includedir)" includedir="$(includedir)"
# rules for building the pyton module
python: Makefile