Fixed autoconf (by autoconf-fix patch)

- Added support for aarch64
  Resolves: rhbz#926455
This commit is contained in:
Jaroslav Škarvada 2013-03-26 20:44:26 +01:00
parent c26af4989f
commit 5dfb97a503
3 changed files with 43 additions and 6 deletions

View File

@ -0,0 +1,28 @@
diff --git a/configure.ac b/configure.ac
--- ./configure.ac.o 2012-01-24 11:08:48.000000000 +0100
+++ ./configure.ac 2013-03-26 20:34:06.722121427 +0100
@@ -782,7 +782,7 @@
done
fi
- LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+ LUA_RRD_LIBDIR="$libdir/lua/$lua_vdot"
# if lua 5.0 can't find compat-5.1, force installation of
# compat-5.1.lua together with RRDtool.
if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then
diff --git a/bindings/tcl/Makefile.am b/bindings/tcl/Makefile.am
index c0e8b0f..265191d 100644
--- a/bindings/tcl/Makefile.am
+++ b/bindings/tcl/Makefile.am
@@ -27,8 +27,9 @@ tclpkgdir = @TCL_PACKAGE_DIR@
tclpkg_DATA = pkgIndex.tcl
tclpkg_SCRIPTS = ifOctets.tcl
else
-pkglib_DATA = pkgIndex.tcl
-pkglib_SCRIPTS = ifOctets.tcl
+pkgindexdir = $(pkglibdir)
+pkgindex_DATA = pkgIndex.tcl
+pkgindex_SCRIPTS = ifOctets.tcl
endif
# Automake doen't like `tclrrd$(VERSION)$(TCL_SHLIB_SUFFIX)' as

View File

@ -1,7 +1,8 @@
diff -up rrdtool-1.4.7/bindings/Makefile.in.origs rrdtool-1.4.7/bindings/Makefile.in
--- rrdtool-1.4.7/bindings/Makefile.in.origs 2012-01-24 11:09:10.000000000 +0100
+++ rrdtool-1.4.7/bindings/Makefile.in 2013-03-18 14:48:23.074370021 +0100
@@ -659,14 +659,12 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COM
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index c4fdc10..247fe58 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -22,14 +22,12 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
$(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
$(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true

View File

@ -18,7 +18,7 @@
Summary: Round Robin Database Tool to store and display time-series data
Name: rrdtool
Version: 1.4.7
Release: 13%{?dist}
Release: 14%{?dist}
License: GPLv2+ with exceptions
Group: Applications/Databases
URL: http://oss.oetiker.ch/rrdtool/
@ -29,6 +29,7 @@ Patch1: rrdtool-1.4.4-php54.patch
Patch2: rrdtool-1.4.7-ruby-2-fix.patch
# disable logo for php 5.5.
Patch3: rrdtool-1.4.7-php55.patch
Patch4: rrdtool-1.4.7-autoconf-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: dejavu-sans-mono-fonts, dejavu-lgc-sans-mono-fonts
@ -37,7 +38,7 @@ BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
BuildRequires: cairo-devel >= 1.4.6, pango-devel >= 1.17
BuildRequires: libtool, groff
BuildRequires: gettext, libxml2-devel
BuildRequires: perl-ExtUtils-MakeMaker, perl-devel
BuildRequires: perl-ExtUtils-MakeMaker, perl-devel, automake, autoconf
%description
RRD is the Acronym for Round Robin Database. RRD is a system to store and
@ -169,6 +170,7 @@ The %{name}-lua package includes RRDtool bindings for Lua.
%patch3 -p1 -b .php55
%endif
%patch2 -p1 -b .ruby-2-fix
%patch4 -p1 -b .autoconf-fix
# Fix to find correct python dir on lib64
%{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
@ -189,6 +191,7 @@ The %{name}-lua package includes RRDtool bindings for Lua.
cp -p /usr/lib/rpm/config.{guess,sub} php4/
%build
./autogen.sh
%configure \
--with-perl-options='INSTALLDIRS="vendor"' \
--disable-rpath \
@ -381,6 +384,11 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
%endif
%changelog
* Tue Mar 26 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 1.4.7-14
- Fixed autoconf (by autoconf-fix patch)
- Added support for aarch64
Resolves: rhbz#926455
* Mon Mar 25 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 1.4.7-13
- Fixed build failure
Resolves: rhbz#926037