25 lines
1.8 KiB
Diff
25 lines
1.8 KiB
Diff
diff -urp rrdtool-1.2.21.orig/bindings/Makefile.am rrdtool-1.2.21/bindings/Makefile.am
|
|
--- rrdtool-1.2.21.orig/bindings/Makefile.am 2007-05-01 16:42:02.000000000 -0400
|
|
+++ rrdtool-1.2.21/bindings/Makefile.am 2007-05-02 10:38:19.000000000 -0400
|
|
@@ -20,7 +20,7 @@ install-data-local:
|
|
test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
|
|
test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
|
|
test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
|
|
- test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(prefix) --exec-prefix=$(exec_prefix) || true
|
|
+ test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
|
|
|
|
# rules for buildung the ruby module
|
|
ruby:
|
|
diff -urp rrdtool-1.2.21.orig/bindings/Makefile.in rrdtool-1.2.21/bindings/Makefile.in
|
|
--- rrdtool-1.2.21.orig/bindings/Makefile.in 2007-05-01 16:42:26.000000000 -0400
|
|
+++ rrdtool-1.2.21/bindings/Makefile.in 2007-05-02 10:38:38.000000000 -0400
|
|
@@ -542,7 +542,7 @@ install-data-local:
|
|
test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
|
|
test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
|
|
test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
|
|
- test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(prefix) --exec-prefix=$(exec_prefix) || true
|
|
+ test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
|
|
|
|
# rules for buildung the ruby module
|
|
ruby:
|